locked
connecting to MSDE 2000 from different system RRS feed

  • Question

  • i have developed an application using VB2008. the database used is MSDE 2000. the MSDE is installed on SYSTEM1. the same SYSTEM1 is used for the development. now I want to use the application on SYSTEM2 and use the same database instance that is on SYSTEM1. my connection string is

    "Integrated Security=false;Persist Security Info=true;Initial Catalog=dbname;Data Source=SYSTEM1;user id=sa"

    when running the app from SYSTEM2, I get the error "Login fail for user SYSTEM1/Guest". I tried various variation of connection string with different parameters, but I continue to get the error. I somehow tried to corner the reason for this error, and found that it is trying to connect to the database on SYSTEM1 using the Guest account of OS of SYSTEM1. I dont understand why that is happening.

    One thing more that I doubt is the .NET framework on SYSTEM2. can anybody put some light on that.

    another hint... I tried to connect to the database installed on SYSTEM1 from SYSTEM2 thru the ODBC by adding new data source, and it connects perfectly from there using the SQL Authentication with sa as the username. but if I use WinNT Authentication, it gives me an almost a similar error. this is all I have been trying to do, but no solution yet. Please help.

    Somebody please give solution.

    • Moved by Chao Kuo Monday, August 9, 2010 11:57 AM (From:Visual Basic General)
    Monday, August 2, 2010 6:35 PM

Answers

  • Hello,

    For sql server issue, please post here http://social.msdn.microsoft.com/Forums/en/sqldataaccess/threads.

    This forum is could be more specific about your issue.

    Thanks

    Chao

     

     


    Please unmark it if it does not help, and mark it if it helps.
    • Marked as answer by dips92 Tuesday, August 10, 2010 10:54 AM
    Thursday, August 5, 2010 7:14 AM
  • Also, I would recommend upgrading to SQL Server Express if possible. MSDE is not supported beyond Windows XP and 2003.
    Paul ~~~~ Microsoft MVP (Visual Basic)
    • Marked as answer by dips92 Tuesday, August 10, 2010 10:54 AM
    Thursday, August 5, 2010 9:02 AM

All replies

  • Hello,

    For sql server issue, please post here http://social.msdn.microsoft.com/Forums/en/sqldataaccess/threads.

    This forum is could be more specific about your issue.

    Thanks

    Chao

     

     


    Please unmark it if it does not help, and mark it if it helps.
    • Marked as answer by dips92 Tuesday, August 10, 2010 10:54 AM
    Thursday, August 5, 2010 7:14 AM
  • Also, I would recommend upgrading to SQL Server Express if possible. MSDE is not supported beyond Windows XP and 2003.
    Paul ~~~~ Microsoft MVP (Visual Basic)
    • Marked as answer by dips92 Tuesday, August 10, 2010 10:54 AM
    Thursday, August 5, 2010 9:02 AM
  • Thanks for the link. However, I tried to find the root of the problem and found it well. There was another [old] form which was no more in use, but was kept for some references. That form was bound with an old connection string, which was giving the problem. Now it is OK.

    The link is surely helpful, for many other problems, that I may come across.

    Tuesday, August 10, 2010 10:57 AM
  • Hello Paul,

    This is a good hint that I should be upgrading the database, if the application has to run beyond XP. I will do that and test the app.

    Tuesday, August 10, 2010 10:59 AM