none
Frozen Windows 10 Mail

    Question

  • Windows 10 Mail has been working perfectly till August 6 2015 after launch on July 29, 2015

    However, from August 6, my Windows Mail 10 has a completely frozen screen, not able to navigate whatsoever, the Windows 10 Mail will launch but no task are accomplished.

    Have Logged Out of my system completely twice, without any success.

    I now await further help in this matter

    JP NCL :(

    Friday, August 7, 2015 8:36 AM

Answers

All replies

  • I'd try them over here.

    http://answers.microsoft.com/en-us/windows/forum/apps_windows_10-outlook_mail?sort=lastreplydate&dir=desc&tab=threads&status=all&mod=&modAge=&advFil=&postedAfter=&postedBefore=&threadType=all&tm=1438949744930

     

     

     

     


    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows]

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees , and confers no rights.

    Friday, August 7, 2015 12:18 PM
    Moderator
  • Fixed by right clicking start icon

    open control panel then open region

    select your correct format  ...ex. United States English

    then reboot

    Worked for me.

    Friday, August 7, 2015 7:19 PM
  • Mine worked until 8 August then absolutely frozen. Was not doing anything else, just came to check emails and nothing would open.  Able to check them through Gmail, so not an internet problem. Tried resetting computer 3x, and killing Mail through TaskManger - no change. Followed advice below about changing region - no change. 

    What next?

    Saturday, August 8, 2015 10:24 AM
  • I succeeded in getting Mail to work again by restoring the system to a restore point 2 days previous - then turnig off automatic updates!
    Saturday, August 8, 2015 11:26 AM
  • I have exactly the same problem in every detail. Spent an hour and a half at PC World this morning who have been unable to find a remedy. Seems like a Microsoft issue since several people seem to be having this problem. Come on Microsoft- GET IT SORTED
    Monday, August 10, 2015 3:49 PM
  • I have exactly the same problem in every detail. Spent an hour and a half at PC World this morning who have been unable to find a remedy. Seems like a Microsoft issue since several people seem to be having this problem. Come on Microsoft- GET IT SORTED

    Follow the advice in the proposed answer above.

    This forum is not for technical support.


    Monday, August 10, 2015 3:51 PM
  • Thank you! This worked although I was unable to change the format. However I just clicked the panel with the format in it and then rebooted and - Hey Presto Mail is working. Incidentally I had a similar problem with Calendar and this seems to have fixed that also.
    Monday, August 10, 2015 4:06 PM