locked
Address book is not sync RRS feed

  • Question

  • ---------------------------
    Office Communications Server 2007 Public Beta
    ---------------------------
    Cannot synchronize with the corporate address book. The cause of the problem is unknown. Please contact your system administrator with this information.

     

    How do i get it to work?

    Monday, April 2, 2007 1:25 PM

Answers

  • Hello,

     

    On the computer that is hosting the Communicator 2007 client. Log out of OC 2007 and completely close OC 2007 then locate C:\Documents and Settings\username\Local Settings\Application
    Data\Microsoft\Communicator\GalContacts.db - remove the GalContacts.db ad then restart OC 2007. Hopefully this will allow the client to recreate GalContacts.db  and sync with the addressbook share.

     

    Thanks,

     

    Mike Adkins  OCS beta support team

    Thursday, April 26, 2007 11:15 PM

All replies

  • We had to force the first syncronization using the following command:

     

    <install path>\Server\Core\ABServer.exe -snycNow

     

    Hope that helps.

    Friday, April 6, 2007 1:25 PM
  • Dont think it worked for me.  I am having the same problem.  Here is the output after I ran the command you specified:

     

    D:\Program Files\Office Communicator Server 2007\Server\Core>ABServer.exe -snycNow
    Usage: ABServer [-?] [-regenUR | -syncNow | -dumpFile input-file [output-file] |
                     -testPhoneNorm [phone-number] |
                     -dumpRules|
                     -validateDB
                    ]

    D:\Program Files\Office Communicator Server 2007\Server\Core>

     

    In my event log I am receivng logs showing the following:

     

    Event Type: Information
    Event Source: OCS Address Book Server
    Event Category: (1008)
    Event ID: 21058
    Date:  4/6/2007
    Time:  1:34:26 AM
    User:  N/A
    Computer: GALAXY01
    Description:
    Synchronization Pass Summary for Device Address Book files

    Number of organization units: 1
    Number of Full files written: 1 with 72 total contacts
    Number of Delta files written: 8 with a total of 0 new/updated contacts and 0 deleted contacts.
    Number of bytes written: 15,172 compressed to 7,829 bytes on disk.

     

    So it seems like synchronization is happening but in communicator I still get the message stating it cannot synch.

    Friday, April 6, 2007 5:29 PM
  • Just realized I mispelled the -syncNow option and ran the command successfully but to no avail.  The event logs are the same as if the synchronization had always been working but my communicator is still receving the same error.

     

    HELP!

    Tuesday, April 10, 2007 1:34 PM
  • Hi Christian Grams,

    Can you let us know the status of your issue? Have you been able to solve it? If so, can you share your fix with the forums? If not, please let us know asap.

    Thursday, April 26, 2007 10:57 PM
  • Hello,

     

    On the computer that is hosting the Communicator 2007 client. Log out of OC 2007 and completely close OC 2007 then locate C:\Documents and Settings\username\Local Settings\Application
    Data\Microsoft\Communicator\GalContacts.db - remove the GalContacts.db ad then restart OC 2007. Hopefully this will allow the client to recreate GalContacts.db  and sync with the addressbook share.

     

    Thanks,

     

    Mike Adkins  OCS beta support team

    Thursday, April 26, 2007 11:15 PM
  • Hello,

    There could be several reasons why this is failing.  I would first suggest collecting client logs while reproducing the problem.

    Please set the following registry key on the client machine:

    \HKEY_Current_user\software\microsoft\tracing\uccp\communicator\
    enablefiletracing  Set this key to 1

    At that point, exit Office Communicator completely and then go back in and wait for the error to come back.  A log file should be generated in the %userprofile%\tracing folder.  That log along with running the Validation Wizard on the Front End server will likely point to what the issue is.

    Monday, April 30, 2007 6:18 PM
  • Mike,

    Your suggestion about deleting the GalContacts.db seems to work which validates the abs website is functioning properly.  I am also able to validate the address book itself is updating with the abserver utility by both forcing the update (instead of waiting until 1:30AM) as well as dumping the database contents.  The issue is that the client seemingly never updates the galcontacts.db without deleting it via your suggestion.

    One thing I noticed is that there seems to be 2 versions of the client available - one dated April 2nd with a size of 12,812,800 bytes and the other from the public website dated late March with a size of 12,805,632.  Using the newer client didn't seem to help much at all though there is no description as to any difference between the 2

    So overall, what mechanism may be breaking which would not allow delta updates to the galcontacts.db?  I do have logging running if you are interested in looking at any logs.

    Thanks

    Tom

     

    Thursday, May 3, 2007 2:01 PM
  • I have done a number of the tasks posted and nothing works. My clients still cannot get to the address book.

    In IIS default website > conf > int is empty. The folder is also empty. It only contains a tshoot.htm file.

     

    this is the local path for the virtual directory.

    E:\Office Communications Server 2007\Web Components\Conf\Int

     

    this is the path that actually contains dabs files

    E:\Office Communications Server 2007\Web Components\Address Book Files

     

    Any suggestions?

    Friday, May 4, 2007 3:37 PM
  •  Mike Adkins569243 wrote:

    Hello,

    On the computer that is hosting the Communicator 2007 client. Log out of OC 2007 and completely close OC 2007 then locate C:\Documents and Settings\username\Local Settings\Application
    Data\Microsoft\Communicator\GalContacts.db - remove the GalContacts.db ad then restart OC 2007. Hopefully this will allow the client to recreate GalContacts.db and sync with the addressbook share.

    Thanks,

    Mike Adkins OCS beta support team




    Hi

    I'm also having the same problem, but cannot find "C:\Documents and Settings\username\Local Settings\Application Data\Microsoft\Communicator\GalContacts.db" file.
    I'm having only History Spooler and CEIP folders in C:\Documents and Settings\username\Local Settings\Application Data\Microsoft\Communicator .

    Boris
    Thursday, May 17, 2007 8:23 AM
  • I'm also having this issue,

     

     

    C:\Documents and Settings\username\Local Settings\Application Data\Microsoft\Communicator does not have any addressbook file in it. I will try some of the other tasks posted here and report back after.

     

    [edit] I have found that my default website was stopped, and another website was running on port 80. I've added the /abs/Int and /abs/Ext virtual directories to it so that they are accessable via the web. Still no luck so far, but I'll keep trying.

     

    [edit 2] That was almost it, I had to add the MIME types as well to the new website. Totally my fault for running a non default website

     

    MIME type

    .dabs

    application/dabs

     

    .lsabs

    application/lsabs

    Tuesday, May 22, 2007 5:07 PM
  • I am also having the same problem but manage to solve it with this.

     

    1) Enable directory browsing for ABS\Ext and ABS\Int

    2) Disable SSL for EXT and INT virtual directory.

    Thursday, May 24, 2007 4:54 AM
  • I have tried all of the above but it still does not work.

     

    When i run the syncnow command nothing happens, it reports that it has submitted successfully, but nothing.  No file in the directory, no entry in the event viewer, nothing.

     

    Do you have any ideas please?

     

    Thanks.

    Wednesday, May 30, 2007 8:24 PM
  • I have the same problems, i have tried all the solutions regarding the address book sync issues but still have the problem. Any help would be appreciated.
    Monday, June 4, 2007 12:36 PM
  • I have managed to solve the problem, within IIS right click the 'Int' folder and change the details in the Connect As section. I have change this to the local administrator login. If anyone can tell me what this should be i would be grateful, but at present my address book is synchronizing without any problems.
    Wednesday, June 6, 2007 2:52 PM
  • Could you be a bit more specific as to "details" and "connect as" regarding the Int folder in the IIS Admin console?

    I am left in the same boat with the OCS/OC RC version where after deleting the local copy of GalContacts.db, running "ABServer.exe -syncNow" and no amount of restarting client and backend components will bring GalContacts.db back to life.

    Thanks.

    Monday, June 11, 2007 1:31 PM
  • I see what the problem is for you.

     

    The Address book server uses RTCGuestAccessUser as the user for connecting to the virtual directory on the IIS server.

     

    What probably happened is the password expired for this account - and yet it does not generate any errors for you.

     

    Change the user back to <DOMAIN>\RTCGuestAccessUser under "Connect As" for the INT directory, and go into

    AD users and computers and change the account settings to "Password never Expires" under the account tab.

     

    LCS 2005 / 2003  also had the same problem with service accounts set to expire (which is a good thing in a highly

    secure environment I suppose), which caused issues with the service not restarting after a reboot.

     

    Cheers.

     

    - Steve

     

     

    Friday, June 22, 2007 5:00 PM
  • If all else fails, try this. This helped me with my issues with OCS communication between client and address book.

     

    Please see http://forums.microsoft.com/OCS2007/ShowPost.aspx?PostID=2175599&SiteID=57 for my troubleshooting that helped with Outlook Sync errors.
     
    Good luck.
    Friday, October 5, 2007 4:56 AM
  • We are getting a "cannot synchronize address book information" error but we can still go add contacts and all of the contacts are listed. We just have a yellow triangle with an exclamation point that worries some of our users. Any ideas on how to fix that.

    Friday, November 9, 2007 8:38 PM
  •  

    i am probably re-iterating that at this point, just in case it has not been said... here it is

     

    Copy the Cert of your local CA or whichever CA you are using to the client machine and see if that helps. If that works, you can use Group Policy to distribute that certificate to everyone.

     

    Hope this helps.

    Saturday, December 1, 2007 8:50 AM
  •  

    It should be connecting as RTCGuestAccessUser account to download the address book. It's probably not a good idea to leave it as the Local Admin, as this does allow higher priviledges than necessary.
    Thursday, December 13, 2007 12:10 AM
  • i also face the same issue before. what i did is,i just uninstall the OCS server. don't worry,even it already uninstalled...but when you reinstall the server it still get the same setting as previous. reinstall your server and it will take less than 30 minutes. then your address book will be ok. seriously!
    Monday, January 7, 2008 2:47 AM
  •  Mike Adkins569243 wrote:

    Hello,

     

    On the computer that is hosting the Communicator 2007 client. Log out of OC 2007 and completely close OC 2007 then locate C:\Documents and Settings\username\Local Settings\Application
    Data\Microsoft\Communicator\GalContacts.db - remove the GalContacts.db ad then restart OC 2007. Hopefully this will allow the client to recreate GalContacts.db  and sync with the addressbook share.

     

    Thanks,

     

    Mike Adkins  OCS beta support team

     

    This file doesn't exist where you said it should be.  I've tried "Abserver -syncnow."  I've made sure WMI settings for MSFT_SIPAddressBookSetting properties are correct; my Default Website settings are correct; We have a certificate assigned to the Front End Server.  What else can I check.

     

    I've been up and down the Internet for ideas with no avail.

     

    Wednesday, March 5, 2008 4:48 PM
  •  Steven Hahn wrote:

    I see what the problem is for you.

     

    The Address book server uses RTCGuestAccessUser as the user for connecting to the virtual directory on the IIS server.

     

    What probably happened is the password expired for this account - and yet it does not generate any errors for you.

     

    Change the user back to <DOMAIN>\RTCGuestAccessUser under "Connect As" for the INT directory, and go into

    AD users and computers and change the account settings to "Password never Expires" under the account tab.

     

    LCS 2005 / 2003  also had the same problem with service accounts set to expire (which is a good thing in a highly

    secure environment I suppose), which caused issues with the service not restarting after a reboot.

     

    Cheers.

     

    - Steve

     

     

     

    I cannot find this.

    Wednesday, March 5, 2008 5:07 PM
  •  

    The only time the "CONNECT AS" option shows up is if you are connecting to another computer.

    If it local, then you are running into a different issue.

     

    Check under IIS, under Default Web Site / ABS / Ext / Files,  and Default Web Site / ABS / INT /  Files.

     

    Go to the properties of each and make sure they are pointing to the correct location as well as using the

    RTCGuestAccessUser account.   (The permissions should be set up correctly on the remote server, if indeed

    you are storing the ABS files remotely.)

     

    I'm thinking if you have (2) Front Ends, the Defeault Web Site / ABS / INT  and ABS / EXT may point to a remote site too...but I haven't played with this for a bit.  

     

    Cheers.

     

    - Steve

     

    Wednesday, March 5, 2008 6:06 PM
  • Hello Steve.

     

    I am configuring IIS locally so I don't see "CONNECT AS" as you mentioned.  The RTCGuestAccessUser is not in our Active Directory.  Do I need to create this account?  If so, what groups does this account need to be a part of?  As of now, the only user listed is IWAM_%COMPUTERNAME% as the user for each of the folders you listed.

     

    Also, we are using Exchange Server 2003.  I saw an article that stated that you may need Exchange 2007 for OCS 2007 to work properly.

     

    http://forums.microsoft.com/unifiedcommunications/ShowPost.aspx?PostID=2274628&SiteID=57

     

    Wednesday, March 5, 2008 6:33 PM
  • I'm sorry about that.  The user is IUSR_%COMPUTERNAME%, not IWAM.  Smile

     

    Wednesday, March 5, 2008 6:39 PM
  • The RTCGuestAccessUser should have been created automatically.   I don't remember manually adding it anywhere when I was setting up OCS.

     

    RTCService, RTCWebService, RTCCompontent Service, CWA Service are just a few of the accounts created.

    There are at least 10 RTCUniversal Groups created as well that should  be visible in Active Directory.

     

    Exchange 2007 is needed if you want to use Exchange 2007's Unified Messaging to work with OCS....you can use Instant Messaging / VOIP / Web conferencing without it...but UM is kinda the "big thing".

     

    Exchange 2007 SP1 is what you need for UM and OCS integration to work.  (If you download the documentation, it goes into great detail on setting this up - multiple steps required).

     

    I'm also pretty sure I was working with the beta back when I wrote this answer - so I'm not sure if things changed for these settings as well.   But it is always  a good idea to check the service accounts and make sure the passwords have not expired.  (And certficiates - on both servers if running MTLS - the 2nd server usually gets you...)

     

    Cheers.

     

    - Steve

     

     

     

     

     

    Wednesday, March 5, 2008 6:51 PM
  • Thanks for the info.

     

    I only can find the Universal Groups you mentioned.   No user accounts and all the groups are all empty.  I created a user called RTCService before the initial setup.  Is RTCGuestAccessUser important to Address Book synchronization or can we use another account?

    Wednesday, March 5, 2008 7:00 PM
  • Maybe you should just check out the final docs:

     

    http://www.microsoft.com/downloads/details.aspx?FamilyId=760A3FF9-7F82-4A5F-841D-5E528B1DA334&displaylang=en

     

    Look at the OCS-ADGUIDE.DOC for more info about the RTC groups.

     

    The Enterprise Edition Deployment guide says more about the RTCGuestUser account.

     

    See the "OCS_Planning_Guide" for info about Exchange 2007 SP1 + OCS.

     

    (I generally print out the Planning and Deployment guides before implementing these products...

    .....too many changes between 2003 / 2005 / and OCS...)

     

    Cheers.

     

    - Steve

    Wednesday, March 5, 2008 7:31 PM
  • Maybe this will help as well...

     

    I finished setting up OCS 2007 and the first few clients were great. I thought I was done and could go home, but noticed that our receptionist couldn't sync the address book - same errors and all the fixes suggested didn't do a thing. It worked on several PCs so the problem had to be LOCAL to the PC.

     

    After looking closely, I realized that I had McAfee Ent Edition configured to block access to address books. I know that seems too simple, but it might save somebody a few hours of searching for the needle in the proverbial haystack. Once I changed those settings, everything else has worked great!

     

    Jay

    Tuesday, May 13, 2008 5:46 AM
  • Another possible solution: Communicator clients would not sync address book and the web components validation tool failed for the address book.  In IIS, I changed the Int\Handler local path from C:\Program Files\Microsoft Office Communications Server 2007\Web Components\Address Book Files\Int\Handler to L:\addressbookfolder (location of my address book). Clients now download the files using SSL, without anonymous authentication.  I hope this helps someone else!

    Tuesday, May 13, 2008 3:50 PM