locked
Enable Rule not working on HomePage Grid's custom button after migrating to CRM 2013 OnPremise RRS feed

  • Question

  • Hi,

    We just migrated from CRM 2011 On Premise to CRM 2013 On Premise and we observe that Enable Rule is not working on HomePage Grid's custom button in Command bar. Let me explain the scenario in details.

    On Case Entity(On HomePage Grid), we have a custom button which has a Enable Rule and we are calling JavaScript function from Custom Rule.

    When opening the case HomePage Grid, Enable Rule functionality is not working until unless I click on "MORE COMMANDS" on Command Bar. On HomePage Grid, we are calling a JavaScript function to colored the grid records.

    Can anybody tell me why it is not working during initial load of HomePage Grid?? Is there any work around for same??

    Thanks in Advance  :)

    Thanks,

    Arvind


    Regards, Arvind

    Thursday, February 20, 2014 12:11 PM

Answers

  • Hi All,

    I removed  the old ribbon button(from CRM 2011 ) and added new button, Enable Rule with Custom Rule which solve my issue.

    Thank you all for your help.

    Thanks,
    Arvind Singh


    Regards, Arvind

    • Marked as answer by ArvindSingh Wednesday, February 26, 2014 10:17 AM
    Wednesday, February 26, 2014 10:17 AM

All replies

  • hi

    Sounds like a weird scenario.

    Just to cross-check, your 2013 is on Rollup 1 ? initial version had some weird bugs which were fixed in rollup1. and so far i think rollup 1 is very stable.


    Thursday, February 20, 2014 12:33 PM
  • No, we have not yet installed Rollup 1.

    Thanks,
    Arvind Singh


    Regards, Arvind

    Thursday, February 20, 2014 1:19 PM
  • I will suggest install it and see if issue still remains
    Thursday, February 20, 2014 2:30 PM
  • Hi Arvind,

    I have tried to make it work in CRM 2013 when we migrated from CRM 2011 and I was not able to do it either.

    As far as I know, the EnableRule doesnt work in CRM 2013, meaning you cannot have a ribbon button in disabled mode on the command bar. The command bar only shows enabled buttons at all times. You can only make it visible/invisible by changing its DisplayRule.

     

    @Experts - Please correct me if I am wrong :)

     

    Thanks,
    Swaroop

    Friday, February 21, 2014 1:14 AM
  • Thank you for reply Swaroop, I will try that way and let you know.

    Thanks,
    Arvind Singh


    Regards, Arvind

    Friday, February 21, 2014 5:02 AM
  • Hello Arbind,

    As swaroop said, you won't be able to see disable buttin in MS CRM 2013, in MS CRM 2013 disable means hidden, but you should be able to see your button in case your validation is true.


    Our Website | Our Blog | Follow US | My Facebook Page | Microsoft Dynamics CRM 2011 Application Design
    Make sure to "Vote as Helpful" and "Mark As Answer",if you get answer of your question.

    Friday, February 21, 2014 6:28 AM
    Moderator
  • Hi Mahender,

    Thank you for reply. I have enable the button by returning true value always..I can see the button in More Commands(...) but I am calling a JavaScript function using Custom Rule and that JavaScript function is only working when I am clicking on "MORE COMMANDS". As per my requirement It should work on load of HomePage Grid as mentioned in my first post.

    Hope I am able to explain the scenario.

    Thanks,
    Arvind Singh


    Regards, Arvind

    Friday, February 21, 2014 8:32 AM
  • Ok, I did not experience this, let me try this then I will update you.

    Our Website | Our Blog | Follow US | My Facebook Page | Microsoft Dynamics CRM 2011 Application Design
    Make sure to "Vote as Helpful" and "Mark As Answer",if you get answer of your question.

    Friday, February 21, 2014 9:03 AM
    Moderator
  • Hi All,

    I removed  the old ribbon button(from CRM 2011 ) and added new button, Enable Rule with Custom Rule which solve my issue.

    Thank you all for your help.

    Thanks,
    Arvind Singh


    Regards, Arvind

    • Marked as answer by ArvindSingh Wednesday, February 26, 2014 10:17 AM
    Wednesday, February 26, 2014 10:17 AM