Not reading discs RRS feed

  • Question


    I seem to be having a very weird problem with my Dell Dimension 4700. Yesterday i tried to install the game lord of the rings battle for middle earth 2 and i almost got through the installation, when at the last second it asked me to put the disc back in. I did and it didnt read it. It acted like i had no disc in the drive. I kept trying but it kept saying that. So i then tried puting other games in such as age of empires and battle for middle earth 1 and it wouldnt read those disks either. I've looked at the troubleshooters and i cant find any answers. Then the weirdest part of all when i put the game oblivion in the drive it shows up after a minutes in my computer. I don't understand what the problem is. When i first open oblivion it says that the disk isnt in also and then i click retry and it opens the game.

    I have also had a weird black screen show up when i frist start my computer. It says something about an error in a diskette drive and i have to press f1 to continue on or f2 to go into bios. ITs happened ever since i installed my nvidia geforve 8400 graphics card. I don't know whats wrong with it and i would appreciate any help i can get. thanks

    Sunday, March 30, 2008 10:49 PM


All replies