locked
This add-in is incompatible with the Data Execution Prevention mode and should be disabled... RRS feed

  • Question

  • I've seen this error twice now:

    "Outlook experienced a serious problem with the 'noreplyalladdin' add-in.  This add-in is incompatible with the Data Execution Prevention mode and should be disabled or upgraded to the latest version.  Do you wish to disable this add-in from loading?"

    Monday, June 4, 2012 10:32 PM

All replies

  • Hmmm, not seen that myself... What are your DEP settings - I have the default "Turn on DEP for essential Windows programs and services only" but perhaps you have the more stringent "Turn on DEP for all programs and services except those I select" - is that the case? (I'll turn on the latter and see what happens in any case.)

    A web search found http://social.msdn.microsoft.com/Forums/en-US/vsto/thread/7d145e1e-b948-4fea-9b41-743991f6f787and http://blogs.msdn.com/b/vsod/archive/2008/10/09/mappoint-and-data-execution-prevention-dep.aspx which might be relevant - if I can reproduce the error, I'll see if this makes a difference.

    BTW: the add-in certainly shouldn't be doing any weird execution stuff - there's nothing in there that has any need to execute code from a data segment.

    Tuesday, June 5, 2012 7:16 AM
  • I've been running with DEP turned on for several days now and have not seen this error yet. (Mind you, this is with Windows 8, both CP and RP.) Is there any more information you can supply about your setup that might help me reproduce the error?
    Wednesday, June 13, 2012 4:42 PM