locked
CRM 3.0 to 4.0 upgrade roadblock RRS feed

  • Question

  • I get the following error when it's searching the prerequisites(sp)

    objects added to the crm database conflict with objects crm 4.0 will add to the database


    HELP PLEASE!!!!
    david@withersdavid.com
    Sunday, November 9, 2008 7:16 PM

Answers

  • 1.  Have you done any advanced custiomization of the 3.0 database (added tables outside of the CRM interface, triggers, call-outs, etc?)

    2.  Have you added any custom indexes?  If so, you will need to drop these indexes prior to upgrade

    3.  Is this a warning that stops you from continuing, or is it just a warning.?

     

    I would recommend that you call Microsoft support--you will save yourself a lot of time and get the supported way to resolve this roadblock.

     

    Oh, and make sure that you back up your 3.0 database first as you might have to go back and try again.

    Monday, November 10, 2008 11:52 AM
    Moderator

All replies

  • 1.  Have you done any advanced custiomization of the 3.0 database (added tables outside of the CRM interface, triggers, call-outs, etc?)

    2.  Have you added any custom indexes?  If so, you will need to drop these indexes prior to upgrade

    3.  Is this a warning that stops you from continuing, or is it just a warning.?

     

    I would recommend that you call Microsoft support--you will save yourself a lot of time and get the supported way to resolve this roadblock.

     

    Oh, and make sure that you back up your 3.0 database first as you might have to go back and try again.

    Monday, November 10, 2008 11:52 AM
    Moderator
  •  Joel CustomerEffective wrote:

    1.  Have you done any advanced custiomization of the 3.0 database (added tables outside of the CRM interface, triggers, call-outs, etc?)

    Triggers yes


    2.  Have you added any custom indexes?  If so, you will need to drop these indexes prior to upgrade

    I inherited the system and i'm not 100% sure, I  have a feeling we may have custom indexes.


    3.  Is this a warning that stops you from continuing, or is it just a warning.?

    Nope this is the x of doom do not pass go do not collect $200.

     

    I would recommend that you call Microsoft support--you will save yourself a lot of time and get the supported way to resolve this roadblock.

    What's the number?

     

    Oh, and make sure that you back up your 3.0 database first as you might have to go back and try again.

    DID THIS, phew!!!!! Smile  but now we are stuck on sql server 2008.  YES 4.0 is officially supported my 2008.

    Monday, November 10, 2008 1:33 PM
  • I'm going to document this so no one else has this nightmare.

    Thanks to Danial at MS support!

    Existing server
    MS SQL 2000 sp4
    Windows Server 2003 ?r2?
    CRM 3.0

    Steps to get to 4.0 and SQL Server 2008:

    1. UPGRADE TO SQL SERVER 2005 (Even if you have to get a trial version)
    2. Launch the Upgrade to 4.0
    a. Remove anything in the log file that stops the upgrade (%appdata%\Microsoft\MSCRM\Logs)
    b. I had to remove SP, and some function on both DB's
    3. Complete Upgrade
    4. Upgrade SQL SERVER to 2008

    *2.a is HUGE!!!!!!!

    I'm still working through this but I'll let everyone know what the result is

    Withers

    **Thanks for the un-documented feature MS Smile
    ***MS Support if you find the right person is actually valuable, I know it's hard to believe but it's true.  Thanks Daniel
    Monday, November 10, 2008 9:27 PM