All client print jobs get stuck in WHS spooler RRS feed

  • Question

  • I have WHS with 2 XP Pro, 1 XP Home and 1 Vista home clients.
    I want to make WHS a printer server with my HP ColorLaser 1600. This printer has been functioning flawlessly as a shared printer mounted on the Vista computer a couple of years now.

    Well, I have tried to setup client printers in various ways according to different recommendations in this forum, but nothing works (- some of the Vista installations being extremely slow as seen by others).

    Setup using local port works fine, and local printout from WHS is fast and ok. Print jobs from clients however appear in the print queue quickly, but first job gets status "Printing" although nothing gets printed and then message in the status bar is: "Error processing command.".
    Attempt to delete the first print job from the print queue has no effect other than changing status to "Deleting - Printing". I have to go around services.msc to clear the spooler to make something happen. But if WHS is restarted and the deleted job is the Test Page,  it will actually be printed during startup!

    I have been careful to install separate drivers of equal edition.

    I suspect there is something wrong with the spooler?

    I would very much appreciate any help to sort this issue out.

    Tuesday, December 8, 2009 5:49 PM

All replies

  • I have noticed, that the printer driver on both WHS and Vista computers are based on the same HP-software, that is the

    HP Color LaserJet 1600 Plug and Play Package Version 20070627 from 20 oct. 2009

    And I wonder, if the installation on either machine is selecting the correct version of the driver, Windows Server 2003  and Windows Vista respectively?

    Is it possible, that this selection has to be manually controlled somehow? And if yes, then how is that done?


    Tuesday, December 8, 2009 9:29 PM
  • You may want to go to the HP support site and download "driver only" packages for your various operating systems. I'm pretty sure HP will have them for that printer; it's only a couple of years old after all.
    I'm not on the WHS team, I just post a lot. :)
    Tuesday, December 8, 2009 9:56 PM
  • Please note that there might be different sets of drivers on each machine, and HP printers (especially the host based ones) tend to have issues with this.
    I've had similar issues here at our office with some CLJ 3600 and SBS 2k3, only sollution was to unplug the printer and remove the driver from the server, remove the driver and all software from all clients.
    Make sure that the drivers are removed from the print server drivers list an both the server and all clients by (in XP) opening printers and faxes, in the menu open up print server properties and look at the drivers tab. (might be translated incorrectly, my system is in Swedish)

    Don't have vista around me right now, but I believe that the print server drivers are found in the control panel, admin tools.

    After that, install the driver on your server and make sure the printer is working correctly. If so, connect to the printer from one of your clients. Do not install the software by using the CD on your computer, your clients should receive the drivers from the server. If not, you might have to install more sets of drivers on your server.

    If you have problem deleting the print jobs, a batch like this should help (will temporarly disable all print sharing and delete the print jobs):

    net stop spooler
    del /Q C:\WINDOWS\system32\spool\PRINTERS\*.SHD
    del /Q C:\WINDOWS\system32\spool\PRINTERS\*.SPL
    net start spooler

    Wednesday, December 9, 2009 7:13 AM
  • Tank you Ken and Bjurran for your suggestions.

    Firstly I have found out, that the collection of drivers is the same for Windows Server 2003, XP and Vista.
    Secondly I have now explicitly installed the same package on my WHS, my Vista and one of the XP computers. And results are the same:

    First printjob in the queue gets stuck. If I then restart the printspooler on WHS with services.msc , all jobs are printed in sequence!

    I therefore still suspect the spool system to be the cause of my problems. In the HP Color LaseJet 1600 drivers package there is a file ZSPOOL.DLL - could this file possibly be bugged?

    By the way: If the Printers and Faxes window on WHS is open during these actions, this window is not updated. I have to close and reopen the window to se, that the queue is actually emptied (0 jobs at the printer icon). The same goes for the printer window with the specified list of printjobs.

    Could this clarification possibly trigger a final solution to my problem?

    Thursday, December 10, 2009 11:51 AM
  • Hi Martin,
    for network printers I usually recommend to change the spool settings for the printer in the Advanced tab of printer properties to "Start printing after last page is spooled" on both the client and the server. This can help to solve situations, in which the printer does receive a part of the data and the job times out before it can get completed.
    Best greetings from Germany
    Thursday, December 10, 2009 12:25 PM
  • Thanks Olaf.

    Unfortunately this change does not fix my problem.

    Friday, December 11, 2009 12:26 AM
  • Hi Martin,
    is there anything in the event log which may point to the cause of the problem?
    What happens, if you create a spooler folder on D:\ and redirect the spooler in Start/Printers and Faxes under File/Server Properties/Advanced to that folder?
    (After that restart the spooler service or the system.)
    On the specific printers Properties dialog on the Advanced tab is the Keep printed documents checkbox clear?
    Are the NTFS permissions for that folder configured in a way, that users have full control? (Also the security settings of the printer should be at default value.) Can you try to delete the printer, create a generic (text only) printer and test this? If this would show the same behavior, we can assume, that this is not a driver problem.
    Eventually you will have to perform some auditing what is going on.

    Best greetings from Germany
    Friday, December 11, 2009 9:03 AM
  • Hi Olaf.

    I think, we are on the track of someting about permissions.

    I found this interesting thread:
    The issue is described quite similar to what I encounter. I actually tried the prescription in the end of the thread, but unfortunately it did not save the day.

    When I saw your answer, I carried on fiddeling with permissions, and now I have ended up in a situation, where my client print jobs do not appear equally fast in spooler queue as before - changed from milliseconds to ~10 minutes!!

    If I have more than one job stuck in the spooler queque, I can easily remove these pending print jobs except from the uppermost, which is claimed to be printing. There I have to use services.msc . There are two scenarios:
    - If I try to remove the job, using "Printer/Cancel all jobs", it does not happen, but subsequent restart with services.msc will clear the spooler, and nothing is printed. 
    - If I right away restart with services.msc, the print job is actually printed - and all of them, if there are more than one.

    I am aware, that have not followed up on all your suggestions in your latest answer, but maybe some of them are now obsolete?

    I have no backup of my C:\WINDOWS\system32\spool folder right at hand. How do I most easily recreate the original folder as a basis for further tests and ajustments?
    Furthermore my efforts are made more difficult since it happens quite often, that my client looses contact with the server. I do not know how to reestablish the connection at will - it seems that this happens all by itself after some time? Is there a systematic way to control this?

    Greetings from Denmark

    Friday, December 11, 2009 12:34 PM
  • Hi Martin,
    an instable network connection may be a reason for the print job not delivered completely - so you are stuck with a half print job on the server.
    (That is why the recommendation was to complete spooling before printing on both client and server in the printers properties).
    The spool folder is set to inherit the permissions from the Windows folder here.
    Another problem could be, that the Everyone group on Server 2003 is not matching the users on other PCs - they are Anonymous. Those may be treated as guest, especially if the guest account is enabled. There was a group policy to add anonymous account to Everyone as it was in earlier Windows versions. Be aware, that this lowers the system security.
    Best greetings from Germany
    Friday, December 11, 2009 12:55 PM
  • Hi Olaf - and everybody else, who might be concerned.

    I eventually found the key to my main problem due to Barry Atkins in the bottom of this thread:


    I can now print from any client logged on to the WHS, so this was a spooler-problem after all.

    But all my troubles are not quite vanished. I still have a local net access problem:

    The solution mentioned above works for me personally on all my clients. But if other users log in on any client, the WHS printer is present in the window "Printers and Faxes" , but their prints do not come through. They appear with an error in the local printer queue. These blocked prints do not show up in the printer queue on the WHS.

    How may that be fixed?

    Monday, December 14, 2009 11:03 AM
  • Hi Martin,
    "They appear with an error" - well what for an error?
    Are there errors in the event log of the client and/or the server as well?
    Does printing a test page work?
    Is the printer accessed directly via \\server\sharedprintername or mapped to an LPT port?
    Try also to use the older driver package - fully fletched PnP drivers are often designed for client PCs and not very useful on servers.
    (You can also try one of the built in drivers like Generic/Text only to see, if the problem is more driver related or not.)
    Best greetings from Germany
    Monday, December 14, 2009 11:24 AM
  • Hi,

    Even this is quite old subject here already, I like to reply to this becouse I have had this same problem now more more than a year, actually as long as I have used WHS. And it has been difficult to find complete solution for this.

    When I found out that with administrator username and password (equal to user in WHS) printing works well from network clients, I tried to solve this again. This fixed the problem in my Home Server:

    At first:

    1. Login to your WHS via Remote Desktop
    2. Start / Control Panel / Administrative Tools / Services
    3. Find the "Print Spooler" service, double-click to view properties
    4. Select the "Log On" Tab
    5. UNCHECK "Allow service to interact with desktop"
    6. Click OK
    7. Restart the service

    (like in explaned in http://forum.wegotserved.com/index.php?/topic/384-installing-a-printer-on-whs-oem/page__st__20)


    1. Go to Printer's properties

    2. Open the Security tab and click Advanced.

    3. Check out how are rights for Administrators and add rights for Users group with same way.

    (Some usefull screen prints here: http://www.windowsnetworking.com/articles_tutorials/Securing-Printer-Usage-Windows-Server-2003-Part2.html)


    Now members of Users Group can print and manage documents and these two changes solved the same problem with my WHS.

    Monday, August 30, 2010 10:35 PM