none
PsExec no works after Creators Update at Windows 10 RRS feed

  • Question

  • Hi guys!

    This is my first post in this forum i'm brazilian and i not found any response about this question in brazilian foruns and i'll try here.

    So, after last Microsoft update (Creators) never more PsExec runs and i no have idea why it happened. Maybe a new security resource is blocking this tool or PsExec is no more compatible, whatever, i need know why PsExec never more runs after this update. Any idea???
    • Moved by Bill_Stewart Wednesday, July 26, 2017 7:39 PM This is not psexec or security support forum (not a scripting question)
    Sunday, April 30, 2017 7:28 AM

All replies

  • Go Brazil.  Your issue can best be resolved in this forum which is specific to PsExec: https://forum.sysinternals.com/pstools_forum8.html


    \_(ツ)_/

    Sunday, April 30, 2017 7:39 AM
  • Thanks for link about, but this forum looks dead, inactive... =/
    Monday, May 1, 2017 5:35 AM
  • Hi Rafaeljsc -

    I'm just chiming in that I too am experiencing psexec failing when connecting to a v1703 Creators Update edition.

    If your run Processmon and filter against psexec & Results that contain denied does it fail on \pipe\psexesvc ?

    High Resolution Date & Time: 6/15/2017 4:55:48.4735260 PM
    Event Class: File System
    Operation: CreateFile
    Result: ACCESS DENIED
    Path: \\COMPUTER\pipe\PSEXESVC
    TID: 10452
    Duration: 0.0050997
    Desired Access: Generic Read/Write
    Dis"Apple-tab-span" style="white-space:pre;"> Open
    Options: Synchronous IO Non-Alert, Non-Directory File
    Attributes: n/a
    ShareMode: None
    AllocationSize: n/a

    Thursday, June 15, 2017 9:27 PM
  • This is not a psexec forum, as already noted.

    -- Bill Stewart [Bill_Stewart]

    Thursday, June 15, 2017 9:33 PM
  • You must be running PsExec 2.2 on any modern Windows system or you will get many access denied errors depending on the scenario.

    Group Policy and AV settings may block PsExec.


    \_(ツ)_/

    Thursday, June 15, 2017 9:42 PM
  • The forum linked above is valid and active.  There are questions that have been responded to in the last few days.


    \_(ツ)_/

    Thursday, June 15, 2017 9:44 PM
  • Hey Rafaeljsc -

    I found out after going down a rabbit hole with this I realized that c$ and admin$ wouldn't work on the same v1703 system that all other version of windows worked just fine.

    Then on a whim I tried the v1703 by IP address and \\<IP>\admin$ worked! I googled Windows 10 admin$ share and this link was the first and only hit:

    https://social.technet.microsoft.com/Forums/en-US/fa0b4e73-29e8-46e8-a68d-ec5b66edd040/admin-not-accessable-by-hostname-after-windows-1703-feature-update?forum=win10itpronetworking&prof=required

    You just have to disable this setting:

    We have "Microsoft network server: Server SPN target name validation level" set to "Accept if provided by client" according to Microsoft security baseline, if I change it to "off" I can access the share.

    We use the Microsoft security baselines for all versions of Windows and even disabling the GPO keeps this setting unless you setup a GPO that had all windows defaults set in it to override this setting.

    Tuesday, June 20, 2017 12:09 AM