locked
USB drive failing after restart RRS feed

  • Question

  • Hi,

     

    I have a configuration with 2 sata drives and 2 usb drives and always when i restart one of the usb drives is failing. If i plug the usb connection out and in again it will work but it's getting annoying doing that. Does anyone have a suggestion ?

     

    Regards,

     

    Constant

    Friday, January 4, 2008 12:10 PM

All replies

  • Have you checked to see if powersaving is enabled? It could be that either the USB port, or the drive itself, might have this enabled. You will need to RDP into the server, select Start and then 'right-click' on My Computer. Select Properties and then the hardware tab, from there, select Device Manager and then go through your USB Controllers to see what the settings are.

    Of course, you could well have a 'duff' drive! but it doesn't sound like it.

     

    Colin

     

    Friday, January 4, 2008 6:01 PM
  • Colin,

     

    Powersaving was enabled but i disabled it and the result is the same. And it's a little strange that i have that with one of the two usb drives. After a restart it still says missing for the one usb drive.

     

    Constant

    Friday, January 4, 2008 7:11 PM
  • No suggestions for this problem ?

    Friday, January 18, 2008 3:26 PM
  • Can you tell us about the USB drives? Do they both work with other operating systems?

    I've seen this happen on other operating systems when I put a spare drive into a cheap USB enclosure that happened to be defective.
    Friday, January 18, 2008 5:50 PM
    Moderator
  • Hi again,

    When you say you've disabled power saving, is this on the M/B, or the drive. Also, if you have any extra USB ports, have you tried it on them.

    Sometimes it seems, some motherboards have difficulty supplying enough power to run multiple adapters. Something else that came to mind, that particular drive could have some thing like write delay enabled, which would be enough for WHS to think it's having problems.

     

    Colin

     

    Friday, January 18, 2008 5:53 PM
  • I've been having the exact same problem with an internal drive addition so I don't think this is necessarily a USB issue.  Oddly, only with a Maxtor 300GB (MaXLine III 7B300S0) drive.  I have a 250GB MaXLine Plus II with no trouble.  The other two internal drives are Seagates.

     

    This drive works fine in another system so I was beginning to think there was some strange connector issue on this drive but I know the drive is spinning up and getting power but WHS doesn't "see" it for some reason.  It is not in the add list and no drive lights when powered up.  Reseating the drive usually results in it being found though.  It will survive a server reset but not a power down/up situation.  When the server powers up from being off the drive will not be found.

     

    Then I came across another Maxtor drive I could use, exact same model/size and tried it.  Same problem!  So if it is the drive it is something unique to that particular model.

     

    I was beginning to wonder whether there is was something special about these Maxtor drives that the HP unit doesn't like when I came across this post.

     

    Also, the HP drive lights (in the Maxtor case) are not always in sync with WHS.  I reseated the Maxtor drive while the server was running and it found it and I got the purple light.  I powered the system off, removed the drive and powered by up and I still had a purple light even though there was no drive in the bay.  WHS did not "see" the drive in the Console or even when you used Remote Desktop to look at the hardware drive list.  But the HP drive light was purple.

     

    I had this problem with an HP EX475 unit (which got returned because HP thought it was broken) and now my HP EX470 unit that replaced it has the same issue.

     

    I don't have another SATA drive type to try so I can't narrow where the problem any further at the moment.

     

    I don't want to hijack this thread on another issue but I think the issue is the same and maybe this information will help both of us.

     

    Saturday, January 19, 2008 1:02 PM
  • Well, you are NOT alone!  I have TWO Maxtor OneTouch II 300GB drives, and they failed at precisely the same time!  I spent over two hours with 3rd level techs at Seagate, but to no avail. They said my drives just failed...YEAH, TWO at the SAME TIME!  B.S.  Then, since this was on an Intel iMac with Leopard/Vista/Bootcamp, each drive supporting one O/S, Apple discussion boards have two people with the same problem!  they have failed 500GB drives.

     

    Just to document it, are yours 300GB?  Using Vista only?  It sounds like some legacy USB devices have just landed in the crapper.  Let me know if you get it working.

     

    JJJ671

     

    Tuesday, May 13, 2008 8:48 PM