MSCRMTracing 17203 but No Tracing Enabled RRS feed

  • Question

  • I get event error MSCRMTracing 17203

    Invalid Trace Directory. Additional Info:[ Unable to Write file , Trace directory not defined (Reporting Process:File Name is Null.

    However, I have never enabled tracing. I found posts and a MS website how to disable and enable tracing and from that I checked the registry. On the server where the event happens and where CRM is installed I don't even have the relevant registry entry TraceEnabled in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM So why do I get this tracing event error?

    Btw, the trace directory C:\Program Files\Microsoft Dynamics CRM\Trace does exist and seems to have the right access rights but the relevant keys in the registry are missing (since I never enabled tracing in the first place) so I guess that is where this is coming from.

    Thursday, May 3, 2012 8:15 PM

All replies

  • The error is happening because is not defined in the registry. Follow this KB to enable tracing:


    Let us know if it worked



    Visit my blog for CRM material, improving performance, kerberos, IFD, development tips, etc. :) http://quantusdynamics.blogspot.com

    Thursday, May 3, 2012 9:46 PM
  • Nuno, thanks. I actually was wondering why there is a trace when I did not enable it in the first place. In any case, what I now tried is enabling tracing through PS and then disable it in the hope the relevant registry entries are added. However, after doing this I don't see the required registry entries TraceEnabled, TraceDirectory and TraceRefresh on HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRM (note this is on the CRM server). So where does set-crmsetting $setting write the settings? If that is somewhere else than the registry then which source has precedence over which one?

    Friday, May 4, 2012 4:21 PM
  • I  think there is a lot of confusion about tracing settings and not enough clear documentation. This is an area I'm looking into at the moment.

    So far, I've discovered that the powershell commands change settings in the MSCRM_CONFIG database and not the registry keys. In fact, my experience is that you can enable two sets of trace files, one with the powershell commands and one with registry keys. They seem to work independently.

    I suspect that the powershell commands cause tracing to occur on all CRM servers in a deployment whereas the registry keys only apply to the one server but I have yet to prove this.

    Wednesday, May 9, 2012 10:30 PM