locked
Group Chat file transfer problems RRS feed

  • Question

  • I have Group Chat on Server 2008/IIS7.  It all works except for file uploads.  I have worked through multiple errors and at this point the files are created on the file share, but the operation fails and I can't retrieve the files from within Group Chat.  The most recent error is simply "A file transfer error occurred. Server error."   At other times, I have gotten "Failed to retrieve a valid token".

    I would appreciate steps I can take to troubleshoot.

    My certificate is an internall generated domain cert with SAN which includes FQDN and NetBIOS name.  A direct connection to https://fqdn/MGCWebService/MGCWebService.asmx works fine with no cert errors.  I set the anonymous account to the Channel Service account.  I saw some access denied errors on SQL where the machine account was trying to access the DB so I added the machine account to SQL and to the RTCComponentUniversalServices group.  At first, I couldn't upload the file.  Now the file uploads and then fails (as I described earlier).

    In IIS, the default web site has only anonymous authentication using the default account.  The MGCWebService only uses anonymous auth with the Channel service account.

    At this point, although I have logging cranked up, I am seeing very little to help me troubleshoot.  Any ideas would be appreciated.

    Rob
    Tuesday, May 5, 2009 5:09 PM

Answers

  • For those who may have struggled with some of this, I resolved it for myself and I have this to offer. 

    For troubleshooting purposes, relax permissions on your network shares where Group Chat and Compliance content is stored. 

    The key here is related to the IIS (MGCWebService app) credentials.  The only authentication I have enabled for this app is Anonymous.  I changed the creds fronm the default IUSR to the Channel Service account (as stated in the deployment docs).  There is also an application pool (MGCWebServicePool) which runs under "Network Service".  The Channel Service (and the other service accounts) were granted access to the file shares. 

    When I first started to troubleshoot this, I had already noticed from some of the trace logs that the "servername$" computer account was getting "Access Denied" errors, so I granted access for that account to the share for Group Chat content.  Well I also needed to add that account to the Compliance content share.  Then it all worked.

    Rob
    • Marked as answer by solorob Wednesday, May 6, 2009 9:04 PM
    Wednesday, May 6, 2009 9:04 PM