locked
WHS Problems... (Won't boot + Explorer.exe issues) RRS feed

  • Question

  • Starting to think WHS was a failed investment...

    My first problem was after installing some updates for WHS I received a nice "NTLDR is missing" error on restart.  Managed to fix that by booting from a W2K3 CD and using chkdsk fixboot & fixmbr.  Then I had another problem come up.  Whenever I tried to copy data from the server to a computer via explorer then the client side explorer would freeze and need a restart.  On the WHS side it would basically kill the OS.  I was unable to restart explorer.exe and since explorer was stuck I was unable to restart the WHS box.  This also made it impossible to RDC into the box, had to RDC into it beforehand.  Using shutdown /r /f did not work either.  Had to do a hard reboot.  Used Process Explorer to see if there was something else going on such as DPC's churning the CPU since Task Manager showed no issues.  Process Explorer showed nothing however and I was unable to kill explorer with it either.  Now I can't even boot into WHS.  The computer boots up and shows the WHS loading screen then just sits at a black screen.  Unable to ping the server so nothing is actually loading on it.  So I have 2 questions:

    1.  Is the data on the hard drives salvageable via regular means?
    2.  Is there a way to repair/reinstall WHS and have it recognize all the data on the hard drives?

    Info:

    Vista Ultimate x64 SP2 Desktop
    Vista Ultimate x64 SP2 Laptop
    WHS w/PP2 (8x750GB Sata HD, Gigabit LAN, 2GB RAM)

    Any help is appreciated.  If more information is needed I'll promptly reply.
    • Edited by FiftyOne50 Tuesday, June 23, 2009 7:11 PM Update Title For Clarity
    Tuesday, June 23, 2009 6:50 PM

All replies

  • My thought is that you have failing hardware. The failing component is pretty hard to pin down; it could be anything along the line from the hard drive(s) to the motherboard to the CPU or memory. I would bet on the system drive being the point of failure, personally...

    You can, in extremis, pull the drives out of your server and check them individually, or copy files off of them. The files in your shares are stored on the drives in a hidden folder: <drive>:\DE\Shares\etc.

    If all your hardware checks out (doubtful; I really think you'll most likely find your system drive is failing) you can perform a server reinstallation. There are (sketchy) instructions in this FAQ post. This will preserve the data in your shares (assuming duplication is turned on for all shares), but you will have to recreate users, rejoin computers, etc. You may lose your backup database as well; it doesn't participate in duplication, and if components are on a damaged drive the whole database is probably toast.

    I'm not on the WHS team, I just post a lot. :)
    Tuesday, June 23, 2009 7:16 PM
    Moderator
  • Thanks for your reply Ken.  I do have duplication enabled on all shares.  I tried booting from the WHS CD but reinstallation is not an option.  I have posted in the Hardware & Install forum as you advised.

    On a side note, as stated above I did run a chkdsk on the system drive when I originally had the NTLDR problem and I haven't seen any signs that any of my drives or hardware are failing.  I also did not notice any issues with WHS until I tried copying data so I believe it is corruption of the OS somewhere.  At the same time however I'm not restricting myself from hardware being the issue, but it seems sketchy to me.

    Also, if it makes a difference, I don't use backups and only have one user created so I don't care too much about the setup of the OS, I just care about the data.  I have another ~2.5TB of HD space separate  from the server so all I'm trying to do at this point is get that data backed up.

    Edit:  Ken, thanks for your help.  I am going to just install Vista over the Sys partition and salvage my data from the shares.
    • Edited by FiftyOne50 Tuesday, June 23, 2009 8:22 PM
    Tuesday, June 23, 2009 7:39 PM
  • Well, a diagnostic session will be called for at some point. That may reveal the source of the issue, and OS corruption is certainly a possibility. How it happened, though, is likely to remain a mystery. 

    As for your data, the data is available, as I said. I'm not sure why you're not getting a reinstallation option. Some things you can try are to delete the system partition (the 20 GB partition) and see if that help, and to delete all partitions on the system drive (which would leave the drive looking like a brand new one to setup). As long as setup can see all your other storage pool disks it should give you the reinstallation option.

    I'm not on the WHS team, I just post a lot. :)
    Tuesday, June 23, 2009 8:20 PM
    Moderator