locked
Customize Entities is not available except on CRM server RRS feed

  • Question

  • I'm running CRM 4.0 in an IFD.  Only the CRM server itself uses a domain sign on.   If I sign on to the CRM server as an administrator from another machine the Customize Entities menu item does not display.  I get this behavior even if I sign in using the administrator account.  If I remote desktop to the CRM server and sign in, Customize Entities is available.  Is that an IFD restriction or is there some other permission I need to set to get the item to show up?

    Thanks,
    -WT
    Monday, May 18, 2009 4:16 PM

Answers

  • The outlook client limits the connection to the CRM server.  It is not possible (for instance) to see the settings > customization section of CRM once you have opened Outlook on the computer.  Even if you close outlook, the hoster process is often still running in the background and holding open a connection to the server with the limitations still enabled.  This is by design.

    There are two work-arounds (if you don't want to remove the Outlook client from the computer that will be doing the customizations)

    1. The hoster process usually has an icon in the system tray - right-click it and select disable - then open an internet browser and connect to CRM. (during this time the crm functions within Outlook won't be opperational until you restart outlook - at which time the CRM connect re-establishes with the limitations and you can not longer access customizations)
    2. On the server create a host header for administration purposes.  You can then access the CRM from the server using the host header with full access while still being able to access all features of outlook and CRM from within outlook

    I like # 2 the best, but there is always the possibility that you may run into something that doesn't act as expected while using the host header (I have never run into an issue while customizing within the CRM appliation, but that doesn't mean the possibility doesn't exist).  If you are doing major programming (ie plugins, additional web interfaces etc.  I recommend using #1).

    If you are using the data migration manager - you have to use method #1 or the MM won't connect correctly.

    CK

    • Marked as answer by wtsun Friday, May 22, 2009 5:58 PM
    Tuesday, May 19, 2009 5:06 PM

All replies

  • Hi,

    use you the same language when you connect over IFD or with the domain sign in? The customization is only available in the base language from crm. When you installed a englisch version and a german language pack, then the customization is only available in the englisch language.



    Viele Grüße

    Michael Sulz
    axcentro GmbH
    Monday, May 18, 2009 4:31 PM
  • Hi Michael,

    Yes, both the CRM Server and my client machine is running in EN-US.  There are no language packs installed on the CRM server that I'm aware of.  On my client machine I have the far east language input method capability but I'm running in English mode.  Does this have any effect?

    BTW, when I access the CRM server from my client I use https.  All other CRM functions seem to be fine except this one.

    William Tsun

    Monday, May 18, 2009 4:39 PM
  • Hi wtsun,

    Could you confirm you're not currently running an open Outlook application? If so, please close Outlook and try connect again.

    Thanks,
    Karlo
    Karlo Swart - http://www.ver206.com
    Monday, May 18, 2009 9:58 PM
  • Yes, I'm running Outlook and I have the CRM 4.0 Desktop client installed.  That does seem to be related because after rebooting it seems to work.  I'm not sure if it was the reboot or the crmaddin plug-in disabled.  I run CRM mostly from the web client though I use the Desktop client to Track emails.  Any insight on how Outlook might be related to this problem?

    In any case, the item now shows up.

    Thanks,
    William. 

    Tuesday, May 19, 2009 3:29 PM
  • The outlook client limits the connection to the CRM server.  It is not possible (for instance) to see the settings > customization section of CRM once you have opened Outlook on the computer.  Even if you close outlook, the hoster process is often still running in the background and holding open a connection to the server with the limitations still enabled.  This is by design.

    There are two work-arounds (if you don't want to remove the Outlook client from the computer that will be doing the customizations)

    1. The hoster process usually has an icon in the system tray - right-click it and select disable - then open an internet browser and connect to CRM. (during this time the crm functions within Outlook won't be opperational until you restart outlook - at which time the CRM connect re-establishes with the limitations and you can not longer access customizations)
    2. On the server create a host header for administration purposes.  You can then access the CRM from the server using the host header with full access while still being able to access all features of outlook and CRM from within outlook

    I like # 2 the best, but there is always the possibility that you may run into something that doesn't act as expected while using the host header (I have never run into an issue while customizing within the CRM appliation, but that doesn't mean the possibility doesn't exist).  If you are doing major programming (ie plugins, additional web interfaces etc.  I recommend using #1).

    If you are using the data migration manager - you have to use method #1 or the MM won't connect correctly.

    CK

    • Marked as answer by wtsun Friday, May 22, 2009 5:58 PM
    Tuesday, May 19, 2009 5:06 PM