locked
Printer Installation Error Message RRS feed

  • Question

  • I'm trying to install a printer via USB on WHS but without success. 

     

    I've downloaded from HP the Server 2003 driver for the Laserjet 1320 printer.  When I connect the printer (or use find new hardware) the install new hardware goes through the process and says that it is downloading an update from MS - the DOT4USB driver (for a USB connected printer), which all seems good but then the whole thing fails with the following error message:

     

     configuration registry key is invalid

     

    Looking through MS tech support doesn't help much and responses from elsewhere on this error message seem mixed as to causes.

     

    I've tried doing this remotely and directly on WHS.

     

    Any ideas would be very welcome - I've tried the original CD software but that doesn't load as it's intended to Windows XP and I'd prefer not to use compatibility mode in case of problems later.

     

    Thank you

     

    Robert

     

    Saturday, July 21, 2007 7:54 AM

All replies

  • Hi,

    Remove any trace in the registry for that installed drivers (use any registry util), then remove the usb cable for the printer from the pc, restart.

    Install the drivers, then if the software till you to connect the printer to the usb, then do that.

    I found many USB printers need to be installed that way.

    Also, many of them run best on USB 2.0 ports.

    In this topic, some good info , not for for usb issue, but good workaround matters, it may help:

    http://forums.microsoft.com/WindowsHomeServer/ShowPost.aspx?PostID=1814671&SiteID=50

    My best.
    Saturday, July 21, 2007 8:29 AM
  • Hi,

     

    Thanks for this, which partly solved the problem.

     

    In fact what happened was that as I tried to delete certain entries in the Registry that related to the HP 1320 printer I found that on two items I couldn't delete them.  I noticed that this related to the two USB entries where I had tried to install the printer.  I started to wonder whether my inability to delete the registry values might also be part of what stops the printer installing.

     

    Anyway, thinking about the greater security and restrictions that you have on Windows Server 2003 and therefore WHS I decided to adjust the permissions on these two registry entries to see if that let me delete them.  Well, it did,  Then I rebooted the WHS and then I followed your instructions above and switched on the printer and then connected it via USB to the WHS.  This time the printer installed just fine and I had no problems (thanks to HP having Vista, XP, and Server 2003 drivers all in one place) connected each PC to the new network printer on the server. 

     

    So on this occasion the error message was due to Windows Server 2003 having too high a permission level for changing the USB values in the registry.  The system setting was for full control but everyone else was read only.  For some reason, even logged in as an Administrator this wasn't sufficient to change the registry values and so the installation failed. Changing permissions on this registry value so that everyone had full control allowed the printer to install.

     

    At least that's how it seemed to me, but I may of course have missed out some other vital information.  However, on this occasion this tweak worked.

     

    Thank you and hope this may help someone else.

     

    Regards

     

    Robert

    Sunday, July 22, 2007 5:13 AM
  • Good to see that I was able to help in someway and you manage to install the printer.

    My best.


    Sunday, July 22, 2007 9:09 PM