locked
Edge server installation probleme... RRS feed

  • Question

  • Hello,

     

    I'am trying to install a EDGE server in my Lab test (ocs2007 ans oc work internaly...)

     

    I'm encoutering the following errors during my edge server's validation.

     

    No WMI Instance Returned By Query : select * from MSFT_SIPFederationNetworkProviderTable where Enabled 


    Aucune instance WMI retournée par la requête : select * from MSFT_SIPFederationPartnerTable
    Found External Edge listening address : 192.xxx.xxx.xxx:5061:TLS - Enabled
    Found External Edge listening address : 192.xxx.xxx.xxxx:443:TLS - Enabled

     

    Failure
    [0xC3FC200D] One or more errors were detected 

     


    An Idea ?



    And when i Try to connect from a OC client externaly

    in option:  Internal IP : i put the internal ip of the edge, right no?

                    externalIP: i put the public ip of the edge...


    when i loginin, i have a

    There was a problem verifying the certificate...

    So.. From the ocs-server, i have exported the root certificate, and i have installed it on the OC client


    but.. same error (i have make the same for the internal client and it's work...)



    Thank's

    Thursday, October 23, 2008 12:33 PM

Answers

  • Just make sure that you set the record correctly in the HOSTS file as OC will need to resolve a name to IP address, you can't use an IP directly in the Manual Configuration client settings with TLS (as discussed earlier in the thread).

     

    Saturday, October 25, 2008 8:30 PM
    Moderator

All replies

  • "And when i Try to connect from a OC client externaly

    in option:  Internal IP : i put the internal ip of the edge, right no?

                    externalIP: i put the public ip of the edge...

    "


    You must use the FQDNs of the edge server. TLS verification will never happen on the IP Address.

    You can refer the following link to ensure you do have edge servers configured in right way!


    http://www.ocspedia.com/Edge_Server/Deploy_AEP.htm




    Regards,
    R. Kinker
    MCSE 2003 (Messaging), MCTS - LCS 2005, MCTS - OCS 2007
    http://www.ocspedia.com
    http://www.itcentrics.com/LCS_Home.htm

    Friday, October 24, 2008 6:01 AM
  • Thank's for your answer.

    But i'm in a lab test... if try to sign-in from internet  putting the fqdn, how "internet" can know what's the ip of my fqdn ???
    Friday, October 24, 2008 7:26 AM
  • Well.. the external fqdn must be registered with the public IP Address.

    External client doesnt bother about the internal fqdn. You can put anything as internal fqdn.


    Regards,
    R. Kinker
    MCSE 2003 (Messaging), MCTS - LCS 2005, MCTS - OCS 2007
    http://www.ocspedia.com
    http://www.itcentrics.com/LCS_Home.htm

    Friday, October 24, 2008 8:26 AM
  • Hmm okay.

    And if i put this in the HOST client file:

    10.10.2.6              edge.exchange.com
    xxx.xxx.xxx.        
    edge-nic-ext.domain.com


    where 10.10.2.6 is the internal ip of the edge, and xxx.xxx.xx is the public ip of the edge


    It could work ?


    Or do I contact my administrator to register "edge-nic ext.exchange.com" for my public IP?


    Friday, October 24, 2008 9:38 AM
  • To get a clear understanding on how the Edge Server works I would recommend to read the following document:

     

    http://www.microsoft.com/downloads/details.aspx?familyid=e4a8d703-e41a-47d9-b9dd-2799f894af92&displaylang=en

     

    /Thomas

     

    Friday, October 24, 2008 9:42 AM
  • If you are simply trying to test out a lab then you don't need (or may not even be able to) have your administrator register the external SRV and A records required for client Automatic

    Configuration.

     

    Ideally you should have sip.yourdomain.com as your Access Edge external FQDN (the sip. is important) and also as the Access Edge certificate's subject name.  Then you can create an in the HOSTS file of your external test workstation and sign into OC with a SIP-enabled user in the @yourdomain.com namespace.

     

    If you want to test using the Manual Configuration then you can use whatever FQDN name you choose (edge-nic-ext.domain.com in your example) and simply set the client to:

     

    Internal servername: (FQDN of your internal Front-End OCS server, NOT the Edge server)

    External servername: edge-nic-ext.domain.com:443

     

    This is assuming you haven't modified the default listening port of the Access Edge server.

    Friday, October 24, 2008 10:42 PM
    Moderator
  • Okaay !
    Many thank's for your answers (especialy Jeff)

    SO i do not need dns record (I thought it was necessary even if we tried to connect manually)....


    I will try it Monday

    Thank's
    Saturday, October 25, 2008 8:24 PM
  • Just make sure that you set the record correctly in the HOSTS file as OC will need to resolve a name to IP address, you can't use an IP directly in the Manual Configuration client settings with TLS (as discussed earlier in the thread).

     

    Saturday, October 25, 2008 8:30 PM
    Moderator
  • Okay... Perfect !

    it work now!

     I can Loginin (edge-nic.domain.com:5061) and send Instant message.

    But the Audio and the Video don't work.

     

    http://img146.imageshack.us/my.php?image=extfr9.png

     

    http://img111.imageshack.us/my.php?image=confng4.png

     

    http://img444.imageshack.us/my.php?image=confavef1.png

     

    thank's for your help


    ps: i have opened an other post in the correct forum (edge forum)

    Monday, October 27, 2008 7:49 AM