locked
problem with extra zero's after organisation import RRS feed

  • Question

  • I have upgraded from CRM 3 32bit to CRM 4 32 bit (reinstall + import) and then moved from that machine to a 64bit CRM4 machine (import). Now I have the problem that when entering a quantity in the add product screen when creating an invoice, the system automatically adds 5 zero's to the quantity. Why can that be, how to solve?
    R.
    Tuesday, August 4, 2009 8:51 AM

Answers

  • Please go to following setting in your user options

    On the main toolbar of the crm window: Extras -> Options -> Tab "Formatting" ( don't know the exact word because I have no english system for reference) -> Button "Cusomize" -> What is the value of the field "decimal seperator" ?
    • Marked as answer by ruud00000 Saturday, August 22, 2009 3:11 PM
    Monday, August 10, 2009 10:33 AM

All replies

  • Hi,

    please check the decimal seperator option in your user settings. See http://support.microsoft.com/kb/951268
    • Marked as answer by Donna EdwardsMVP Tuesday, August 4, 2009 5:22 PM
    • Unmarked as answer by ruud00000 Friday, August 7, 2009 6:15 PM
    Tuesday, August 4, 2009 11:04 AM
  • Where do I check that? In CRM I can go to configuration tab then link systemconfiguration and then second tab, there notation is 123.456.789,00, which should be correct. Where else sould I check? In Windows OS, elsewhere? 

    I tried installing the rollup 5 but no difference.

    To summarize:
    - I checked in SQL: notation is 123.456.789,00 in the CRM database itself, which is correct (dutch).
    - in CRM all numbers show with '.' as seperator for thousands as well as '.' for decimal sign, which is not correct and which is not in accordance with the setting as shown in the CRM settings window.
    - as soon as crm starts validating a number input it adds a number of zero's that equals the number of decimals (so the problem is definitely related to this decimal sign setting), so for a number with 5 decimals, CRM adds 5 zero's and if a validation includes two steps it adds 10 zero's, ...
    - during rollup 5 install I got an error, which I chose to ignore (no other way to proceed), related to not finding a system user or so. This was in the stage of publishing reports.

    R.
    • Edited by ruud00000 Friday, August 7, 2009 6:54 PM
    Friday, August 7, 2009 6:16 PM
  • Where in the value are the 0's being added?  Did you maybe mess up the precision setting on the attribue, and it's adding them after the decimal?
    Matt, MVP - Dynamics CRM
    Friday, August 7, 2009 11:19 PM
  • When I enter a 1 in an amount (number of products e.g.) field it becomes 100.00 and then 10.000.00. when I enter a 1 in a value (price e.g.) field it becomes 100.000.00 and then 10.000.000.000.00 or even more.

    How can I mess up a precision setting af an attribute, and of which attribute? How to check? I didn't change anything myself to such settings after the upgrade / import but maybe something went wrong there anyway?


    R.
    Saturday, August 8, 2009 7:53 AM
  • Please go to following setting in your user options

    On the main toolbar of the crm window: Extras -> Options -> Tab "Formatting" ( don't know the exact word because I have no english system for reference) -> Button "Cusomize" -> What is the value of the field "decimal seperator" ?
    • Marked as answer by ruud00000 Saturday, August 22, 2009 3:11 PM
    Monday, August 10, 2009 10:33 AM
  • This is a concern:

    during rollup 5 install I got an error, which I chose to ignore (no other way to proceed), related to not finding a system user or so. This was in the stage of publishing reports.

    It could be the symptom of an issue.  If the root of the issue lies in something associated with the upgrade from 3.0 to 4.0, we might be challenged to find the solution.  The issue sounds like what is describe in the KB http://support.microsoft.com/default.aspx/kb/951268 but maybe not.  In any event, I would not expect you to recieve an error message when attempting to install an Update Rollup.

    You may need to open a support ticket with Microsoft to get to the root cause of the issue as the latest update was supposed to correct your issue. 
    Best Regards, Donna
    Monday, August 10, 2009 4:37 PM
  • Hi,

    the easiest way to change it, is to save another format and then rechange it to the right format. To do this, go to Tools/Options and select the tab formats.
    On this tab you can change the current format, save the changes and then change it again to the right format.

    You have to do this on each client. I hear from this problem only with a german crm server. If you have a lot of clients, you can update the database directly, but this is absolutly unsupportet. To change the database directly, you can use the following script (for a german CRm server):
     

    UPDATE UserSettingsBase SET DecimalSymbol = ',', NumberSeparator = "."


    Viele Grüße

    Michael Sulz
    axcentro GmbH
    MVP für Microsoft Dynamics CRM
    Monday, August 10, 2009 4:59 PM
  • Well I found that as mentioned before when going to instellingen -> beheer -> systeeminstellingen -> indelingen the notation shows 123.456.789,00 so that would be correct. However going to CRM's menubar -> extra -> options -> indelingen (the way ckeller told me to go above) the notation shows 123.456.789.00. There I can adjust the setting and then it works fine, problem solved.

    Why are there two different ways to manage what seem to me the same settings? And most of all, how can these settings be different?


    R.
    Saturday, August 22, 2009 3:44 PM