locked
How to Automatically Minimize Launchpad on Start Up RRS feed

  • General discussion

  • I created a VBScript to Start and then Minimize Launchpad.

     

    First I turned Off automatic start of Launchpad.  Launchpad, \/, settings, Start up option, Uncheck “Automatically run the Launchpad when I log on to Windows”.

     

     

    Using Notepad I saved the script below as Launchpad.vbs adding it to the Programs\Startup folder.

     

    Set objShell = CreateObject("WScript.Shell")
    objShell.CurrentDirectory = "C:\Program Files\Windows Server\Bin\"
    objShell.Exec "C:\Program Files\Windows Server\Bin\Launchpad.exe"
    Do Until Success = True
        Wscript.Sleep 1000
        Success = objShell.AppActivate("Windows Home Server 2011 Launchpad")
    Loop
    Do Until Success = False
        objShell.SendKeys "%{F4}"
        Wscript.Sleep 1000
        Success = objShell.AppActivate("Windows Home Server 2011 Launchpad")
    Loop

     

    I have tested the script with XP and Win 7 (64 bit).


    Texas

    • Changed type Ken Warren Monday, July 11, 2011 2:02 AM Not a question. Helpful, though.
    Monday, July 11, 2011 12:30 AM

All replies

  • Thanks for that ! Works like a charm on my Dell laptop with Win7 Pro 64bit !

    Will try it on the other machines later and let you know.

    Glad I can get rid of that: specially on my wife's laptop !

    I'm not too sure to understand your sentence:

    "First I turned Off automatic start of Launchpad.  Launchpad, \/, settings, Start up option, Uncheck “Automatically run the Launchpad when I log on to Windows”."

    Is there just somewhere, something to click? I searched for something like this like crazy.

    Thanks

     

    Tuesday, August 2, 2011 4:45 PM
  • Rupicola

    If you are logged into the Launchpad, click the downward facing arrow in the upper right corner and select "Settings". That's what the " \/" above means.



    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.
    Tuesday, August 2, 2011 5:45 PM

  • I have tested the script with XP and Win 7 (64 bit).


    Interesting. I have just tested this on my W7 (64 bit) Dell laptop and the Dashboard starts up at boot and then closes, but leaves the launchpad.exe process running. There is no minimised Launchpad to open!

    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.
    Tuesday, August 2, 2011 6:03 PM

  • I have tested the script with XP and Win 7 (64 bit).


    Interesting. I have just tested this on my W7 (64 bit) Dell laptop and the Dashboard starts up at boot and then closes, but leaves the launchpad.exe process running. There is no minimised Launchpad to open!

    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.


    When you said "Dashboard" did you mean Launchpad?

    I have seen the same problem intermittently on both my Win 7 and XP machines.  I have had it occur with and without my script.  Launchpad starts but there is no Taskbar Icon.  If I then kill the Lanuchpad process in Task Manager then restart Launchpad I get the icon back.

    These Launchpad issues really need to be fixed by Microsoft.

    My might try adding a delay in the script before Launchpad is started and see if that helps.

    Also when you uncheck "Automatically run" it places the follow entry in thr registery:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run

    "Launchpad"="%programfiles%\\Windows Server\\Bin\\Launchpad.exe -autostart" 

    So Launchpad is actually starting and then the "-autostart" shuts it down.  I removed the above entry from my PC's. 

     


    Texas
    Tuesday, August 2, 2011 7:27 PM
  • Texas

    Yes of course I meant Launchpad - just testing you were being alert! Wiil try your suggestions later.

    Thanks


    Phil P.S. If you find my comment helpful or if it answers your question, please mark it as such.
    Tuesday, August 2, 2011 7:33 PM