locked
Site not showing up in results. Not blocked. 18,000 pages indexed. RRS feed

  • Question

  • I'm the webmaster for Parable.com.  On Google we show up in the top 10 results for "christian books", the top result for "parable", the top result for "parable.com", the top result for "parable christian stores", in the top 10 for "christian accompaniment", etc.  I could go on.  We also rank well on Yahoo and Ask.

    On search.live.com, we do not show up in searches for "parable", "parable.com", "christian books", or any other similar term.

    In Live Webmaster Tools, it says that parable.com is not blocked, 17,900 pages are indexed, many have been spidered in the past couple days, our domain score is 5 green boxes, as is the page score for our homepage (I'm assuming that's something similar to PageRank) and there are no crawl issues.  A search for site:www.parable.com returns results, so I assume it's a ranking issue.  I don't understand what that issue would be, though.

    Any help figuring this
    out would be very much appreciated.

    Thanks.
    Thursday, September 18, 2008 11:00 PM

Answers

  •  

    Hi,

     

    Sorry for the delay. I am reviewing this and will get back to you as soon as I can. You will be moved to the front of the list.

     

     

    Thanks,

     

    Brett

    Tuesday, October 14, 2008 4:13 PM
  • Hi Josh,

     

    I'm glad Jeremiah could help you out. He tracked you down on Twitter after I brought the situation to his attention and he wanted to contact you directly. Twitter was the easiest way for him to do so at the time. If you are still experiencing difficulties, please let either Jeremiah or myself know.

     

     

    @Capone

    Please let me know what you find in your logs please also check that you haven't blocked our IP range. You can read more about it on our reverse DNS lookup blog post.

     

    Thanks,

     

    Brett

     

     

    Wednesday, October 22, 2008 8:32 PM

All replies

  •  

    Hi,

     

    Sorry for the delay. I am reviewing this and will get back to you as soon as I can. You will be moved to the front of the list.

     

     

    Thanks,

     

    Brett

    Tuesday, October 14, 2008 4:13 PM
  • This turned out to be an issue that came about when Live first launched.  They were crawling our site too quickly and causing server slowness so the bots' IP addresses got blocked and I was never informed about it.  We recently unblocked them and the situation seems to be improving.

    That said, a helpful Live Search employee responded to my concerns much quicker via Twitter (how sad), helped me track down the issue and provided the following article that could be useful for anyone experiencing too much traffic from Live bots:
    http://blogs.msdn.com/webmaster/archive/2008/06/03/robots-exclusion-protocol-joining-together-to-provide-better-documentation.aspx

    Wednesday, October 22, 2008 6:46 PM
  • Thats good news Josh!

     

    Im having a similar problem here as well. im going though my logs to see when the last time i was visited.

    Wednesday, October 22, 2008 7:26 PM
  • Hi Josh,

     

    I'm glad Jeremiah could help you out. He tracked you down on Twitter after I brought the situation to his attention and he wanted to contact you directly. Twitter was the easiest way for him to do so at the time. If you are still experiencing difficulties, please let either Jeremiah or myself know.

     

     

    @Capone

    Please let me know what you find in your logs please also check that you haven't blocked our IP range. You can read more about it on our reverse DNS lookup blog post.

     

    Thanks,

     

    Brett

     

     

    Wednesday, October 22, 2008 8:32 PM