locked
crm2013: change owner will update the change-date of the annotations ... but only on account instances! RRS feed

  • Question

  • Hi all,

    we have a strange Problem, when changing the owner of an account.
    On the form we have the Annotation/ Activities subgrid.

    .. and ONLY in account entity, if i Change the owner of the account, all changed-Dates of assigned annotations will be updated too, to the same date.

    I looked if in realationship betw. account + Annotation are some assignments to fields (e.g. changed on) but there arent any. 
    I havent found any js which could Change the Annotation changed date.

    I have no more ideas, which will help me, finding the solution for the Problem.
    Any hint welcome.

    thx, greets pit

    we use IE11, crm2013 sp1 newest ru

    Tuesday, October 21, 2014 7:42 AM

All replies

  • Hi again,

    could anyone try to reproduce this?

    If everyone has this, i'll Report this in MS:Connect as bug.

    THX, Greets Peb

    Wednesday, October 22, 2014 10:52 AM
  • did you check the relationship behavior?

    My blog: www.crmanswers.net - Rockstar 365 Profile

    Wednesday, October 22, 2014 11:15 AM
  • Hi,

    Check relationship behavior. It might be assigning the annotation to the owner that you are setting on Account.

    http://msdn.microsoft.com/en-in/library/gg309412.aspx 

    Thanks!

    Kalim Khan

    Wednesday, October 22, 2014 12:35 PM
  • thx Guido & Kalim,

    but, the owner will not be changed .. the owner of the annotations is not changed ... ist only the changed-date of all to the account instance assigned annotations, which is effected.

    the courious is, in all the other entities it works ...

    i compared the realationship behavior of a working to the account ... and ist exactely the same.

    and i have no js which does a Change in annotations if in account changes something.

    Have you tried to reproduce this in one of your Systems?

    THX, Greets peb

    Thursday, October 23, 2014 7:14 AM
  • Bottom line, if some functionality acts different on different entities, it is definitely a bug.  What I have realized with my experience of moving from 2011 to 2013 is that not all new functionality is updated correctly on all entities.  There are quote a few of this cases.  Some cases I had to write plugins to make all entity forms behave the same. 

    Unfortunately, you do not want to add missing functionality, but remove faulty functionality.  Have you looked at the Plugin Registration tool in the SDK?  Maybe there are some functionality that can be disabled.


    Christo Vermeulen

    Thursday, October 23, 2014 1:46 PM