locked
CRM 2013 (On Premise) IFD Outlook Client on Windows Server 2012 RRS feed

  • Question

  • enabled and configure IFD for CRM 2013 and I can log in using the browser but when I try logging in using Outlook this error Appears.
    Cannot connect to Microsoft Dynamics CRM server because we cannot authenticate your credentials.

    Log file:
    Error

    13:31:29|  Error| Error connecting to URL: https://auth.domain.com:444/XRMServices/2011/Discovery.svc Exception: Microsoft.Crm.CrmException: Authentication failed
       at Microsoft.Crm.Outlook.ClientAuth.ClaimsBasedAuthProvider`1.AuthenticateClaims()
       at Microsoft.Crm.Outlook.ClientAuth.ClaimsBasedAuthProvider`1.SignIn()
       at Microsoft.Crm.Outlook.ClientAuth.ClientAuthProvidersFactory`1.SignIn(Uri endPoint, Credential credentials, AuthUIMode uiMode, IClientOrganizationContext context, Form parentWindow, Boolean retryOnError)
       at Microsoft.Crm.Application.Outlook.Config.DeploymentsInfo.DeploymentInfo.LoadOrganizations(AuthUIMode uiMode, Form parentWindow, Credential credentials)
       at Microsoft.Crm.Application.Outlook.Config.DeploymentsInfo.InternalLoadOrganizations(OrganizationDetailCollection orgs, AuthUIMode uiMode, Form parentWindow)


    Saturday, January 11, 2014 12:03 PM

Answers

  • I found the solution:

    Go to database MSCRM_CONFIG
    MSCRM_CONFIG.FederationProvider

    UPDATE https://sts1.domain.com/adfs/ls/mex to https://sts.domain.com/adfs/services/trust/mex

    UPDATE [dbo].[FederationProvider]
       SET 
          [ActiveMexEndpoint] = 'https://sts.domain.com/adfs/services/trust/mex'

    Then

    iisreset

    Sunday, January 12, 2014 8:52 AM

All replies

  • I found the solution:

    Go to database MSCRM_CONFIG
    MSCRM_CONFIG.FederationProvider

    UPDATE https://sts1.domain.com/adfs/ls/mex to https://sts.domain.com/adfs/services/trust/mex

    UPDATE [dbo].[FederationProvider]
       SET 
          [ActiveMexEndpoint] = 'https://sts.domain.com/adfs/services/trust/mex'

    Then

    iisreset

    Sunday, January 12, 2014 8:52 AM
  • Hi any other solution.

    i have already done this change but i didn't had any successful results.

    I have the same issue on IFD CRM 2011 and with this change it works but now in CRM 2013 didn't worked any ideas?

    we may need to open another port than 443 for this purpose?

    thanks

    Saturday, November 1, 2014 7:57 AM
  • If your CRM is installed on the same server with ADFS, then try following:

    1. Open PowerShell

    2. Type: Set-ADFSProperties –nettcpport 809

    3. Hit enter

    Wilson

    Monday, November 3, 2014 6:09 AM