locked
CRM 4.0 upgrade from CRM 3.0 - IIS check fails RRS feed

  • Question

  •  

    I am attempting to upgrade my CRM 3.0 server to CRM 4.0.  CRM 3.0 is working correctly.  CRM server is installed on a Windows 2003 sp2 server  with a seperate Windows 2003 sp2 server running SQL 2005 and SQL reporting services.

     

    When I get to the step in the setup where it checks system requirements I get one error and 1 warning (the warning is that there are existing workflows that reference a Post URL action.  These workflows cannot be upgraded).  The error is the problem:

    "IIS - The web site's NTAuthenticationProviders must be Negotiate,NTLM."

     

    I have confirmed (looking at the registry) that my CRM installation is using w3svc/1 (the default website) and when I run cscript adsutil.vbs get w3svc/1/root/NTAuthenticationProviders  -  I get string "Negotiate,NTLM"

     

    I have tried setting it to NTLM and then back to Negotiate,NTLM  but the check still fails.

     

    Can some one give me some pointers as to what might be going on and how to trouble shoot.  

     

    Thanks in advance for any assistance you can provide.

    Monday, February 11, 2008 6:02 PM

All replies