locked
CRM 2011 RU10 causes CrmDiscoveryService.asmx to not be found - why? RRS feed

  • Question

  • Hi. I manage a 3rd party application that connects from the cloud to CRM using the old 2007 webservices.

    With rollup 10 this no longer works with the following code, and we get 404 not found error messages from the discovery service.

                            CrmDiscoveryService discoveryService = new CrmDiscoveryService();
                            discoveryService.Url = orgdetail[1];
                            RetrieveCrmTicketRequest ticketRequest = new RetrieveCrmTicketRequest();
                            ticketRequest.OrganizationName = _OrgID;
                            if( orgdetail[0].Equals("hosted") )
                            {
                                ticketRequest.UserId = orgdetail[4];
                                ticketRequest.Password = orgdetail[5];
                            }
                            RetrieveCrmTicketResponse ticketResponse = null;
    
                            if( orgdetail[0].Equals("hosted") ) ticketResponse = (RetrieveCrmTicketResponse)discoveryService.Execute(ticketRequest);
                            CrmExtensions.NN.Config.CrmSdk.CrmAuthenticationToken token = new CrmExtensions.NN.Config.CrmSdk.CrmAuthenticationToken();
                            token.AuthenticationType = orgdetail[0].Equals("hosted") ? 2 : 0;
                            token.OrganizationName = _OrgID;
                            if( orgdetail[0].Equals("hosted")) token.CrmTicket = ticketResponse.CrmTicket;
                            if (!String.IsNullOrEmpty(guid)) token.CallerId = new Guid(guid);
                            service.Url = orgdetail[2];
                            if (orgdetail[0].Equals("onpremise"))
                            {
                                string[] creds = orgdetail[4].Split('\\');
                                if( creds.Length != 2 ) throw new ArgumentException("Invalid username - must be domain\\user");
                                service.Credentials = new NetworkCredential(creds[1], orgdetail[5], creds[0]);
                            }
                            service.CrmAuthenticationTokenValue = token;
                            if( orgdetail[0].Equals("hosted") ) _webServiceExpTime = System.Convert.ToDateTime(ticketResponse.ExpirationDate);
    What can cause this? I've scanned through the changelog of RU10 and found nothing relating to the availability of CrmDiscoveryService.asmx.

    Tuesday, September 4, 2012 12:00 PM

Answers

  • We have logged this as an issue with MS. I've just had this feedback from a colleague:

    OK Microsoft just called me. As we suspected, it is a “known issue” and is a “high priority with lots of visibility”. It will be fixed in the next rollup (rollup 12) but the release date for that has not yet been decided. There is also a separate patch coming out specifically for this issue “real soon” for those who don’t want rollup 12.

    Friday, November 2, 2012 12:01 PM

All replies

  • I'd even like to know if other people are experiencing the same problem; I know we have two applications both suffering from the same problem. If you're reading this and are experiencing the same problem after installing UR10, tell me.

    Tuesday, September 4, 2012 2:43 PM
  • We just installed UR 10 and we're having the same problem.

    This is really serious as we have a lot of software developed using the 2007 end points that now don't work.

    Please let me know if you find a solution out of this forum.

    Thanks

    Thursday, September 6, 2012 6:09 AM
  • I just figured out I'm able to connect to the ASMX file through IE if I log into CRM via ADFS first. Not sure if this helps, though in the past I haven't had to log in first...

    Thursday, September 6, 2012 7:17 AM
  • Hi Jacob.

    I've contacted Microsoft regarding the issue and they're working on it; they say they're able to reproduce it only in environments using HTTPS with ADFS. Is this your setup too?

    We have this setup with all of our customers that are experiencing problems.

    Friday, September 7, 2012 3:31 PM
  • Hi Emil,

    We are running in an environment using HTTPS and ADFS. I've contacted Microsoft as well, though I am yet to hear a response.

    Please keep me posted.

    Thanks

    Sunday, September 9, 2012 10:57 PM
  • Exact same issue with HTTPS and ADFS.

    Get a 404 and once I login via ADFS I can get to the service through IE.

    Any official word on this?

    Tuesday, September 11, 2012 2:02 AM
  • Any update for MS regarding this issue?

    Wednesday, September 12, 2012 11:30 PM
  • We also have an add on based on CRM 4 that worked fine with CRM 2011 IFD but our first customer went to CRM 2011 Rollup 10 last night and this AM our CRM add on stopped working for them with a failure trying to access the discovery service (404: Not Found).

    Grant Schenck

    Thursday, September 13, 2012 12:39 PM
  • Just to post an update on the situation:

    Microsoft has acknowledged that there is an issue with the 2007 web services in setups using HTTPS and ADFS. They are investigating the issue.

    Thursday, September 13, 2012 12:53 PM
  • After to speaking to Microsoft support, I have also been told it's a known issue and that they are investigating it.

    I was also told that this could take up to three months.

    In the meantime they said that uninstalling UR10 will fix the issue, we'll be doing this over the weekend (Australian time) and I'll post up the results when it's done.

    Hope this helps someone.

    • Proposed as answer by Jacob Appleton Thursday, September 13, 2012 11:25 PM
    • Unproposed as answer by Jacob Appleton Monday, September 17, 2012 3:57 AM
    Thursday, September 13, 2012 11:25 PM
  • Three months?!
    Sunday, September 16, 2012 11:21 PM
  • Ok, so we did the uninstall on Friday night and tried to access the CrmDiscoveryService.asmx file through both IE and the applications we have developed that use this service and in both instances, we received a 401: Unauthorized error instead. To make matters worse, on Monday morning, we found that all plugins were failing with the error "Unable to load plug-in type" (thanks Microsoft support =[ ).

    We traced the issue to missing CRM 4 DLL's in the GAC. We installed the DLLs from the bin folder of the CRM 4 SDK and then we got a "Unable to cast object of type 'xxxx' to type 'Microsoft.Crm.Sdk.IPlugin'" error instead. After following the instructions posted here: http://kennyvaes.wordpress.com/2012/04/10/unable-to-cast-object-of-type-xxxx-to-type-microsoft-crm-sdk-iplugin/ we now have working plugins and the CrmDiscoveryService.asmx is now accessible from IE and software.

    Basically we think that the uninstall removed the CRM 4 DLLs from the GAC which caused all of our problems this morning, however we are going to test next weekend to see if installing Update Rollup 10 and re-installing the CRM 4 DLLs to the GAC will fix the CrmDiscoveryService issue as well. I'll keep you posted on our results.

    tl;dr: To fix this issue, uninstall CRM 2011 Update Rollup 10, install the DLLs from the bin folder of the CRM 4 SDK to the GAC of the CRM 2011 server and follow the instructions here: http://kennyvaes.wordpress.com/2012/04/10/unable-to-cast-object-of-type-xxxx-to-type-microsoft-crm-sdk-iplugin/.


    Monday, September 17, 2012 3:57 AM
  • I'm having problems reaching the legacy discovery web service on a CRM 2011 with IFD and are getting the same symptoms as you are describing above. I can reach it in a browser when I'm logged in to the CRM but not otherwise. I get a 404 from the browser when I'm trying to reach the web service and I get a message saying too many redirects when I try to connect using VS 2010. We want to install a third party product that uses the legacy web services so it would be very nice indeed to get this to work. The solution on the kennyvaes blog did not help me since that info is already in the web.config in the CRMWeb-folder.

    What DLLs did you copy to the GAC?

    (Edit, this is a CRM 2011 installed fresh and updated to UR8 so no influence of UR10, just having problems with the legacy disco service.)

    Thanks,


    Rickard Norström Developer CRM-Konsulterna
    http://www.crmkonsulterna.se
    Swedish Dynamics CRM Forum: http://www.crmforum.se
    My Blog: http://rickardnorstrom.blogspot.se


    Tuesday, September 18, 2012 8:03 AM
  • We had the same exact situation with UR10 with our IFD of CRM 2011.  Everything worked great in our http test environment but once we applied it to an IFD our tool crashed.  Uninstalling UR10 from CRM back to UR8 restored our custom tool connection.  We were advised by Microsoft it could be months before an answer as well and that the 2007 SDK Endpoints would eventually be going away permanently so our developer is revamping our tool with the new 2011 SDK Endpoints for testing.

    Kristen Elliott

    • Proposed as answer by JFoerch Monday, October 1, 2012 3:01 PM
    • Unproposed as answer by JFoerch Monday, October 1, 2012 3:01 PM
    Wednesday, September 26, 2012 5:04 PM
  • We had the exact same problem. We have some existing integrations that utilize the CRM 4.0 endpoint. After applying UR10 over the weekend, these integrations stopped working all together. I was able to work around the issue by going to http://server/mscrmservices/2007/crmservice.asmx vs. https://server/mscrmservices/2007/crmservice.asmx. This prevents your code from jumping through the ADFS authentication and ultimately causing the 404 error. This looks to have worked for us, hope it helps.
    Monday, October 1, 2012 3:03 PM
  • Hi Kristen - how did you go about uninstalling UR10 to go back to UR8?

    Thanks!

    Leslie

    Tuesday, October 23, 2012 9:49 PM
  • Hi,

    We are getting the same problem using claims based authentication over https. This has broken various legacy code we have as well as preventing Stunnware tools from connecting.

    We were hoping rollup 11 would fix this as it contains this line in the release notes:

    • When you access a CRM website in a claims authentication deployment, the Authentication Engine may reject the request. In this situation, you receive the following error message:
      404 - File or directory not found.

    But still the same problems. Even browsing to the 4.0 discovery service endpoint via IE gives the same 404 error.

    Has this been officially recognised by MS as an issue? Is there an ETA for a fix?

    Currently we are rolling back to RU8 but obviously this isn't a long term solution.

    Thanks,

    Christian

    Wednesday, October 31, 2012 2:44 PM
  • Hi. They've said they would write back when they had any news - nothing so far... and I don't think UR11 fixes it, at least not according to some of my customers.

    We've resorted to upgrading to the 2011 WebServices which we had to do at some point anyway to include Office365 online versions of CRM.

    Wednesday, October 31, 2012 2:55 PM
  • We have logged this as an issue with MS. I've just had this feedback from a colleague:

    OK Microsoft just called me. As we suspected, it is a “known issue” and is a “high priority with lots of visibility”. It will be fixed in the next rollup (rollup 12) but the release date for that has not yet been decided. There is also a separate patch coming out specifically for this issue “real soon” for those who don’t want rollup 12.

    Friday, November 2, 2012 12:01 PM
  • Hi Christian,

    when MS will release patch for your issue (it's also our issue. CrmService not works with https ADFS with error http 404!), can you give us a link to download it?

    Thank you very much,

    Alberto


    Alberto

    Saturday, November 3, 2012 10:09 AM
  • Hi Christian,

    Did MS provide or promise any KB?
    Nowadays, the fixes have no KB reference which means we are missing on useful information like Symptoms or Workarounds..

    -Will


    William Toh | 3P Solutions Pte Ltd | Dynamics CRM Partner

    Monday, November 5, 2012 7:25 AM
  • Hi Christian,

    You managed to get the hotfix?


    William Toh | Dynamics CRM

    Thursday, November 15, 2012 11:49 AM
  • We did receive a hotfix from Microsoft but we were told this would have to be uninstalled before Rollup 12 is applied so we are staying on Rollup 8 until Rollup 12 is released.  I don't think the hotfix is published I think this is something they are giving out on a case by case basis.

    Kristen Elliott

    Monday, December 10, 2012 5:04 PM
  • What was the hotfix number for the fix you received?
    Monday, December 10, 2012 11:36 PM
  • It wasn't in a kb it was a website where we had to download the files.

    Kristen Elliott

    Tuesday, December 11, 2012 12:24 AM
  • I understand that, but usually the hotfix will still have a number associated with it.
    Tuesday, December 11, 2012 12:25 AM
  • I understand that, but usually the hotfix will still have a number associated with it.

    For what it's worth, this issue was resolved for us after contacting Microsoft support who provided the Critical On Demand (COD) hotfix KB2779364 which was initially released on the 29th of November 2012.

    We were told that it would be included in Update Rollup 12 (this was before the on-premise UR12 server components were re-released), which does seem to be the case based on the UR12 release notes (http://support.microsoft.com/kb/2795627):
    After you install Microsoft Dynamics CRM 2011 Update Rollup 10, and when the Claims Base Authentication feature is enabled, you cannot access the Microsoft Dynamics CRM 2007 endpoints.

    Friday, February 1, 2013 2:59 AM
  • Hello I found this thread because the config not longer works.. but we applied RU12 and we are now running into this issue....

    Someone else also? Any Ideas?


    gruss Daniel Ovadia MBSS - Microsoft Dynamics CRM MCNPS

    Friday, February 1, 2013 3:27 PM
  • Hi Daniel,

    As seen above, we thought Rollup 11 fixes the issue but it did not.

    Are you saying you installed Rollup 12 and you still have the issue? Did you install the original RU12 or th re-released one?

    I have requested my infra guys to install RU12 in our DEV but this will not be so soon..


    William Toh | Dynamics CRM

    Monday, February 4, 2013 9:30 AM
  • Hi William,

    yes I have installed the re-release RU12 v2. Today it seems that the error went away, but I only updated the adfs metadata again..


    gruss Daniel Ovadia MBSS - Microsoft Dynamics CRM MCNPS

    Monday, February 4, 2013 9:36 AM
  • We are having the same problem in our test-environment. Had to remove Rollup 12 v2. JScript functions accessing the 2007 asmx service fail. (In our development environment with UR12, it works...). In test we're running Dynamics Connector for AX - which also stopped working after this update. Outlook clients are running UR12 (32 bit on Office 2010) - startup time has become a HUGE problem - but that's another ticket... 


    Tuesday, February 12, 2013 1:41 PM
  • Hi Jan Olav Strandman, we are also having major startup time issues and are trying to work out a fix, have you got another post that you are discussing this that you can link me too?  Also any news from Microsoft on that ticket?
    Monday, February 18, 2013 12:35 AM
  • I just wanted to let people know I was having this problem, but after installing Update Rollup 13 it fixed my issues.
    Tuesday, May 28, 2013 6:03 AM