locked
Connector: Error 1802 (Failed to issue certificate) RRS feed

  • Question

  • Hi,

    the following problem: If I install the Connector software, it finds my server, everything normal, shows me also my password hint and even if I type a wrong password. However then the following error comes:

     

    This operation cannot be completed at this time.

    Please try again later. If the problem persists, please contact Windows Home Server support.

     

     

    And in the Eventviewer the following:

     

    Event Type: Error
    Event Source: HomeServer
    Event Category: Connection
    Event ID: 1802
    Date:  19.08.2007
    Time:  18:03:11
    User:  N/A
    Computer: Server
    Description:
    Failed to issue certificate C2FB0BE96F8F647E1AD2D7717B9F1AEEF with error code 0.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

     

     

    On the linked MS-Site the Event-ID is not listed.


    What could I make? Restart and such a thing I naturally already tried and there are no errors during the windows start. I have absolutely no idea, where or why this certificate is important.


    Thanks!

    Alex

     

     

    Sunday, August 19, 2007 6:18 PM

Answers

  • I had the same issue it turns out MakeCert.exe did not have permission to make the key so I changed the permissions in the keys folder and was able to install all my connectors. I discovered this by using the Sysinternals successor to filemon.

    • Proposed as answer by daleykd Friday, January 1, 2010 12:33 AM
    • Marked as answer by Jonas Svensson -FST- Thursday, January 28, 2010 11:39 PM
    Sunday, October 18, 2009 10:41 PM

All replies

  • Hi Alex,

    you should check your time and date settings on the Home Server... is there a big difference between them and those of the clients?

    Thanks,

    Christoph
    • Proposed as answer by levelbest Sunday, August 7, 2011 5:54 PM
    Sunday, August 19, 2007 6:32 PM
  •  

    No, the time is correct and updated via ntp ..
    Sunday, August 19, 2007 7:10 PM
  • I'm having the same issue, no resolution.

     

    Saturday, March 1, 2008 9:14 AM
  • This might be happening because it was Feb 29th..  Have you tried again since it's the 1st now?
    Saturday, March 1, 2008 9:26 AM
  • I know this is a very old thread, however I had the same symptoms and didn't discover the answer that worked for me anywhere on the net;

    I ran a great utility from Sysinternals called "FileMon" (I suggest you get it, it's invaluable!!) on the server while a client attempted to make the connection. After analysing the output, I found the source of my certificate woes;
    cmd.exe:1960 DIRECTORY C:\WINDOWS\system32\ NO SUCH FILE
    cmd.exe:1960 DIRECTORY C:\WINDOWS\system32\ NO SUCH FILE
    cmd.exe:1960 DIRECTORY C:\WINDOWS\system32\ NO SUCH FILE
    cmd.exe:1960 DIRECTORY C:\Program Files\Support Tools\ NO SUCH FILE
    cmd.exe:1960 DIRECTORY C:\Program Files\Support Tools\ NO SUCH FILE
    cmd.exe:1960 DIRECTORY C:\Program Files\Support Tools\ NO SUCH FILE
    cmd.exe:1960 DIRECTORY C:\WINDOWS\system32\ NO SUCH FILE
    cmd.exe:1960 DIRECTORY C:\WINDOWS\system32\ NO SUCH FILE
    cmd.exe:1960 DIRECTORY C:\WINDOWS\system32\ NO SUCH FILE
    cmd.exe:1960 DIRECTORY C:\WINDOWS\ NO SUCH FILE
    cmd.exe:1960 DIRECTORY C:\WINDOWS\ NO SUCH FILE
    cmd.exe:1960 DIRECTORY C:\WINDOWS\ NO SUCH FILE
    cmd.exe:1960 DIRECTORY C:\WINDOWS\System32\Wbem\ NO SUCH FILE
    cmd.exe:1960 DIRECTORY C:\WINDOWS\System32\Wbem\ NO SUCH FILE
    cmd.exe:1960 DIRECTORY C:\WINDOWS\System32\Wbem\ NO SUCH FILE
    cmd.exe:1960 DIRECTORY C:\WINDOWS\system32\WindowsPowerShell\v1.0\ NO SUCH FILE
    cmd.exe:1960 DIRECTORY C:\WINDOWS\system32\WindowsPowerShell\v1.0\ NO SUCH FILE
    cmd.exe:1960 DIRECTORY C:\WINDOWS\system32\WindowsPowerShell\v1.0\ NO SUCH FILE

    Essentially, the connector trys a bunch of times to find "MakeCert.exe" to create the client certificate, and never locates the application. For me, MakeCert.exe was located in C:\Windows\MakeCert\MakeCert.exe.
    So I simply copied the utility to the C:\Program Files\Support Tools\ (seemed like the most logical of the options). Low and behold, problem solved.
    (Note: This was all done ON THE SERVER using RDP - not the client)

    EDIT: Sorry - crytical piece of info missing, all the FILE NOT FOUND errors actually read more like this;
    cmd.exe:1960 DIRECTORY C:\WINDOWS\system32\ NO SUCH FILE FileBothDirectoryInformation: makecert.exe
    cmd.exe:1960 DIRECTORY C:\WINDOWS\system32\ NO SUCH FILE FileBothDirectoryInformation: makecert.exe"*
    cmd.exe:1960 DIRECTORY C:\WINDOWS\system32\ NO SUCH FILE FileBothDirectoryInformation: makecert.exe

    If not now, when?
    Thursday, April 23, 2009 12:26 AM
  • I had the same issue it turns out MakeCert.exe did not have permission to make the key so I changed the permissions in the keys folder and was able to install all my connectors. I discovered this by using the Sysinternals successor to filemon.

    • Proposed as answer by daleykd Friday, January 1, 2010 12:33 AM
    • Marked as answer by Jonas Svensson -FST- Thursday, January 28, 2010 11:39 PM
    Sunday, October 18, 2009 10:41 PM
  • I had the same issue it turns out MakeCert.exe did not have permission to make the key so I changed the permissions in the keys folder and was able to install all my connectors. I discovered this by using the Sysinternals successor to filemon.


    This was EXACTLY my issue.  I was pulling my hair out after 24 hrs of frustration.

    The folder was located at: C:\Documents and Settings\All Users\Application Data\Microsoft\Crypto\RSA\MachineKeys.  I had to give SERVER\Administrators Full Access, and it FINALLY worked.

    Thanks!
    Friday, January 1, 2010 12:33 AM
  • I encountered the same issue with my Acer Aspire easyStore H340 Windows Home Server.

    To solve it I only had to add %SystemRoot%\MakeCert to my system path.

    1. Log in to the Windows Home Server using Remote Desktop.
    2. Click "Start", right-click on "My Computer" and select "Properties"
    3. Click on the "Advanced" tab
    4. Click the "Environment Variables" button
    5. In the "System variables" section at the bottom of the dialog window, scroll down until you see the "Path" field
    6. Select the "Path" field and click the "Edit" button.
    7. Items in the path are separated by a ";" otherwise known as semicolon. Add the path using one of the methods below.
      ";%SystemRoot%\MakeCert" to the very end, OR
      "%SystemRoot%\MakeCert;" to the very beginning, without the "" marks.
    8. Click "OK" on the 3 windows that are open, then reboot the server.

    Once the server is restarted, install the WHS Connector software on the PC, and all should be well.

     

    • Proposed as answer by phreaq app Friday, November 19, 2010 5:23 PM
    Sunday, May 30, 2010 7:19 PM
  • Finally found my answer.  Thanks you so much Big Dumb Yak.  That is just funny typing.  I have been searching for 3 days.  Thanks.
    Friday, July 23, 2010 1:40 PM
  • I encountered the same issue with my Acer Aspire easyStore H340 Windows Home Server.

    To solve it I only had to add %SystemRoot%\MakeCert to my system path.

    1. Log in to the Windows Home Server using Remote Desktop.
    2. Click "Start", right-click on "My Computer" and select "Properties"
    3. Click on the "Advanced" tab
    4. Click the "Environment Variables" button
    5. In the "System variables" section at the bottom of the dialog window, scroll down until you see the "Path" field
    6. Select the "Path" field and click the "Edit" button.
    7. Items in the path are separated by a ";" otherwise known as semicolon. Add the path using one of the methods below.
      ";%SystemRoot%\MakeCert" to the very end, OR
      "%SystemRoot%\MakeCert;" to the very beginning, without the "" marks.
    8. Click "OK" on the 3 windows that are open, then reboot the server.

    Once the server is restarted, install the WHS Connector software on the PC, and all should be well.

     


    THANK YOU SO MUCH!!!!!!!!!

    I have tried all the other suggestions on the net with no success, I finally stumbled upon this one, and it worked for me. I cannot thank you enough!!

    Friday, November 19, 2010 5:18 PM
  • I encountered the same issue with my Acer Aspire easyStore H340 Windows Home Server.

    To solve it I only had to add %SystemRoot%\MakeCert to my system path.

    1. Log in to the Windows Home Server using Remote Desktop.
    2. Click "Start ", right-click on "My Computer " and select "Properties "
    3. Click on the "Advanced " tab
    4. Click the "Environment Variables " button
    5. In the "System variables " section at the bottom of the dialog window, scroll down until you see the "Path " field
    6. Select the "Path " field and click the "Edit " button.
    7. Items in the path are separated by a ";" otherwise known as semicolon. Add the path using one of the methods below.
      ";%SystemRoot%\MakeCert " to the very end, OR
      "%SystemRoot%\MakeCert; " to the very beginning, without the "" marks.
    8. Click "OK " on the 3 windows that are open, then reboot the server.

    Once the server is restarted, install the WHS Connector software on the PC, and all should be well.

     


    THANK YOU SO MUCH!!!!!!!!!

    I have tried all the other suggestions on the net with no success, I finally stumbled upon this one, and it worked for me. I cannot thank you enough!!


    I am having the same issue.  I have tried the above steps and I am still stuck.  I get to the point where it asks me for the server password.  I enter the password and then get the message:

     

    This operation cannot be completed at this time.
    
    Please try again later. If the problem persists, please contact Windows Home Server support.

     

     

    Any help is appreciated.

    Wednesday, November 24, 2010 9:24 AM
  • Try logging in to your server using keyboard, video, and mouse. Then check the time, date, and time zone on the server, the client you're having troulbe with, and a computer that you aren't having trouble with.
    I'm not on the WHS team, I just post a lot. :)
    Wednesday, November 24, 2010 2:20 PM
    Moderator
  • I had the same issue it turns out MakeCert.exe did not have permission to make the key so I changed the permissions in the keys folder and was able to install all my connectors. I discovered this by using the Sysinternals successor to filemon.


    This was EXACTLY my issue.  I was pulling my hair out after 24 hrs of frustration.

    The folder was located at: C:\Documents and Settings\All Users\Application Data\Microsoft\Crypto\RSA\MachineKeys.  I had to give SERVER\Administrators Full Access, and it FINALLY worked.

    Thanks!

    Thanks, after a lot of searching finally the solution. Greatings from Holland
    Saturday, January 15, 2011 4:16 PM
  • Thank You Thank You Thank You Thank You Thank You Thank You Thank You Thank You Thank You Thank You Thank You Thank You Thank You Thank You Thank You Thank You Thank You Thank You

     

    I have been going krazy over this issue. Finally found the correct answer. thank you once again

    Friday, March 18, 2011 6:25 AM
  • I spent hours searching threads, and I think it was this that finally got it going for me.  Thank you guys SO much!!

     

    Also, another idea... I was looking through event logs, and the WHS Port Forwarding service was disabled, and generating errors because another WHS service couldn't start.  I enabled it the same time I did the key permission change, so I don't know which one fixed it for me.  Might be something to think about.

    Wednesday, September 7, 2011 7:42 AM