locked
Tip for Adding a Troublesome External USB 3.0 Hard Drive to the WHS (v1) Storage Pool RRS feed

  • General discussion

  • Recently added a Buffalo USB 3.0 PCI-e (2 port) card to my WHS, and picked up a USB 3.0 docking station for 2.5" and 3.5" SATA drives. 

    In attempting to add a 500GB SATA drive to the storage pool, I kept getting the "hard drive initialization failed" - The wizard was unable to create a volume on the drive" error, noted elsewhere. Unfortunately, none of the other tips found on the forum worked (diskpart/clean, reformat, add to backup then move to storage pool...). What finally did work was as follows - hopefully someone can get some use out of this info: 

    1. Connect the Docking Station & Drive to another computer running windows (doesn't matter if it's only a USB 2.0 connection)
    2. Format to NTFS (quick format is OK)
    3. Unmount drive, plug into WHS on USB 2.0 port
    4. Open WHS Console, add drive to storage pool
    5. Once drive has been added, power down WHS server
    6. Swap plug on newly added drive from USB 2.0 port to USB 3.0 port
    7. Turn WHS server back on
    8. Drive recognized as part of the pool and operating at USB 3.0 speed. 

    To back up a few steps, originally I had plugged the dock/drive into the newly installed USB 3.0 card. The drive had previously been used in a Linux install, so the format wasn't readable by WHS - that was no surprise, I was expecting to format. It started to go downhill when attempting to use the WHS disk manager (diskmgr.msc) - while the disk was recognized and I could create a "blank" partition, any type of NTFS formatting failed (searching these forums, this appears to be relatively common). The only way it worked at all was to take the computer to another machine to format it, then bring it back to the WHS server. At that point I was able to see the drive and test the speed with USB 3.0 (damn fast), but every time I added it to the server pool or tried to use it for server back up (without preserving the existing volume), it failed. Attempting to add the drive to the server pool through a USB 2.0 port was just part of making sure all the equipment was functioning properly. I'm not sure why it worked, but...whatever. 

    For those interested, my WHS setup is as follows: 

    • Dell PowerEdge T105 Server (4GB RAM, 2.31GHz AMD Athlon Dual Core 4450B, gigabit ethernet)
    • 4x 2TB Western Digital "Green" SATA drives
    • 3x 1TB Western Digital External USB 2.0 drives
    • 1x 500 Western Digital SATA II connected through the USB 3.0 dock (will be replaced with a 2TB drive when I get around to purchasing)

     

    • Changed type radar_dx Wednesday, January 5, 2011 11:40 PM Not really a question..
    • Changed type radar_dx Wednesday, January 5, 2011 11:40 PM Not really a question..
    Wednesday, January 5, 2011 11:39 PM

All replies

  • Personally, I would be concerned about reintegrating that drive in the event of a server failure that requires a reinstallation of the OS...
    I'm not on the WHS team, I just post a lot. :)
    Thursday, January 6, 2011 1:28 AM
    Moderator
  • Absolutely a valid point, and one that (I admit) I hadn't considered. 

    Given the apparent mobility of external USB drives between ports, I'd imagine it'd have to be done over a USB 2.0 port, then moved back to a USB 3.0 port after the OS re-install was completed. 

    ...I've had the good fortune to avoid such an occurrence so far however, so that's just a guess on my part. Any particular "gotchas" with reinstalling the OS when it comes to external drives that could be an issue? 

    Thursday, January 6, 2011 2:09 AM
  • This USB 3.0 Expresscard is designed for your laptop's expresscard slot, the small thin slot that's probably on the left or right side of your laptop and is found on most laptops these days. This expresscard is of the 34mm variety, and will fit into virtually any expresscard slot.    http://www.espow.com/wholesale-pcmcia-express-usb-3-0-2-port.html

    Monday, January 17, 2011 3:02 AM