locked
"ShellExtension.dl failed to register." ICE 2.0.3 fails to start and cannot be Repaired. RRS feed

  • Question

  • My 64-bit version of ICE 2.0.3 worked flawlessly for months but today it failed to start. The last time I used it successfully was January 6th. The only recent change to my PC is a small batch of automatic security updates to Windows 8.1. If that's the culprit then a dependency has broken.

    Attempting to start ICE results in a slight flicker (focus changes to a window that is never drawn) and nothing else. I used "Control Panel > Programs and Features" to Repair the instance but it generates the following error message:

    Module C:\Program Files\Microsoft Research\Image Composite Editor\ShellExtension.dl failed to register. HRESULT -2147024770. Contact your support personnel.

    Clicking "Try again" produces nothing except the same message. Clicking "Ignore" continues the Repair process but fails to correct ICE. I have not attempted to re-install it because I suspect it will choke at the same point in the process.

    I've seen older posts reporting the same problem and there have been no answers. Is ICE still being developed and supported? I hope so because this problem effectively renders it non-functional.

    Does anyone have a solution?





    • Edited by T.T.D Monday, January 25, 2016 8:51 PM
    Monday, January 25, 2016 8:46 PM

All replies

  • I was wrong about assuming a re-installation would fail to correct the problem. I fixed it by re-installing ICE. Here's what I did:

    1. Uninstall ICE 2.0.3.
    2. Remove the ICE related folder from C:\Users\<Name>\AppData\Local\Microsoft.
      This is probably unnecessary but I did it for thoroughness.
    3. Install Microsoft Visual C++ 2013 Redistributable (x64).
      You're prompted to install it when running the ICE installer.
    4. Install ICE 2.0.3 (x64).

    During the installation of ICE, it prompted me to install VC++ 2013 Redistributable. This package must have been installed at some point because it is needed by ICE and it worked fine for months. I've confirmed uninstalling ICE does not automatically remove VC++ 2013 Redistributable. Perhaps some other program I uninstalled recently (although I don't recall doing that in the last three weeks) removed the Redistributable along with it. <shrug>

    TL;DR

    If ICE 2.0.3 fails to start, confirm you have VC++ 2013 Redistributable installed.

    Tuesday, January 26, 2016 3:36 PM