locked
Action Microsoft.Crm.Setup.Server.CreateSetupUserAction failed RRS feed

  • Question

  • Hey.

    I am trying to set up a CRM 3.0 test environment based on a live CRM database, to a _different_ domain. So what i do is:
    1.Backup CRM databases from live
    2.Restore them into the new server (also deleting all SQL users, just in case)
    3.Using redeploy tool to match AD users
    4.Install CRM

    Everything goes fine until during the CRM installation i get error message saying "Action Microsoft.Crm.Setup.Server.CreateSetupUserAction failed".

    Now from the error log file, i can see that the problem is that it cannot find a user with a certain GUID. That value references to "SYSTEM" user 
    in SystemUser table based on SystemUserId value. Can anyone tell me, what is the problem here?

    Since i succeeded setting up a test environment within the _same_ domain with our development CRM database, doing exactly the same steps, i think it has to do something with the new domain. Since it seems it's the only thing different (as i dont think the database itself has anything to do with it, live vs development; and server OS (2003) is the same as well, with user who installs having full administrator rights, etc).

    But "SYSTEM" user should be a special user in CRM with no reference to Active Directory, so i dont know what do try more. I even tried deleting SYSTEM user before step 4, hoping the installation will create them, but it gave me another error message about Business Unit not found for system user.

    Regards,
      Martin.
    Monday, May 31, 2010 6:59 AM

Answers

  • If you have the CRM 3.0 media (CD's), look in the /RedeploymentTool folder, and you will find a PDF (instructions) and a .MSI file (tool to run during process).

     


    Jeff Loucks | Available Technology | 888-474-2237 | http://msmvps.com/blogs/jeffloucks
    • Proposed as answer by Jeff Loucks Tuesday, October 5, 2010 7:58 AM
    • Marked as answer by Jim Glass Jr Wednesday, October 6, 2010 8:35 PM
    Tuesday, October 5, 2010 7:58 AM