locked
CRM 2013 - Unable to Save Appointments RRS feed

  • Question

  • I have just recently upgraded our company's CRM from 2011 to 2013. We are using an on-premise system.

    Currently we cannot save new Appointments.  Regardless of what type of appointment I try to create; after filling in all of the required fields and clicking 'Save', nothing happens.  If I try to navigate from the page I receive a message saying the record has not been saved. 

    I can save other types of Activities, i.e. Phone calls, emails, but not Appointments.

    Any help would be greatly appreciated.

    Tuesday, February 18, 2014 2:22 PM

All replies

  • hi

    do you have some script which is preventing save on appointment.

    Trying doing a page refresh, see if you get a CRM error prompt

    Tuesday, February 18, 2014 2:37 PM
  • As far as I know there are no scripts running preventing the save.  We did not have this issue when we were on 2011.

    I tried the page refresh, but received no error prompt.

    Tuesday, February 18, 2014 2:51 PM
  • I'm having the exact same issue with the online version.  It has something to do with an unresolved email error.  I found an old KB article on a hotfix for 2011, but it seems as though the issue has surfaced in 2013.  I have a ticket in, but have yet to connect with my tech rep to troubleshoot.  I'll let you know what we find.
    Tuesday, February 18, 2014 2:58 PM
  • I figured out what was going on with my appointments.  I imported my customizations from production to my development instance.  The appointment form with my customizations was the old Information form.  That was the form I was using to test and it wouldn't save.  When I merged this to the new Appointments form and customized it as needed I was able to save using the Appointment form.  Appointments are the only activity that you can not create a new form, by importing my old cusom form with my solution I forced a new form to be created and it obviously did not like that.

    ...hope this helps with the on-premise system.

    • Proposed as answer by carol eckert Tuesday, February 18, 2014 8:58 PM
    Tuesday, February 18, 2014 8:58 PM
  • Hi,

    This is a bug that will be fixed in Rollup 2. Rollup 2 is likely to be released in the coming days.

    http://support.microsoft.com/kb/2919956

    After you upgrade Microsoft Dynamics CRM 2011 to Microsoft Dynamics CRM 2013 or import Microsoft Dynamics CRM 2011 appointment customization, you receive a pop-up error message while you are saving appointments:
    There was an error with this field’s customized event.
    Field:crmform
    Event:onsave

    Error: Object doesn't support property or method 'Form_onsave'


    MCTS. GAP Consulting Ltd. Microsoft Community Contributor Award 2011 & 2013

    Tuesday, February 18, 2014 10:26 PM
    Answerer
  • While I'm hopeful that Update Rollup 2 will fix my issue, I'm not positive.

    I don't think we had any customizations in the Appointment form and we don't receive any errors when trying to save Appointments.  When we click 'Save', we just get nothing.  The appointment is not saved and there is not error.

    Wednesday, February 19, 2014 4:38 PM
  • Hi

    When you changed the field value, did you try to click somewhere else on page and then clicking the save button ?

    Wednesday, February 19, 2014 7:47 PM
  • Yes, I have tried just about everything you could thing of to get this work with no success.
    Wednesday, February 19, 2014 7:50 PM
  • Try using fiddler and F12 developer tools then click save. CRM2013 seems to hide errors more than CRM2011, chances are there is an error it's just not popping up in a dialogue.

    MCTS. GAP Consulting Ltd. Microsoft Community Contributor Award 2011 & 2013

    Wednesday, February 19, 2014 8:07 PM
    Answerer