locked
Help with IIS virtual directory RRS feed

  • Question

  • I'm trying to add a site in IIS as a virtual directory, and I'm not having much luck.  I can add it as a new site just fine, but I want to add it as a vdir under the default web site so I don't break any normal WHS stuff.

    The site itself is called MediaFrontPage, and is used to manage various web services (XBMC, SAB, Sickbeard, CouchPotato).  

    This is what I've done:
    - Open IIS Manager
    - Right-click Default Web Site > New > Virtual Directory. 
    - Give it a name (MediaFrontPage), navigate to the directory the files are, check off permissions. (Read, Run Scripts).
    - When I attempt to access server\MediaFrontPage, I receive an error that the site doesn't support directory listing.  If I try to access \server\MediaFrontPage\index.html (which I added in the documents as a default content page) I get a 404.
    - I enabled directory browsing and got a list of the actual directory, but if I click on any of the files it goes right to a 404.  

    I know it has to be something simple, but I've been trolling google all morning and it looks like I'm doing everything correctly. Any ideas?
    • Moved by Ken WarrenModerator Friday, October 29, 2010 5:02 PM dev question (From:Windows Home Server Software)
    Friday, October 29, 2010 3:33 PM

All replies

  • Hi,

    This probably is about access rights. In short:
    The Default Web Site is running in the Default Application Pool.
    The Default Application Pool runs under the credentials of the Network Service.
    You will get a 404 error if your MediaFrontPage directory has not set acces privileges for the Network Service account.

    Solution:
    1. Add acces for "Network Service" to your website files.
    2. Configure you site to run under a custom application pool with appropriate identity

    - Theo.


    No home server like Home Server
    Saturday, October 30, 2010 9:45 PM
    Moderator