locked
Windows 7 64bit Network Printing Problems RRS feed

  • Question

  • I have recently upgraded my PC to Win 7 64 bit.  I am having lots of problems trying to connect to other printers which are shared on my local network. I have an HP laserjet 1200 which would not work when connected over the network. The error I got when attempting to connect was ''no driver found". This was after it had checked Windows update (which I have set to auto).  I then proceeded to add manually and located the correct driver on my local machine.  However this then resulted in a further error: "windows cannot locate a suitable print driver...please contact your administrator". HOWEVER if I connect the printer locally via a USB port on my PC, it installs without issue, using the same driver I attempted to use earlier.  This printer is now plugged in locally and working.  I have another OKI laser C3200 which is connected to another (32bit) Win 7 machine on my network.  There is no server; just a simple workgroup, and no other issues with sharing files etc.  The printer is shared and I have followed the same procedure as above, with the exact same result that Windows tells me the driver cannot be found.  The driver I know is the correct one as I have had this connected locally and it just works.  But I point it to the location of the correct .inf file and it's a big NO! For some reason it just will not identify it as the correct driver when I try to connect over the network instead.

    Microsoft have verified that both these printers are compatible with my OS.  I obtained a 64bit driver from the OKI website.  I have tried installing universal printer applications, and these too will not pick up the shared network printer.  I have downloaded an app from Microsoft which runs a driver check on the PC but this is a vicious circle as in order to troubleshoot the printer problem, it asks me to install the correct driver!!

    Would be very grateful to anyone who can help - most other forums suggest things I've already done and have me going round in circles.  Hoping it is something simple to fix!

    Friday, November 4, 2011 3:48 PM