locked
Response Group question RRS feed

  • Question

  • I'm trying to use OCS R2 response group to facilitate rotating on-call schedule where it looks like this:

    Step 1. Incoming call to OCS Contact #
    Step 2. Parallel ring to OCS Group takes place
    Step 3. Nobody answers after 30 seconds of caller being in queue
    Step 4. Depending on who's turn it is, forwards to the on-call persons cell phone #.

    The only step I can't figure out how to facilitate is step #4.  The only way I can think of doing it is to set each group member up with their own queue and then change the queue every Friday to the next on-call person manually.  Is there some automated way to rotate a 'no answer - forward to x', next week, 'no answer - forward to y', and so on?

    Thanks
    Tuesday, July 21, 2009 1:06 AM

Answers

  • Russ,

    Please have a look at this article I wrote:
    http://ocsguy.com/2009/06/05/18/

    It covers exactly what you are talking about.  Please let me know if you have questions.

    Hope this helps!

    -kp
    Kevin Peters MCSE/MCSA/MCTS/CCNA/Security+ blog: www.ocsguy.com
    Tuesday, July 21, 2009 1:54 AM

All replies

  • Russ,

    Please have a look at this article I wrote:
    http://ocsguy.com/2009/06/05/18/

    It covers exactly what you are talking about.  Please let me know if you have questions.

    Hope this helps!

    -kp
    Kevin Peters MCSE/MCSA/MCTS/CCNA/Security+ blog: www.ocsguy.com
    Tuesday, July 21, 2009 1:54 AM
  • Hi Kevin,

    Are you saying that forwarding to telephone number within the response group configuration doesn't work? Does it work only for internal numbers in OCS for instance? Nice work around by the way.

    Cheers
    Chris
    http://voipnorm.blogspot.com/
    Tuesday, July 21, 2009 5:04 AM
  • Chris,

    As far as I know at this point it doesn't work.  I've spoken to a few contacts at Microsoft and they weren't aware of any way to make it work to outside numbers.  One of the folks actually asked me if I could forward him my work around over so he could make a note out of it.  It may just be a case of config error, but I was never able to get it to work any other way.

    -kp
    Kevin Peters MCSE/MCSA/MCTS/CCNA/Security+ blog: www.ocsguy.com
    Tuesday, July 21, 2009 12:53 PM
  • Me neither. I dont understand the domain part of the SIP URI. Whats it expecting to see:-) So another thing I found last night while testing this out is if you forward direct to a SIP URI like chris@contos.com it will only honor Sim ring and call forward settings while the user is logged on. Whats up with that. I can understand agents and not honoring those becuase you want it based on presence but when you forward it to a person you want to take an out of hours call they are more than likely not going to logged on. They didnt think that one through very well. I want this so much to be better but it falls short in a couple of places. I will more than likely be using your work around in a couple of weeks so thanks.

    Cheers
    Chris
    http://voipnorm.blogspot.com/
    Tuesday, July 21, 2009 2:51 PM
  • Hi Kevin,

    I have a question about your work around. Its says to log on as the contact object you created to change the call forward setting. How is this possible with no AD account and no password. A contact object is basically a SIP URI and a phone number right? It sounds like you have created an AD account for this not just a contact object.

    Cheers
    Chris

    http://voipnorm.blogspot.com/
    Friday, July 31, 2009 4:28 PM
  • Chris,

    You're exactly right, it's a AD user, I used "contact object" in-appropriately in the description.

    -kp
    Kevin Peters MCSE/MCSA/MCTS/CCNA/Security+ blog: www.ocsguy.com
    Friday, July 31, 2009 5:15 PM
  • Thanks Kevin, that clears it up.

    Cheers
    Chris
    http://voipnorm.blogspot.com/
    Friday, July 31, 2009 6:44 PM
  • Hi Everyone,

    So i happen to pose this issue to a friend of mine at MSFT and the issue stems from the use of the defualt usage records which if you do not use you probably do not have any routes configured. So although this problem is solved by the workaround already mentioned there is a better, easier way to fix it.

    Doug has done a fantastic job documenting the issue and the resolution.

    http://blogs.technet.com/dougl/archive/2009/08/12/outbound-pstn-calling-from-response-groups.aspx

    Cheers
    Chris


    http://voipnorm.blogspot.com/
    • Proposed as answer by VoIPnorm Thursday, August 13, 2009 5:45 PM
    Thursday, August 13, 2009 5:45 PM