locked
Dome Warped Fisheye extremely slow (Migrated from community.research.microsoft.com) RRS feed

  • Question

  • jhavens posted on 04-04-2011 7:13 PM

    Would like to use WWT in portable dome outreach but whenever I select "Dome" (warped fisheye 16:9) the image comes to a very slow crawl.  It is so slow that it is unuseable for presentations.  This is a terrific program for outreach but unable to use it so far.  Have tried disabling Aero and a multitude of other options.  Seems to only be a problem with "Dome" selections.

    Dell laptop XPS 15, i5, 6 GB, NVIDIA GeForce GT 420M, Win 7 Home Premium, 64bit

    When using Dell GPU the slowness is encountered.  When using NVIDIA, the warped fisheye and fisheye are both black screens similar to the gentleman who posted last Fall.

    Any help is greatly appreciated.

    -Jim

    Tuesday, June 7, 2011 2:05 PM

Answers

  • jhavens replied on 04-05-2011 7:15 PM

    Jonathan,  the asteroid orbits did the trick.  Went from 1 frame/sec to 30 frames/sec.  I would be very happy to try the new alpha version and provide any useful feedback that I can.  The outreach with my dome is totally volunteer so a program like WWT is going to be an extremely valuable tool.  Thank you for your rapid and in-depth response.    -Jim

    Tuesday, June 7, 2011 2:05 PM

All replies

  • Jonathan Fay replied on 04-05-2011 4:00 AM

    You *do* want Areo on, turning off will actually slow things more.

    The warped dome mode requires at least 5 rendering passes to first render a cube map and then render it to the warp. Some features are very GPU intesive, and many mobile GPU's may have a difiicult time rendering one pass, much less 5.

    There are a few things you can do to improve the performance. Asteriods and orbits are very intensive, turn turn off minor orbits and asteroids to star with and see how that helps. Also you can slide the "Image Quality Slider" in thesettings tab.

    Use the Settings...Advanced..Show Performance Data to show the frame rate while you test these settings.

    The back screen can be to do using large textures on a machine with a smaller display resolution. Try turning Large textures off to fix this.

    There is also a alpha version with some very significant full dome improvements that I can get you if you would like to try.

    Also the Gt 420M is the slowest of all the 4 series cards. It is 5-8 times slower than the midrange desktop cards, and 10-20 times slower than the high-end cards, even with the best software optimization, this won't perform like a good desktop GPU.

    Jonathan

    Tuesday, June 7, 2011 2:05 PM
  • jhavens replied on 04-05-2011 7:15 PM

    Jonathan,  the asteroid orbits did the trick.  Went from 1 frame/sec to 30 frames/sec.  I would be very happy to try the new alpha version and provide any useful feedback that I can.  The outreach with my dome is totally volunteer so a program like WWT is going to be an extremely valuable tool.  Thank you for your rapid and in-depth response.    -Jim

    Tuesday, June 7, 2011 2:05 PM