locked
HTML page interferes with menustrip RRS feed

  • Question

  • Hi Everyone,

    I am having a problem while configuring an HTML webresource in CRM 2013. I created the resource, and added to the sitemap with Sitemap Editor. When I navigate to the resource in the menu, it shows up fine, but when I navigate away, part of the menustrip is not visible from the HTML page. I suspect the layers are set incorrectly. Do you have any suggestions how can I resolve this issue?

    Regards,

    Adam

    Friday, October 10, 2014 10:00 AM

Answers

  • Hi,

    I managed to solve the problem. It turns out that the silverlight application nested in my HTML page ignores z-index property unless it is told not to. I had to set the

    <param name="windowless" value="true"/>

    Parameter on my silverlight control.

    • Marked as answer by Adam Borsik Friday, October 10, 2014 1:19 PM
    Friday, October 10, 2014 1:19 PM

All replies

  • Hi Adam, 

    You can edit sitemap using this tool below.

    https://xrmtoolbox.codeplex.com/releases/view/116287


    Polat Aydın Crm Software Developer

    Friday, October 10, 2014 10:03 AM
  • Hi,

    I am currently using this tool's editor for sitemap editing. However, the issue is not with sitemap editing itself, but the HTML resource covering up some of the area where the drop-down menu should be.

    Friday, October 10, 2014 10:10 AM
  • it is interesting. I send you some screen shots that ı used in my project. You can see the custom menu item below.

    When you select the multisearch menu item , custom html shows up. I think it caused from your css code.Can you give margin-top of body in your html.



    Polat Aydın Crm Software Developer

    Friday, October 10, 2014 10:41 AM
  • Hi,

    Setting the top margin does help, but in that case I lose valuable space. I also tried to set the z index to negative, but it did not help.

    Any other ideas? 

    Friday, October 10, 2014 12:51 PM
  • Hi,

    I managed to solve the problem. It turns out that the silverlight application nested in my HTML page ignores z-index property unless it is told not to. I had to set the

    <param name="windowless" value="true"/>

    Parameter on my silverlight control.

    • Marked as answer by Adam Borsik Friday, October 10, 2014 1:19 PM
    Friday, October 10, 2014 1:19 PM