locked
Can't active Live1Care with a Canadian address RRS feed

  • Question

  • When I try to activate Live1Care - I enter my address - I am from Canada - and there is no where to enter a province (instead of a state) - so I can't subscribe

    I get denied every time

    What should I do

    Tony

     

    Thursday, February 28, 2008 3:17 PM

Answers

  • Try these ideas:

    Go into Internet Explorer and click Tools / Internet Options and click the Languages button.  Change the language to reflect your current geographic location and click OK.

    Also, sign in tol http://account.live.com/ and make sure your address information (especially country) is correct.
    Thursday, February 28, 2008 7:15 PM

All replies

  • Try these ideas:

    Go into Internet Explorer and click Tools / Internet Options and click the Languages button.  Change the language to reflect your current geographic location and click OK.

    Also, sign in tol http://account.live.com/ and make sure your address information (especially country) is correct.
    Thursday, February 28, 2008 7:15 PM
  • Did you fix this problem.  I am trying to subscribe from Australia and can't because you can only put in a US state and postcode and phone number?

    Friday, February 29, 2008 6:15 AM
  • Did you try the instructions in my post above?

    Friday, February 29, 2008 8:15 PM
  • Also, delete cookies and temporary Internet files in IE and close all browser windows before proceeding with activation in OneCare.

     

    Additionally, if the LiveID is already associated with a Billing account, be sure that it is also correctly configured for your country - http://billing.microsoft.com

     

    And, contact support if all of the above does not resolve the problem.

    How to reach support (FAQ) - http://forums.microsoft.com/WindowsOneCare/ShowPost.aspx?PostID=2421771&SiteID=2

    -steve

    Friday, February 29, 2008 9:35 PM
    Moderator
  • Yes, but that did not work
    My address is Canada, and it says that when I look it up
    Why is this so difficult?
    Monday, April 14, 2008 5:57 PM
  •  Tony from Manitoba wrote:
    Yes, but that did not work
    My address is Canada, and it says that when I look it up
    Why is this so difficult?

    Tony,

    Try the following:

    1. Set Internet Explorer to be your default browser, if it isn't already, via Program Access and Defaults from Control Panel.

    2. Open IE and in Tools/Internet Options, verify that your language setting is correct for your country.

        If it is not, click "Add" to select your language and country combination from the list.

        Make that selection the default. It should appear at the top of the list.

        Remove or demote other entries that are not appropriate for your country.

    3. Delete cookies and temporary Internet Files from within IE.

    4. On the IE connections tab, make sure "automatically detect" is not selected for the LAN settings.

    5. Close IE.

    6. Open OneCare and proceed with activation.

     

    If the above still fails to bring you to the form for payment in your (supported) country, please contact support.

     

    How to reach support (FAQ) - http://forums.microsoft.com/WindowsOneCare/ShowPost.aspx?PostID=2421771&SiteID=2

     

    -steve

    Monday, April 14, 2008 6:08 PM
    Moderator