locked
Windows 7 Pro no more upgrading (error 0x8004FE21) RRS feed

  • Question

  • I have a Lenono T500 Thinkpad upgraded to Windows 7 Pro (64 bits) which has started acting up recently (error 0x8004FE21) after an important automatic update. I tried to restore it to a previous date, but that didn't correct the problem.

    Please, help me out on that. I thought that windows 7 is supposed to be stable, but it seems to be a common problem with various causes. I've red many pots on the matter and the solution differs in many cases. I don't want to worsen the problem by trying the different solutions proposed in these posts, this is why I'm posting the MCGDiag report like other posters did.

    Thanks for your help.

    See below the MCGDiag report:

    Diagnostic Report (1.9.0027.0):
    -----------------------------------------
    Windows Validation Data-->

    Validation Code: 0x8004FE21
    Cached Online Validation Code: 0x0
    Windows Product Key: *****-*****-MV8MH-98QJM-24367
    Windows Product Key Hash: wgci5Gdejx4esg7++zTOe3LWF+4=
    Windows Product ID: 55041-OEM-8992671-00437
    Windows Product ID Type: 2
    Windows License Type: OEM SLP
    Windows OS version: 6.1.7601.2.00010100.1.0.048
    ID: {B7CA0C14-156E-425E-A56B-DE2C3D1EB960}(1)
    Is Admin: Yes
    TestCab: 0x0
    LegitcheckControl ActiveX: N/A, hr = 0x80070002
    Signed By: N/A, hr = 0x80070002
    Product Name: Windows 7 Professional
    Architecture: 0x00000009
    Build lab: 7601.win7sp1_gdr.140303-2144
    TTS Error: 
    Validation Diagnostic: 
    Resolution Status: N/A

    Vista WgaER Data-->
    ThreatID(s): N/A, hr = 0x80070002
    Version: N/A, hr = 0x80070002

    Windows XP Notifications Data-->
    Cached Result: N/A, hr = 0x80070002
    File Exists: No
    Version: N/A, hr = 0x80070002
    WgaTray.exe Signed By: N/A, hr = 0x80070002
    WgaLogon.dll Signed By: N/A, hr = 0x80070002

    OGA Notifications Data-->
    Cached Result: N/A, hr = 0x80070002
    Version: N/A, hr = 0x80070002
    OGAExec.exe Signed By: N/A, hr = 0x80070002
    OGAAddin.dll Signed By: N/A, hr = 0x80070002

    OGA Data-->
    Office Status: 109 N/A
    OGA Version: N/A, 0x80070002
    Signed By: N/A, hr = 0x80070002
    Office Diagnostics: 025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3

    Browser Data-->
    Proxy settings: N/A
    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
    Default Browser: C:\Program Files (x86)\Google\Chrome\Application\chrome.exe
    Download signed ActiveX controls: Prompt
    Download unsigned ActiveX controls: Disabled
    Run ActiveX controls and plug-ins: Allowed
    Initialize and script ActiveX controls not marked as safe: Disabled
    Allow scripting of Internet Explorer Webbrowser control: Disabled
    Active scripting: Allowed
    Script ActiveX controls marked as safe for scripting: Allowed

    File Scan Data-->
    File Mismatch: C:\Windows\system32\wat\watadminsvc.exe[7.1.7600.16395], Hr = 0x80092003
    File Mismatch: C:\Windows\system32\wat\watux.exe[7.1.7600.16395], Hr = 0x80092003
    File Mismatch: C:\Windows\system32\sppobjs.dll[6.1.7601.17514], Hr = 0x80092003
    File Mismatch: C:\Windows\system32\sppc.dll[6.1.7601.17514], Hr = 0x800b0100
    File Mismatch: C:\Windows\system32\sppcext.dll[6.1.7600.16385], Hr = 0x800b0100
    File Mismatch: C:\Windows\system32\sppwinob.dll[6.1.7601.17514], Hr = 0x80092003
    File Mismatch: C:\Windows\system32\slc.dll[6.1.7600.16385], Hr = 0x800b0100
    File Mismatch: C:\Windows\system32\slcext.dll[6.1.7600.16385], Hr = 0x800b0100
    File Mismatch: C:\Windows\system32\sppuinotify.dll[6.1.7600.16385], Hr = 0x80092003
    File Mismatch: C:\Windows\system32\slui.exe[6.1.7601.17514], Hr = 0x80092003
    File Mismatch: C:\Windows\system32\sppcomapi.dll[6.1.7601.17514], Hr = 0x800b0100
    File Mismatch: C:\Windows\system32\sppcommdlg.dll[6.1.7600.16385], Hr = 0x800b0100
    File Mismatch: C:\Windows\system32\sppsvc.exe[6.1.7601.17514], Hr = 0x80092003
    File Mismatch: C:\Windows\system32\drivers\spsys.sys[6.1.7127.0], Hr = 0x80092003
    File Mismatch: C:\Windows\system32\drivers\spldr.sys[6.1.7127.0], Hr = 0x80092003
    File Mismatch: C:\Windows\system32\systemcpl.dll[6.1.7601.17514], Hr = 0x800b0100
    File Mismatch: C:\Windows\system32\user32.dll[6.1.7601.17514], Hr = 0x800b0100

    Other data-->
    Office Details: <GenuineResults><MachineData><UGUID>{B7CA0C14-156E-425E-A56B-DE2C3D1EB960}</UGUID><Version>1.9.0027.0</Version><OS>6.1.7601.2.00010100.1.0.048</OS><Architecture>x64</Architecture><PKey>*****-*****-*****-*****-24367</PKey><PID>55041-OEM-8992671-00437</PID><PIDType>2</PIDType><SID>S-1-5-21-265868336-3997470921-2762976582</SID><SYSTEM><Manufacturer>LENOVO</Manufacturer><Model>20552CU</Model></SYSTEM><BIOS><Manufacturer>LENOVO</Manufacturer><Version>6FET93WW (3.23 )</Version><SMBIOSVersion major="2" minor="4"/><Date>20121012000000.000000+000</Date></BIOS><HWID>52AA3B07018400F8</HWID><UserLCID>1009</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Eastern Standard Time(GMT-05:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM><OEMID>LENOVO</OEMID><OEMTableID>TP-6F   </OEMTableID></OEM><GANotification/></MachineData><Software><Office><Result>109</Result><Products/><Applications/></Office></Software></GenuineResults>  

    Spsys.log Content: 0x80070002

    Licensing Data-->
    Software licensing service version: 6.1.7601.17514

    Name: Windows(R) 7, Professional edition
    Description: Windows Operating System - Windows(R) 7, OEM_SLP channel
    Activation ID: 50e329f7-a5fa-46b2-85fd-f224e5da7764
    Application ID: 55c92734-d682-4d71-983e-d6ec3f16059f
    Extended PID: 00371-00178-926-700437-02-1033-7600.0000-2062009
    Installation ID: 015930923991332041946692403883356593886921335081451162
    Processor Certificate URL: http://go.microsoft.com/fwlink/?LinkID=88338
    Machine Certificate URL: http://go.microsoft.com/fwlink/?LinkID=88339
    Use License URL: http://go.microsoft.com/fwlink/?LinkID=88341
    Product Key Certificate URL: http://go.microsoft.com/fwlink/?LinkID=88340
    Partial Product Key: 24367
    License Status: Licensed
    Remaining Windows rearm count: 3
    Trusted time: 2014-09-22 12:04:19

    Windows Activation Technologies-->
    HrOffline: 0x8004FE21
    HrOnline: N/A
    HealthStatus: 0x000000000001EFF0
    Event Time Stamp: 9:19:2014 16:26
    ActiveX: Registered, Version: 7.1.7600.16395
    Admin Service: Registered, Version: 7.1.7600.16395
    HealthStatus Bitmask Output:
    Tampered File: %systemroot%\system32\sppobjs.dll
    Tampered File: %systemroot%\system32\sppc.dll|sppc.dll.mui
    Tampered File: %systemroot%\system32\sppcext.dll|sppcext.dll.mui
    Tampered File: %systemroot%\system32\sppwinob.dll
    Tampered File: %systemroot%\system32\slc.dll|slc.dll.mui
    Tampered File: %systemroot%\system32\slcext.dll|slcext.dll.mui
    Tampered File: %systemroot%\system32\sppuinotify.dll|sppuinotify.dll.mui
    Tampered File: %systemroot%\system32\slui.exe|slui.exe.mui|COM Registration
    Tampered File: %systemroot%\system32\sppcomapi.dll|sppcomapi.dll.mui
    Tampered File: %systemroot%\system32\sppcommdlg.dll|sppcommdlg.dll.mui
    Tampered File: %systemroot%\system32\sppsvc.exe|sppsvc.exe.mui
    Tampered File: %systemroot%\system32\drivers\spsys.sys


    HWID Data-->
    HWID Hash Current: OgAAAAEABQABAAIAAAABAAAABAABAAEAln1yezMUgIXkLLBULghxfibO6qNy/YS7YquecpiQsu1Gyg==

    OEM Activation 1.0 Data-->
    N/A

    OEM Activation 2.0 Data-->
    BIOS valid for OA 2.0: yes
    Windows marker version: 0x20001
    OEMID and OEMTableID Consistent: yes
    BIOS Information: 
      ACPI Table Name OEMID Value OEMTableID Value
      APIC LENOVO TP-6F   
      FACP LENOVO TP-6F   
      HPET LENOVO TP-6F   
      BOOT LENOVO TP-6F   
      MCFG LENOVO TP-6F   
      SSDT LENOVO TP-6F   
      ECDT LENOVO TP-6F   
      SLIC LENOVO TP-6F   
      ASF! LENOVO TP-6F   
      SSDT LENOVO TP-6F   
      TCPA
      SSDT LENOVO TP-6F   
      SSDT LENOVO TP-6F   
      SSDT LENOVO TP-6F   

    Monday, September 29, 2014 11:12 PM

Answers

All replies

  • Your report appears to indicate that Windows is activated, however you should not have any mismatches in the File Scan Data. Have you run the sfc /scannow and the re-run MGADiag again to see if those mismatches go away?
    Tuesday, September 30, 2014 2:22 PM
  • This may simply be caused by a bad set of Intel Rapid Storage Technology drivers - Installing the Intel Rapid Storage Drivers try downloading and installing them from here - https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&ProdId=2101&DwnldID=22194  (you want the iata_enu.exe download).   Once complete, please reboot twice, then post another MGADiag report.  

    Please do not read this sentence. Please ignore the previous sentence.

    Tuesday, September 30, 2014 2:31 PM
  • Kamin, I've seen this referenced before. Can you point me to where IRST was discovered to make Windows Activation malfunction?
    Wednesday, October 1, 2014 3:03 PM
  • No I cannot.  It happened before I joined this forum.  But I do know that it came about as a long and exhausting research exercise and has been used hundreds if not thousands of times here to fix activation problems.  The particular set of file mismatches OP has are symptomatic of the IRST issue.

    Please do not read this sentence. Please ignore the previous sentence.


    Wednesday, October 1, 2014 3:34 PM
  • It's doubtful that the IRST drivers are the specific cause - but installing them does fix better than 80% of the cases we see.

    Most of the remainder are cured by resetting the CatRoot2 folder - and the others we've never been able to find a fix for short of a repair install of the OS.

    Hope that helps?


    Noel Paton | Nil Carborundum Illegitemi
    CrashFixPC | The Three-toed Sloth
    No - I do not work for Microsoft, or any of its contractors.

    Wednesday, October 1, 2014 5:11 PM
    Moderator
  • I tried to run sfc.exe, but got the following message:

    "You must be an administrator running a console session in order to use the sfc utility"

    I'm logged as an administrator. What am I missing?

    Thanks

    Sunday, October 5, 2014 4:16 AM
  • I did download the iata_enu.exe file. But on the IRST web site, it is written:

    Purpose: 
    Installs the Intel® Rapid Storage Technology (RAID) driver version 11.7.0.1013.

    This driver supports RAID 0, 1, 5 and 10. The driver should be installed after the operating system has been installed. F6 and RAID BIOS configurations need to be performed prior to installation of this driver for proper operation.
     

    Do I have to mess up with the BIOS and if so how should I do that?

    Thanks

    Sunday, October 5, 2014 4:34 AM
  • 1) no - you don't need to touch the BIOS at all. The install also covers normal disk usage (it simply enables RAID fully as well). I have it installed on my laptop with no problems.

    2) All installs must be done using Administrator  privileges - do you have UAC switched off? If so, re-enable it and allow elevation when required. The 'Administrator Accounts' in Windows Vista and above only have full privileges at that time - otherwise they have reduced permissions to prevent the action of malware attempting to force-install unwanted programs.


    Noel Paton | Nil Carborundum Illegitemi
    CrashFixPC | The Three-toed Sloth
    No - I do not work for Microsoft, or any of its contractors.

    Sunday, October 5, 2014 5:52 PM
    Moderator
  • You seem to be running in a Standard User account - SFC must be run with Administrator privileges.

    SFC -System File Checker - Instructions

    Click on Start > All Programs > Accessories

    Right-click on the Command Prompt entry

    Select Run as Administrator and accept the UAC prompt
    - the Elevated Command Prompt window should pop up.

      

    At the Command prompt, type

    SFC /SCANNOW

    and hit the Enter key

     

    Wait for the scan to finish - make a note of any error messages - and then reboot.

     

    Upload the CBS.log file (compressed, please!) to your OneDrive or DropBox Public folder, and post a link - also post a new MGADiag report.



    Noel Paton | Nil Carborundum Illegitemi
    CrashFixPC | The Three-toed Sloth
    No - I do not work for Microsoft, or any of its contractors.

    Saturday, October 11, 2014 10:11 AM
    Moderator
  • Hello,

    I had the same problem after replacing my HDD bu an SSD. I tried several solutions found on various forums, unsuccessfully.

    Moreover, No update of windows was possible, and also the "capture tool" dincluded in Windows 7 did not work anymore.

    1 or 2 months ago, I found this solution related to Intel Rapid Storage Technology drivers.

    Of course I tried, and magically, everything is not working well, I don't have any error anymore, my windows is now "guenine", windows update and the "capture tool" work as before.

    I don't remember where I found the solution described here, but it really works.

    Thanks to all

    Jeanmicheu

    Sunday, October 12, 2014 10:28 PM