locked
Field Security Profile - Caller doesn't have Create privilege for attribute RRS feed

  • Question

  • Hi,

    I am experiencing big problem. I created field security profile. However I cannot update it.

    I tried everything I read about this in other threads:

    - I published all customizations for about 30 times

    - I removed and re-added the system user role

    - I've tried editing the permissions by using the original deployment admin

    and still no luck. I keep getting Caller 8c2b920e-92a5-e211-a906-005056ac11a4 doesn't have Create privilege for attribute '<attributename>' of entity '<entityname>'

    I have UR14 installed.

    Anyone has some solution to this problem?


    Thursday, December 26, 2013 8:38 AM

All replies

  • I had the same problem sometime back, I had to modify something in FieldPermission table directly in the database, this looks like CRM defect, I would suggest to enable SQL Profiler and trace what is going on... that will give you clear picture...
    Thursday, December 26, 2013 8:07 PM
  • I checked the db, still noting, I even applied the newest rollup (16) to see if something will change, but no luck.

    I still can't find solution to this problem. Does anyone have a suggestion?

    Monday, January 13, 2014 8:06 AM
  • If for some reason you can not update it, have you tried to simply create a new one with the changes you need and use that one instead of the existing one?

    Regards, Donna

    Thursday, January 23, 2014 7:13 PM