locked
Win 7 RTM loses WHS connection after sleep RRS feed

  • Question

  • Since installing Win 7 x64 as my primary OS, the connector to WHS "goes missing" almost always after resuming from sleep.  By this I mean that the WHS tray icon is gray.  If I log into the WHS and go into Backups, it appears the workstation is offline.  Restarting the connector service puts everything right again.  I did NOT see this behavior on the same hardware with XP SP3 (32-bit).

    Monday, August 31, 2009 6:47 PM

Answers

  • So I finally "fixed" this by creating a batch file to stop the WHS Connector service and then start it again.  I created a scheduled task that runs the batch file, with a trigger of a System Event Log entry from " Microsoft-Windows-Power-Troubleshooter", Event ID = 1.  I noticed this event gets entered into the log whenever the machine resumes from sleep.  So now, every time my machine wakes, it runs the batch file that restarts the WHS Connector service.  This kludge finally resolves my issue and VMWare works without incident.
    • Marked as answer by BGood2 Tuesday, September 8, 2009 7:22 PM
    Tuesday, September 8, 2009 7:21 PM

All replies

  • I run Windows 7 RTM x64 and mine does not have this problem.  Is your computer maybe powering off your NIC?  You can go into the properties of the NIC and uncheck the box.  Is the computer connected Wirelessly or wired to your WHS?
    Monday, August 31, 2009 6:59 PM
  • My computer uses a wired connection via Intel gigabit NIC.  I have verified that the connection lights on the NIC continue to operate during sleep.  It's really strange in that SOMETIMES it recovers from sleep and maintains the connection.  Very strange in its inconsistency.
    Monday, August 31, 2009 7:38 PM
  • Hi,
    sometimes the drivers or the router are guilty in such behavior.
    So you might try to get the most up to date drivers for the network card and the latest firmware for your router.
    It may also be worth a try to goto device manager, open the properties of the network adapter and on the power management tab disable the option, that the computer may power off the adapter to save energy.
    Best greetings from Germany
    Olaf
    • Marked as answer by BGood2 Tuesday, September 1, 2009 1:59 PM
    • Unmarked as answer by BGood2 Tuesday, September 1, 2009 2:00 PM
    Monday, August 31, 2009 8:09 PM
    Moderator
  • Olaf,

    I will try your suggestion to keep the NIC powered on.  Regarding your suggestion to update my NIC driver.  Funny you suggest that, because it was a NIC driver update from Microsoft that CAUSED worse behavior than I am reporting now.  The June 2009 driver caused my computer to wake from sleep within 10 seconds every time my computer tried to go into sleep mode.  Talk about frustrating.  The driver was offered to me in Windows Update, among a few others, and I had forgotten it had even been done.  I spent a lonnnnnng time trying to isolate the issue because the computer kept insisting the keyboard was waking the computer (powercfg -lastwake) and it turned out to the the NIC.  I rolled back the driver to the March 2009 version and no more sleep issues, except for this WHS connector problem.

    Thanks!
    Monday, August 31, 2009 8:24 PM
  • Well, I think the party to blame is still the maker of the drivers, who provided those to Microsoft. Microsoft is only the carrier who brings them to you as a convenient way to upgrade such stuff. We cannot expect, that they can themself test all drivers again based on available hardware.
    So it happens sometimes, that buggy drivers are rolled out, which should never have left the developement department of the hardware vendor.
    Best greetings from Germany
    Olaf
    Tuesday, September 1, 2009 7:43 AM
    Moderator
  • Well, I think the party to blame is still the maker of the drivers, who provided those to Microsoft. Microsoft is only the carrier who brings them to you as a convenient way to upgrade such stuff. We cannot expect, that they can themself test all drivers again based on available hardware.
    So it happens sometimes, that buggy drivers are rolled out, which should never have left the developement department of the hardware vendor.
    Best greetings from Germany
    Olaf
    Sorry for my choice of words.  Yes, I blame Intel.  Microsoft just made it easy for me to get the buggy driver!  That said, I've had WAY more issues, historically, accepting driver updates from Windows Update than I ever have getting them from the manufacturer directly.  I do not know why that is, but my rule is now NEVER to accept non-MS driver updates from Microsoft.  I chose not to follow my own rule when this Intel driver was offered for Win 7.

    Again, I cannot explain why there should be any difference, but I'm just not going to accept updates to non-MS drivers from Microsoft any longer.  Fair or unfair.  It's a rule-of-thumb that has served me well over the many years I've been supporting Windows.

    Finally, I took your advice and went into the NIC properties and turned off the computer's ability to put the NIC into low power state.  This DID resolve the problem; however, this morning I found a virtual machine running in VMWare was no longer detecting the network cable.  I'm still looking into this to see if there is a correlation.  It doesn't seem likely, but it was the only change I made yesterday and this was the first time I had this problem in VMWare.  I will test more today and post back.  But thanks for your suggestion, which DID seem to resolve my WHS connector issue.

    Regards

    Tuesday, September 1, 2009 2:06 PM
  • I seen the exact same behaviour on my system. All sorts of connection work fine (work in the WHS console, access to shares on WHS, even remote desktop connection to the WHS), but the WHS icon is gray instead of green (plus, in the WHS console, the client is shown as offline). Consequently, one cannot start a backup, and automatic backup doesn't work either.

    I also have an Intel gigabit chip in my Dell PC. I tried with the latest drivers directly from Intel, but the problem remains.

    On a laptop with Win 7 I don't see this behaviour, even though it connects to the same WHS via the same network (simple home network, with one gigabit switch under my desk). The laptop also has an Intel chipset, by the way. The laptop doesn't automatically backup either, by the way.

    I do not use any beta level WHS software (I can't, because my WHS came with the german WHS OS installed). However, my WHS is fully up-to-date as far as Windows Update is concerned.

    Power saving is enabled for the network connection, but this doesn't switch off the port, it merely reduces the transmission rate.

    Thankls and regards, Martin
    Wednesday, September 2, 2009 11:21 AM
  • So I finally "fixed" this by creating a batch file to stop the WHS Connector service and then start it again.  I created a scheduled task that runs the batch file, with a trigger of a System Event Log entry from " Microsoft-Windows-Power-Troubleshooter", Event ID = 1.  I noticed this event gets entered into the log whenever the machine resumes from sleep.  So now, every time my machine wakes, it runs the batch file that restarts the WHS Connector service.  This kludge finally resolves my issue and VMWare works without incident.
    • Marked as answer by BGood2 Tuesday, September 8, 2009 7:22 PM
    Tuesday, September 8, 2009 7:21 PM
  • I also just started seeing this issue after upgrading two of my machines (a Dell desktop and a Lenovo laptop) to Windows 7. The Dell machine has a Broadcom NetXtreme 57xx Gigabit controller and the Lenovo machine has an Intel 82566MM Gigabit controller. So I don't see that it is necessarily related to problems with Intel LAN drivers. I think it may be a more general Windows 7 issue. The Dell PC was just converted from Vista to Windows 7. This problem did not occur when it was running Vista. The Lenovo laptop is not set up to wake for backup, so there is no issue there; it was only tested to confirm that the problem does exist on different PCs running Windows 7.

    My symptoms are the same. If the WHS tray icon is running and green, showing that the machine is communicating with the server and the machine is then put into sleep mode and left there for a couple of hours, it will wake up without connectivity to the server via the WHS connector service. All other methods of communicating with the server function normally after waking; pings, remote desktop, server shares, WHS Console, etc. The upshot of this is if the PC wakes in the middle of the night to do a nightly backup it wakes up in this state with no communication via the WHS connector service, so it then goes back to sleep after 2 minutes without making a backup.

    After waking the machine I've left it sit for long periods of time to see what happens, and connectivity via the WHS Connector does not restore automatically. As noted in BGood2's post above, connectivity is immediately restored if you restart the WHS Connector service. The service shows as "Running" when the machine wakes but it is not functioning until after restarting it.

    Unless someone knows of a better way to fix this, I am thinking of adopting a different workaround. Instead of relying on automatic backups I will disable the "Wake this computer for Backup" task in the WHS connector and then create a Windows 7 scheduled task on the machine to wake it and run a backup from the command prompt. Backups initiated manually from a command prompt seem to run regardless of the state of connectivity via the WHS Connector. The scheduled task would wake the PC from sleep at 3 AM and run:
    "C:\Program Files\Windows Home Server\BackupEngine" -a
    Tuesday, September 8, 2009 11:55 PM
  • Well, my restart of the service worked pretty well for the past few weeks, but the past 3 nights my backup has failed.  Maybe a recent hotfix changed something, though I have not taken time to look at it.  The other thing I noticed was that restarting my service DID restore my connection to the WHS so that backups worked, *BUT* the service ALWAYS restarted and showed the little green icon.  Even when there was an error condition on the server.  In fact, there were several times when my XP machine showed a yellow WHS icon in the try or even a red one, but the icon on my Win 7 machine stayed green.  So, something is STILL not right with the connector service.  Note that all other functions relating to WHS seem to be working fine.

    So I guess I can try your command line "C:\Program Files\Windows Home Server\BackupEngine" -a and see if that works for me.
    Thursday, September 17, 2009 12:16 PM
  • BGood2:

    I've ended up adopting both solutions and after 10 days, connectivity to the server and daily backups have functioned reliably every day. Your technique of restarting the WHSConnector service is needed on Windows 7 machines that go into and out of sleep mode. Without this service restart workaround, the PCs wake up without connectivity to the server and the server thinks the PCs are offline. A manually started backup will still work with a PC in this state, but if you use the WHS console during the day, Win7 PCs show up as offline even though they are not.

    To implement your solution I didn't use a batch file; you can do it all with Windows 7 Task Scheduler. When setting up the task with the trigger as you described, simply add two actions; one is sc stop WHSConnector and the other is sc start WHSConnector, in that order.

    Still, I kept the daily scheduled task to start a backup manually at a specific time using "C:\Program Files\Windows Home Server\BackupEngine" -a so that the backup is performed at a time of my choosing. It's been working perfectly.
    Thursday, September 17, 2009 12:50 PM
  • Mark,

    Thanks for the feedback!  FWIW, I created a batch file so I could tweak settings in the batch file if I ever decided I needed a sleep timer or anything else added.  I was too lazy to want to keep entering my admin password over and over as I played with minor settings.

    The past 3 mornings, as soon as I awakened my PC from sleep, I noted the WHS icon was blue and showed it was doing a backup, but 0% complete.  It then failed.  It looks like my machine is waking now around 3:15 AM for backup, but it's not running.  This is after a few weeks of working very well (thought not 100%).

    I should add that I am running LightsOut 0.8.2 to save power on my server.  I have the client portion installed so that the WHS wakes whenever a client PC wakes.  The LightsOut uptime chart shows the WHS is running during the 2 AM - 5 AM daily window, so I don't think the server is unavailable.

    If I opt to run the command
    "C:\Program Files\Windows Home Server\BackupEngine" -a
    from a scheduled task, do I go into the WHS console and turn off the automatic backups for this one machine?

    Also, have you noticed at all that restarting the service after sleep always seems to show the green icon as if all is well?  I see this pretty much always, even though I log into the WHS console and sometimes see a yellow or red status.  That's why I was not sure restarting the service was the complete answer.
    Thursday, September 17, 2009 10:46 PM
  • If I opt to run the command
    "C:\Program Files\Windows Home Server\BackupEngine" -a
    from a scheduled task, do I go into the WHS console and turn off the automatic backups for this one machine?
    Or you can do it from the tray icon. Right-click and uncheck "Wake this computer for backup".

    I've only had my WHS box up for less than two months and in that time have gradually iterated towards the solution that works best for me. I started with automatic backups but had problems with an XP machine that doesn't support S3 sleep state, so that PC gets backed up manually from a scheduled task running on the server. Vista machines worked fine with automatic backups but when they were updated to Windows 7 I ran into this connectivity issue after waking from sleep. So I've finally ended up with a network where automatic backups are now disabled on all PCs. Each PC is scripted to wake up and run its own backup at a time of my own choosing.
    Also, have you noticed at all that restarting the service after sleep always seems to show the green icon as if all is well?  I see this pretty much always, even though I log into the WHS console and sometimes see a yellow or red status.  That's why I was not sure restarting the service was the complete answer.
    I just tested this by disabling AV software on a PC to make the Network Status Critical (red icon). After waking from sleep the tray icon was grayed out (no connectivity). Upon restarting WHSConnector the icon immediately turned red as it should have. Re-enabling AV software turned the tray icon green again. So restarting the service appears to work here.
    Thursday, September 17, 2009 11:41 PM
  • Like my approach, yours worked great for a few days.  Then no so great.  I keep having backup failures when this runs as a scheduled task coming out of sleep.  If I manually run the scheduled task, it works fine.  I'm still also seeing the WHS icon as green, but when I log into the console I see the status is really yellow or red.  My XP machine has kept backing up just fine.  The issue is only with this machine running Win 7 Ultimate x64.  The interesting this I noticed yesterday was that when I logged out from my regular user account and logged in on my admin account, the WHS icon immediately changed to yellow.  Not sure if there is some authentication issue at work with this icon.

    Anyway, I guess all I can do is live with this until WHS PP3 is released and hope it works better.  If I didn't know that WHS was actually a good, capable backup tool and if I were just testing WHS right now, I'd probably abandon the entire thing.

    I also could reconsider Win 7 since I'm still facing challenges with various apps not working properly.

    I guess I will stay with it a while longer, but like with Vista, I'm seeing lots of reasons to revert to XP.
    Wednesday, September 23, 2009 1:15 PM
  • BGood2:

    On your scheduled tasks under Security Options , have you checked the box "Run with highest privileges"? As an alternative, if you usually run an account that is not a member of the Admin group, have you tried changing the user in the scheduled task to "System"?
    Wednesday, September 23, 2009 1:48 PM
  • I did check the box to "Run with highest privileges", but I have not tried changing the user to "System".  The weird thing is that when I first set it up, it ran great for 3 consecutive days.  I had not installed any new software during that period.  So I'm unsure why it should work well for a few days and then get flaky.  I will try changing to "System".  I appreciate your continuing assistance!
    Wednesday, September 23, 2009 1:59 PM
  • I have same problem with my home built computer.  The problem started after changing OS from Vista32 to Win7 64-bit. 

     

    I’ve tried:

    Changing Network List Service from manual to automatic.

    Setting WHSTraAPP to run in Vista Compatibility mode.

    Re-installed WHS connector.

    Setting task in admin account to stop and start WHSConnector on trouble-power event.

    Today I turned off network adapter power management.  I will find out tomorrow morning if this works.

     

    Manual backup works fine and I can open my backups from WHS console. 

     

    Hate posting but I wanted to join this crowd.

    Wednesday, November 4, 2009 4:23 AM
  • I am seeing this same issue with two separate machines after installing Windows 7.  The machines have much in common, Attansic L1 gigabit NICs, 3-series Intel chipsets (1 G35, 1 P35) and both by ASUS.  I believe it is related to the NICs, so I put a Netgear gigabit PCI in the P35, and used a USB-LAN on the G35.  Tomorrow morning I should see if this helps.

    Brent
    Thursday, November 5, 2009 2:16 AM
  • Both systems backed up correctly last night, so my testing leads me to believe that the problem is NIC realated.

    Brent
    Friday, November 6, 2009 12:32 AM
  • My connector has not lost connection since I turned of the network adapter power management.  I am sure the issue with the WHSTrayAPP (task bar WHS connector) going gray is with the Win7 network adapter driver.  I am happy with just turning off the network adapter power management for my desk top PC.  The backup not running is a known issue with Win7/WHS to be fixed in WHS PP3. I wrote a task to wake up my computer at midnight and keep it awake for two hours.  So far auto backup has worked.

     

    Not very green but this solution above should work until WHS PP3 is released. 

     

    I am not thrilled that Microsoft did not have all their ducks in a row before the release of Win7 especially with all the folks out there doing beta testing on both Win7 and WHS PP3.  AppleL could use this fact in their Win7 slam commercials.  Windows can’t backup Windows but if you’re a Mac your data is safe on HP WHS.

     

    Microsoft fix the bugs first then add features for the WHS.  Every body needs a reliable backup but we all don’t need new features. 

    Friday, November 6, 2009 3:55 AM
  • My connector has not lost connection since I turned of the network adapter power management.  I am sure the issue with the WHSTrayAPP (task bar WHS connector) going gray is with the Win7 network adapter driver.  I am happy with just turning off the network adapter power management for my desk top PC.  The backup not running is a known issue with Win7/WHS to be fixed in WHS PP3. I wrote a task to wake up my computer at midnight and keep it awake for two hours.  So far auto backup has worked.

     

    Not very green but this solution above should work until WHS PP3 is released. 

     

    I am not thrilled that Microsoft did not have all their ducks in a row before the release of Win7 especially with all the folks out there doing beta testing on both Win7 and WHS PP3.  Apple L could use this fact in their Win7 slam commercials.  Windows can’t backup Windows but if you’re a Mac your data is safe on HP WHS.

     

    Microsoft fix the bugs first then add features for the WHS.  Every body needs a reliable backup but we all don’t need new features. 

    Turning off Power Management didn't work for me.  The computer will at least go back to sleep though.  I've had the odd automatic backup work, even though the icon is gray.
    Saturday, November 7, 2009 11:49 PM
  • My connector has not lost connection since I turned of the network adapter power management.  I am sure the issue with the WHSTrayAPP (task bar WHS connector) going gray is with the Win7 network adapter driver.  I am happy with just turning off the network adapter power management for my desk top PC.  The backup not running is a known issue with Win7/WHS to be fixed in WHS PP3. I wrote a task to wake up my computer at midnight and keep it awake for two hours.  So far auto backup has worked.

     

    Not very green but this solution above should work until WHS PP3 is released. 

     

    I am not thrilled that Microsoft did not have all their ducks in a row before the release of Win7 especially with all the folks out there doing beta testing on both Win7 and WHS PP3.  Apple L could use this fact in their Win7 slam commercials.  Windows can’t backup Windows but if you’re a Mac your data is safe on HP WHS.

     

    Microsoft fix the bugs first then add features for the WHS.  Every body needs a reliable backup but we all don’t need new features. 

    Turning off Power Management didn't work for me.  The computer will at least go back to sleep though.  I've had the odd automatic backup work, even though the icon is gray.

    I only turned off power manager on the network interface device.  My computer still goes to sleep.  It just does not  power down the NIC card.

     

    I would insert a snapshot if I could figure out how.   Sorry to hear you are still having problems.  Mine is still backing up every night and the connector has not lost connection.
    Sunday, November 8, 2009 3:37 PM
  • Turning off Power-Save on my NIC worked for me.
    Tuesday, November 17, 2009 12:01 AM
  • Installation of PowerPack 3 Final appears to have solved this issue for me.
    Thursday, November 26, 2009 8:26 PM