DB error during install of server RRS feed

  • Question

  • I get the following in the error log during installation of the server component, and it comes up with error 25000.

    Any idea what I am missing, I have created the appropiate login on the SAL server and given it dbcreator and securityadmin roles.




    Extracting database model...
    Extracting database deployment manifest...
    Extracting pre and post deployment scripts...
    Writing database deployment parameters...
    Beginning database deployment ...
    An unexpected failure occurred: Object reference not set to an instance of an object.

    An error occurred while creating the database.
    Error 25000. An error occurred while creating the database. View the installation log for additional information.
    MSI (s) (F0!18) [04:12:38:904]: Product: Microsoft Dynamics ERP Management Reporter Server -- Error 25000. An error occurred while creating the database. View the installation log for additional information.

    Action ended 4:12:39: DeployDatabase. Return value 3.
    Action ended 4:12:39: INSTALL. Return value 3.


    Wednesday, September 15, 2010 11:25 AM

All replies

  • Hi Carsten,


    This is an issue with the new install that some machines need SQL Server Compact Edition. This should be posted as a KB today or tomorrow.

    Download Microsoft SQL Server Compact 3.5 Service Pack 2 for Windows Desktop from the following link:



    Note: On a 64-bit Computer, first install the 32-bit and then the 64-bit version of the SQL Server Compact 3.5 SP2 MSI files.



    • Proposed as answer by Corey Clay Wednesday, October 13, 2010 4:32 PM
    Wednesday, September 15, 2010 4:04 PM
  • Is this posted yet as a KB yet Ryan? I hadn't found anything on PartnerSource and then found this post via Google search. It looks to have fixed my problem so it was definitely useful.


    Corey Clay, MCS
    Nextec Group, Inc.
    Wednesday, October 13, 2010 4:32 PM
  • Corey,


    It has been posted, yes.


    All important info and updates should be posted here:


    This landing page will then link to the actual download pages.



    Monday, October 18, 2010 10:18 PM
  • We continue to get this error trying to install MR SP1 and everything is by the book. We have what looks like SP 2 for Compact SQL to the right administrator rights to the right ASP settings. We are now on the better part of a day trying to solve this and still can't even get it to create the initial database before it bombs.
    Friday, October 29, 2010 4:27 PM
  • I am having the same issue. I had had MR w/o the service pack and had finally managed to get it running, however due to the bugs in it, tried to do the SP. It requires that you uninstall MR, then upgrade the db (didn't work but got vague error messages). I completely uninstalled and deleted the MR database and tried to start from scratch, but am getting the same errors you are. I also did the download for SP2 for Compact SQL. At a loss at this point. Any suggestions are appreciated!
    Friday, October 29, 2010 10:57 PM
  • These files should resolve the error. If it is a 64-bit machine you may have to install both the 64 and 32-bit components. Be sure you are running these files from the machine you are trying to run the install from for the Application Server.

    If you still receive the error please submit a support ticket and we can remote in to review why these aren't taking.



    Tuesday, November 2, 2010 1:25 PM
  • Ryan -

    We continue to try and get MR With SP1 installed and the installation still bombs while trying to create the database. Same errors. We unloaded the Compact SQL 32-bit SP2 since everytime we tried to install it said we had a later version and looked like it took both the 32 and 64 bit Compact SP2 installs. Our Add/Remove shows everything by the book but still  getting the 250000 error with the can't access "internal error : sqlcemanager could not be initialized.


    Tuesday, November 2, 2010 7:33 PM
  • The "Internal Error: Sqlcemanager could not be initialized." message from the installation is typically caused when you install the 64-bit SQL Compact before the 32-bit version.
    Best regards,

    Kelly Bjella
    Partner Online Technical Community
    We hope you get value from our new forums platform! Tell us what you think:
    This posting is provided "AS IS" with no warranties, and confers no rights
    Friday, November 12, 2010 4:08 PM