locked
WHS Remote Access to Win 7 Pro RRS feed

  • Question

  • I have upgraded my primary desktop to Win 7 Pro 64 bit.  I have always been able to access this machine with Vista Ultimate through my homeserv.com portal.  But now with Win 7, I'm having issues that I haven't been able to fix.  The Win 7 computer is listed on the computer list, and it says "Available for Connection" but when I click on it, and connect, it takes about 15 seconds, and I get this message: "Cannot connect to your home computer. Check your network connection and make sure your home computer is not blocked by a firewall".

    I have Power Pack 3 installed,  I have "allow connections from running any version of Remote Desktop" selected on the Win 7 machine.  I can RDC to other computers and I can RDC to the Win7 machine with no problems.  The other computers on my Remote Access list work fine also.  It's only using remote access to get to the Win 7 64 bit machine that is the problem.

    The only firewall I have running is Windows firewall, but that should have been configured automatically, but perhaps the firewall isn't configured correctly.    I tried turning off Windows firewall, and that didn't change anything.

    I need to be able to access my desktop remotely because I run a business out of my home, and I'd hate to have to roll back to Vista just because of this.  But there must be other people with a similar problem.

    Any ideas from anyone?

    Tuesday, May 10, 2011 2:07 AM

Answers

  • I figured this out.

    Maybe I should have known this, but I never saw it documented anywhere.  But apparently you can't have the same computer name but with a different operating system.  My old computer still had saved backups, thus it appeared in the computer list with Vista Ultimate with it's computer name.  My new computer had the exact same name but was listed with Win 7 Pro.  I guess that's a no no.

    Once I changed the name of my new Win 7 Pro computer, I was then able to remote access successfully.

    Moral of the story: if you change your operating system, change your computer name.  Or remove your old backups saved under your original computer name.

    Thanks for the help.

    • Marked as answer by Pratt9 Wednesday, May 11, 2011 4:20 AM
    Wednesday, May 11, 2011 4:20 AM

All replies

  • Right click on my computer in Win 7 and click properties, then Remote Settings.  Under the Remote Desktop settings, you have three choices. Ensure the correct "Allow" box is checked for your situation.  You may have to change to the "less" secure one.


    _______________

    BullDawg
    In God We Trust
    _______________
    <Pratt9> wrote in message news:ce5f89b4-e956-4c73-8b00-0622d3fdac6d@communitybridge.codeplex.com...

    I have upgraded my primary desktop to Win 7 Pro 64 bit. I have always been able to access this machine with Vista Ultimate through my homeserv.com portal. But now with Win 7, I'm having issues that I haven't been able to fix. The Win 7 computer is listed on the computer list, and it says "Available for Connection" but when I click on it, and connect, it takes about 15 seconds, and I get this message: "Cannot connect to your home computer. Check your network connection and make sure your home computer is not blocked by a firewall".

    I have Power Pack 3 installed, I have "allow connections from running any version of Remote Desktop" selected on the Win 7 machine. I can RDC to other computers and I can RDC to the Win7 machine with no problems. The other computers on my Remote Access list work fine also. It's only using remote access to get to the Win 7 64 bit machine that is the problem.

    The only firewall I have running is Windows firewall, but that should have been configured automatically, but perhaps the firewall isn't configured correctly. I tried turning off Windows firewall, and that didn't change anything.

    I need to be able to access my desktop remotely because I run a business out of my home, and I'd hate to have to roll back to Vista just because of this. But there must be other people with a similar problem.

    Any ideas from anyone?


    BullDawg
    Tuesday, May 10, 2011 12:03 PM
  • Thanks for the tip....but that option is already checked.
    Tuesday, May 10, 2011 2:18 PM
  • Couple of others to check.

    Date, time, and time zone on Win 7.
    Network discovery is on.


    _______________

    BullDawg
    In God We Trust
    _______________
    <Pratt9> wrote in message news:2b557ea3-c61a-4eb6-84ad-a77048524cb9@communitybridge.codeplex.com...

    Thanks for the tip....but that option is already checked.


    BullDawg
    Tuesday, May 10, 2011 10:05 PM
  • The Date,Time is a good one...that was actually the first thing I checked, but that is good.  And Network discovery is on.

    Like I said, I've been remote accessing my computer with Vista Ultimate for a while without any problems, and nothing has changed other than a new motherboard and Win 7 Pro.  I can remote desktop both ways without a problem, but when I remote access through WHS..."Cannot connect......make sure your home computer is not blocked by a firewall...".    Could the settings be wacked with Windows Firewall?  I never do anything with that and turning if off didn't help.

    Thanks

     

    Wednesday, May 11, 2011 1:39 AM
  • I'm just as stumped as you.  If I think of anything else, I will chime in again.


    _______________

    BullDawg
    In God We Trust
    _______________
    <Pratt9> wrote in message news:ce69b7a3-dcd0-422f-b1fb-25b880f54d51@communitybridge.codeplex.com...

    The Date,Time is a good one...that was actually the first thing I checked, but that is good. And Network discovery is on.

    Like I said, I've been remote accessing my computer with Vista Ultimate for a while without any problems, and nothing has changed other than a new motherboard and Win 7 Pro. I can remote desktop both ways without a problem, but when I remote access through WHS..."Cannot connect......make sure your home computer is not blocked by a firewall...". Could the settings be wacked with Windows Firewall? I never do anything with that and turning if off didn't help.

    Thanks


    BullDawg
    Wednesday, May 11, 2011 3:04 AM
  • I figured this out.

    Maybe I should have known this, but I never saw it documented anywhere.  But apparently you can't have the same computer name but with a different operating system.  My old computer still had saved backups, thus it appeared in the computer list with Vista Ultimate with it's computer name.  My new computer had the exact same name but was listed with Win 7 Pro.  I guess that's a no no.

    Once I changed the name of my new Win 7 Pro computer, I was then able to remote access successfully.

    Moral of the story: if you change your operating system, change your computer name.  Or remove your old backups saved under your original computer name.

    Thanks for the help.

    • Marked as answer by Pratt9 Wednesday, May 11, 2011 4:20 AM
    Wednesday, May 11, 2011 4:20 AM