locked
Vista Ultimate 64-bit: Unable to search for updates. RRS feed

  • Question

  • I have had a copy of Windows Vista Ultimate 64-bit for a couple of years now. I purchased it from a well-known online retailer as an OEM or "system builder's" pack. I have been running this whole time with no issues...until sometime between January 13th and now, since that's the last time it checked for updates.

    First, I ran into an issue where, at login, my desktop went black and it claimed my software wasn't genuine. I got that fixed, but now it won't check for updates. It throws error code 80070426.

    Thank you in advance for any and all assistance provided.

    Below is a copy of my WGA Validation tool result:

    Diagnostic Report (1.9.0019.0):
    -----------------------------------------
    WGA Data-->
    Validation Status: Genuine
    Validation Code: 0

    Cached Validation Code: N/A, hr = 0x80070426
    Windows Product Key: *****-*****-TKMJD-MCPJM-HFYCB
    Windows Product Key Hash: q6xHYsROW+Ocz5DBmSW/lF/z74U=
    Windows Product ID: 89587-OEM-7300585-70058
    Windows Product ID Type: 3
    Windows License Type: OEM System Builder
    Windows OS version: 6.0.6002.2.00010100.2.0.001
    ID: {9129CA74-9DF4-40D4-98CA-8DC2F399856B}(3)
    Is Admin: Yes
    TestCab: 0x0
    WGA Version: N/A, hr = 0x80070002
    Signed By: N/A, hr = 0x80070002
    Product Name: Windows Vista (TM) Ultimate
    Architecture: 0x00000009
    Build lab: 6002.vistasp2_gdr.090803-2339
    TTS Error:
    Validation Diagnostic:
    Resolution Status: N/A

    WgaER Data-->
    ThreatID(s): N/A, hr = 0x80070002
    Version: N/A, hr = 0x80070002

    WGA Notifications Data-->
    Cached Result: N/A, hr = 0x80070002
    File Exists: No
    Version: N/A, hr = 0x80070002
    WgaTray.exe Signed By: N/A, hr = 0x80070002
    WgaLogon.dll Signed By: N/A, hr = 0x80070002

    OGA Notifications Data-->
    Cached Result: N/A, hr = 0x80070002
    Version: N/A, hr = 0x80070002
    OGAExec.exe Signed By: N/A, hr = 0x80070002
    OGAAddin.dll Signed By: N/A, hr = 0x80070002

    OGA Data-->
    Office Status: 101 Not Activated
    Microsoft Office Enterprise 2007 - 101 Not Activated
    OGA Version: N/A, 0x80070002
    Signed By: N/A, hr = 0x80070002
    Office Diagnostics: B4D0AA8B-604-645_025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3

    Browser Data-->
    Proxy settings: N/A
    User Agent: Mozilla/4.0 (compatible; MSIE 7.0; Win32)
    Default Browser: C:\Program Files (x86)\Mozilla Firefox\firefox.exe
    Download signed ActiveX controls: Prompt
    Download unsigned ActiveX controls: Disabled
    Run ActiveX controls and plug-ins: Allowed
    Initialize and script ActiveX controls not marked as safe: Disabled
    Allow scripting of Internet Explorer Webbrowser control: Disabled
    Active scripting: Allowed
    Script ActiveX controls marked as safe for scripting: Allowed

    File Scan Data-->

    Other data-->
    Office Details: <GenuineResults><MachineData><UGUID>{9129CA74-9DF4-40D4-98CA-8DC2F399856B}</UGUID><Version>1.9.0019.0</Version><OS>6.0.6002.2.00010100.2.0.001</OS><Architecture>x64</Architecture><PKey>*****-*****-*****-*****-HFYCB</PKey><PID>89587-OEM-7300585-70058</PID><PIDType>3</PIDType><SID>S-1-5-21-447579575-1148592816-822162173</SID><SYSTEM><Manufacturer>.  </Manufacturer><Model>.  </Model></SYSTEM><BIOS><Manufacturer>Phoenix Technologies, LTD</Manufacturer><Version>6.00 PG</Version><SMBIOSVersion major="2" minor="5"/><Date>20080530000000.000000+000</Date></BIOS><HWID>F6303507018400F8</HWID><UserLCID>0409</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Pacific Standard Time(GMT-08:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM/><GANotification/></MachineData><Software><Office><Result>101</Result><Products><Product GUID="{91120000-0030-0000-0000-0000000FF1CE}"><LegitResult>101</LegitResult><Name>Microsoft Office Enterprise 2007</Name><Ver>12</Ver><Val>9AC2D9EE48C06D4</Val><Hash>kPpEHZK3WehYZcYssdfGMrNz5so=</Hash><Pid>81599-874-7528382-65662</Pid><PidType>1</PidType></Product></Products><Applications><App Id="15" Version="12" Result="101"/><App Id="16" Version="12" Result="101"/><App Id="18" Version="12" Result="101"/><App Id="19" Version="12" Result="101"/><App Id="1A" Version="12" Result="101"/><App Id="1B" Version="12" Result="101"/><App Id="44" Version="12" Result="101"/><App Id="A1" Version="12" Result="101"/><App Id="BA" Version="12" Result="101"/></Applications></Office></Software></GenuineResults> 

    Spsys.log Content: 0x80070002

    Licensing Data-->
    Software Licensing service is not running.

    Windows Activation Technologies-->
    N/A

    HWID Data-->
    HWID Hash Current: PAAAAAIABgABAAEAAQABAAAAAwABAAEAln3G7gz5jj3KzTpfKiGI/XTm4l/imwD68vQka8YO3ImsVkbK

    OEM Activation 1.0 Data-->
    N/A

    OEM Activation 2.0 Data-->
    BIOS valid for OA 2.0: yes, but no SLIC table
    Windows marker version: N/A
    OEMID and OEMTableID Consistent: N/A
    BIOS Information:
      ACPI Table Name    OEMID Value    OEMTableID Value
      APIC            IntelR        AWRDACPI
      FACP            IntelR        AWRDACPI
      MCFG            IntelR        AWRDACPI


    Thursday, February 18, 2010 3:51 AM

Answers

  • Hello josh.m

      The problem is that your Vista's Software Licensing Service has stopped. Vista uses this service to check itself and confirm it is Genuine. When the service is stopped, Vista is unable to confirm it's own Genuine status and may show Genuine or Non-Genuine. The fact that the Service has stopped is also, most likely, the cause of other issues you may be experiencing (such as not having access to the Control Panel).

      Normally this is not a big problem, since you can just restart the Service. However, we have seen a number of users that receive an error when they attempt to restart the Service. This indicates a more serious 'root cause' to the service having stopped.

      What I would like you to do is to try to restart the service using the 'Service Restart' steps, below. If the service won't restart, you will receive an error.

     

    Service Restart steps:

    (If you have access to the Start button):

    1)    Click the Start button

    2)    Type: cmd in the Start Search field

    3)    At the top the Start window, you will see cmd.exe

    4)    Right Click cmd.exe and select Run as Administrator

    5)    Type: net start slsvc

     

    (If you do not have access to the Start button):

    1)    Click the option that launches an Internet Browser

    2)    A Browser will open, type: %windir%\system32 into the address field

    3)    Find the file cmd.exe

    4)    Right Click on the cmd.exe and select Run as Administrator

    5)    Type: net start slsvc

     

    A)   If the error message is "System Error 3, The system cannot find the path specified." or "System Error 2, The system cannot find the file specified": Go to the main Vista Validation forum page http://social.microsoft.com/Forums/en-US/genuinevista/threads/, look in the announcement section and follow the steps found in thread "Fix for ‘Software Licensing service Has Stopped’ on some Vista 64bit systems"

     

    B)   If you receive any other error (System Error 5, System Error 57346 or System Error 54273): These occur as a result of massive file corruption.  We do not know what the root cause of the corruption is and this can be caused by any situation where files could be corrupted. However, from troubleshooting others that had this issue, the likeliest causes are either Malware Infection or failing Hard Drive. The only resolution we can suggest is reinstall Vista.

     

    C)   If you receive no System Error and the Service start but then stops almost immediately: Something is apparently activity stopping the service. Most likely caused by some other dependent Windows Service or possibly a Malware infection. While the Software Licensing Service, itself, is part of the Anti-piracy sub-system, the running (and stopping) of Windows Services is a Vista core system that I have no insight to and is supported by Vista support at http://support.microsoft.com

    Thank you,
    Darin MS

    • Marked as answer by Darin Smith MS Thursday, February 18, 2010 10:03 PM
    Thursday, February 18, 2010 10:03 PM

All replies

  • Hello josh.m

      The problem is that your Vista's Software Licensing Service has stopped. Vista uses this service to check itself and confirm it is Genuine. When the service is stopped, Vista is unable to confirm it's own Genuine status and may show Genuine or Non-Genuine. The fact that the Service has stopped is also, most likely, the cause of other issues you may be experiencing (such as not having access to the Control Panel).

      Normally this is not a big problem, since you can just restart the Service. However, we have seen a number of users that receive an error when they attempt to restart the Service. This indicates a more serious 'root cause' to the service having stopped.

      What I would like you to do is to try to restart the service using the 'Service Restart' steps, below. If the service won't restart, you will receive an error.

     

    Service Restart steps:

    (If you have access to the Start button):

    1)    Click the Start button

    2)    Type: cmd in the Start Search field

    3)    At the top the Start window, you will see cmd.exe

    4)    Right Click cmd.exe and select Run as Administrator

    5)    Type: net start slsvc

     

    (If you do not have access to the Start button):

    1)    Click the option that launches an Internet Browser

    2)    A Browser will open, type: %windir%\system32 into the address field

    3)    Find the file cmd.exe

    4)    Right Click on the cmd.exe and select Run as Administrator

    5)    Type: net start slsvc

     

    A)   If the error message is "System Error 3, The system cannot find the path specified." or "System Error 2, The system cannot find the file specified": Go to the main Vista Validation forum page http://social.microsoft.com/Forums/en-US/genuinevista/threads/, look in the announcement section and follow the steps found in thread "Fix for ‘Software Licensing service Has Stopped’ on some Vista 64bit systems"

     

    B)   If you receive any other error (System Error 5, System Error 57346 or System Error 54273): These occur as a result of massive file corruption.  We do not know what the root cause of the corruption is and this can be caused by any situation where files could be corrupted. However, from troubleshooting others that had this issue, the likeliest causes are either Malware Infection or failing Hard Drive. The only resolution we can suggest is reinstall Vista.

     

    C)   If you receive no System Error and the Service start but then stops almost immediately: Something is apparently activity stopping the service. Most likely caused by some other dependent Windows Service or possibly a Malware infection. While the Software Licensing Service, itself, is part of the Anti-piracy sub-system, the running (and stopping) of Windows Services is a Vista core system that I have no insight to and is supported by Vista support at http://support.microsoft.com

    Thank you,
    Darin MS

    • Marked as answer by Darin Smith MS Thursday, February 18, 2010 10:03 PM
    Thursday, February 18, 2010 10:03 PM
  • What a simple fix. Thank you, Darin, for providing such an easy solution. Everything works well now.

    - Joshua
    Friday, February 19, 2010 3:04 AM