locked
401.1 Unauthorized \w CRM 2011 on SBS 2008 RRS feed

  • Question

  • I am trying to create a development environment based on SBS 2008 with SQL and CRM on that same machine. I did all the installations and tried to go on the website http://[mycomputer]:5555. It prompts me for the username and pwd which I set to NETWORK SERVICE and blank. This is what I used for all the "Service Accounts". The website pulls up with the left and top showing up as expected. However, the center section has "Server Error in Application Microsoft Dynamics CRM". Http Error 401.1 - Unauthorized.

    Modulce WindowsAuthenticationModue
    Notification AuthenticateRequest
    Error Cod 0x8009030c
    Logon Methos Not yet determined
    Logon User Not Yet determined
    Requested URL http://[servername]:5555/crm/workplace/home_dashboards.aspx?pagemode=iframe

    I checked that the _MSCRM database has NETWORK SERVICE as the db_owner and that the server is listed under SQLAccessGroup (thinking that it's a database issue as the top and left menu showed up). I tried to check that NETWORK SERVICE is added to CRM_WPG but I can't find where that is done on SBS2008 (there is no Local Users and Groups under Comptuer management, the group is neither listed in the SBS Console nor in Group Policy Manager as far as I can tell).

    Sunday, September 16, 2012 5:39 PM

All replies

  • I looked at some other places and then revisited the CRM_WPG group. I finally found the folder in "Active Directory Users and Computers"->[domain].local->MyBusiness->Users->SBSUsers. Then under "Members" I tried to add NETWORK SERVICES but it was not listed. I guess this does not qualify as a user or group. I then just added Network Administrator after which the CRM website pulled up correctly. I wanted to verify that indeed this change made it work so I removed Network Administrator again. After closing IE and opening it the website still did come up. It also still worked after rebooting the server. I doubt this is being cached so I am really not sure what made it work as I haven't made any other changes.
    Sunday, September 16, 2012 8:29 PM