locked
Plugin Registration tool: Server Application Unavailable RRS feed

  • Question

  • I do the following actions in my plugin registration tool:

    1. Add Webreferences
    2. Web Services on the local machine
    3. I click CrmService

    And it gives me this message:

    Server Application Unavailable
    The web application you are attempting to access on this web server is currently unavailable.  Please hit the "Refresh" button in your web browser to retry your request.

    Administrator Note: An error message detailing the cause of this specific request failure can be found in the application event log of the web server. Please review this log entry to discover what caused this error to occur.

    Anyone any idea what I can do?

    Tuesday, May 19, 2009 12:12 PM

Answers

  • Hi brosimba,

       Try using the the IP address of the server in the registration tool and in the references to the MS CRM Webservices instead of the machine name.

    This fixed the problem for me when I got the same message.

    Hassan.

    Hassan Hussain | http://hassanhussain.wordpress.com/
    • Proposed as answer by Hassan Hussain Tuesday, May 19, 2009 12:24 PM
    • Marked as answer by brosimba Tuesday, May 19, 2009 12:40 PM
    Tuesday, May 19, 2009 12:24 PM

All replies

  • Hi brosimba,

       Try using the the IP address of the server in the registration tool and in the references to the MS CRM Webservices instead of the machine name.

    This fixed the problem for me when I got the same message.

    Hassan.

    Hassan Hussain | http://hassanhussain.wordpress.com/
    • Proposed as answer by Hassan Hussain Tuesday, May 19, 2009 12:24 PM
    • Marked as answer by brosimba Tuesday, May 19, 2009 12:40 PM
    Tuesday, May 19, 2009 12:24 PM
  • Hi Hassan,

    It didn't work yet for me. Unless I did it wrong.

    So this  http://localhost/MSCRMServices/2006/CrmService.asmx will become http://[IP]/CrmService.asmx

    Or did I do that wrong?

    Tuesday, May 19, 2009 12:34 PM

  • Yes you are. Please change it to the URL below. Are you using MS CRM v3 OR v4?

    The URL below is for v4
    http://<servername[:port]>/mscrmservices/2007/crmservice.asmx

    H.

    Hassan Hussain | http://hassanhussain.wordpress.com/
    Tuesday, May 19, 2009 12:36 PM
  • It worked. Thanks again Hassan.
    Tuesday, May 19, 2009 12:40 PM