SyncToy failure due to drive-letter change of backup drive RRS feed

  • Question

  • SyncToy doesn't seem to handle the drive-letter changing for the backup drive of the archive destination "Right Folder". I am running SyncToy to backup files to an external USB hard-drive from my laptop (Windows XP). When I first created the archive, the USB drive was assigned the letter "F". Since then, depending on what other USB devices are connected to my laptop, the backup diskdrive may connect as drive letter "H", in which case SyncToy doesn't find it and gives error of failure when I run the backup: "Failed to execute folder pair XXX. Could not locate folder F:\xxx\." I request the ability to override the drive letter, or to have it scan more broadly. (I'm using SyncToy I use the "Echo" setting.)  Actually it may handle the drive letter changing between F & G, but not between F & H, I think.

    Monday, June 21, 2010 7:54 PM

All replies

  • I also had a failure to recognize a new drive letter.  To fix it, first I tried going through the steps to rename the drive from the new letter to the old one that ST was accustomed to seeing.  When I tried to run the sync, though, even then it refused to run the sync.  The path was exactly correct, the drive was definitely relettered, visible, and browsable, but I got the same error message (Failed to execute folder pair / could not locate folder).  I wonder if there was any possibility there was a driver assigned to that path from before if there was an improper hardware removal in past, I don't know.

    I'm not sure why the drive letter was different, I thought the situation was identical to before, not sure, but I think I got around it by doing a full power shutdown and restart.   Still, the drive letter recognition feature does not seem to be failproof.

    Saturday, June 26, 2010 6:50 PM