none
Problem with full bare metal restore

    Question

  • Hello,

    I tried to perform a full bare metal restore and it always fails with an error "ERROR:  Could not load VDS".

    I created the USB WinPE restore from the WHS tools menu and all nightly backups are reported as successful.

    The PC to be restored is Windows 7 Ultimate x64.

    Anyone has an explanation or solution?

    Thursday, August 23, 2012 1:59 PM

All replies

  • Hello All,

    Well, I figured it out.

    My WHS 2011 server had to be tweeked.

    1. Enable the "COM+ Network Access (DCOM-In)" firewall inbound rule
    2. Enable the "COM+ Remote Administration (DCOM-In)" firewall inbound rule
    3. Enable the "Remote Volume Management - Virtual Disk Service (RPC)" firewall inbound rule
    4. Enable the "Remote Volume Management - Virtual DIsk Service Loader (RPC)" firewall inbound rule
    5. Enable the "Remote Volume Management (RPC-EPMAP)" firewall inbound rule

    I also played around with the "COM+ System Application"service, but with no definite conclusion as to it has to be enable or not.

    So my problem is fixed, but the real question is : Why do these firewall rules and service were not set appropriately with a standard WHS install?
    Is there some other settings that need to be set to enable these correctly?

    Please, all of you WHS gurus, can you provide a sound explanation?

    • Marked as answer by myriaxis Saturday, August 25, 2012 1:48 AM
    • Unmarked as answer by myriaxis Saturday, September 01, 2012 12:27 AM
    Saturday, August 25, 2012 1:47 AM
  • I got the same problem.  The system I am trying to restore is XP Pro - I don't think the issue is on that side somehow.  Just enabled the 5 firewall rules - still get the failure though.  Am I missing something?  A reboot perhaps?  Should not have to

    Rebooting the server did not help.  Starting the COM+ System Application service did not help.  Feeling really disappointed to be let down by this product when I need it most - to restore!!!  Completely unable to a this point...

    Rich


    Saturday, August 25, 2012 9:05 PM
  • Hello Rich,

    You're absolutely right. The 5 firewall rules and the COM+ aren't the solution. I unmarked my response as an answer.

    I had to restore another computer today and got the same "Could not load VDS" and "Failed to initialize VDS" errors.

    Googling the "Failed to initialize VDS" brought me to this post http://forum.home-server-blog.de/viewtopic.php?f=72&t=18375.

    Using google translate, I gather that the problem seems to be related to a volume size mismatch between the source and the target.

    Honestly, I don't know. After many retries, the restore started magically without any change to the WHS 2011 configuration.

    I guess it follows the moto: If at first you don't succeed, then try again, and again, and again ...

    Francois

    • Proposed as answer by wjg2012 Thursday, November 08, 2012 8:26 PM
    • Unproposed as answer by wjg2012 Thursday, November 08, 2012 8:26 PM
    Saturday, September 01, 2012 12:39 AM
  • Had same issue.  Found when I selected "I will select the volumes to restore (advanced)" it gave me a pop-up error window that basically said I didn't have any initialized hard drives (installed a new hd).  Message continued stating to run disk manager (advanced) in the full system restore wizard.  Clicked ok and there was a button on the bottom that gave me the option to "Run Disk Manager (advanced).  That launched the Disk Management module and gave me the option to create partitions.  Created partitions equal to the original partitions sizes. (the system partition hiccuped when I chose 100MB.  2nd time I chose 105MB and it seems to be working)  I did not bother formatting.  I've got the progress bar running and the HD is lit up.  Hoping this finishes successfully.

    Josh

    Thursday, November 08, 2012 8:31 PM