Disable fields RRS feed

  • Question

  • Hi all,


    I was trying to assign a default value to the owner field and then to disable it

    so i have tried the following code to disable the field



    but after doing the field has been disabled but the owner name is still accessible which means that the user data still accessible


    the question is:

    how to completly disable the field so that no body can click on the user name to access the data


    any help will be appreciated,


    thanks in advance :)

    Wednesday, October 6, 2010 11:49 AM


All replies

  • I don't want it to be inaccessible

    I want it to be a read only field


    thanks for your efforts

    Wednesday, October 6, 2010 12:14 PM
  • i don't which part of my scenario is weird ??!!!


    i want the owner field to be a read only field !!!!!

    Wednesday, October 6, 2010 12:21 PM
  • This weired part could break the security as i think that users data must not be accessible for anybody


    Wednesday, October 6, 2010 12:35 PM
  • It doesn't need any explanation if you click on the field contents it will open the user form and you'll be able to its data
    Wednesday, October 6, 2010 12:42 PM
  • may be Mostafa telling that if the field is disabled, and if you will click on the record(hyperlinked) it will open the record.

    Am i right Mostafa?


    Wednesday, October 6, 2010 12:57 PM
  • I can see that you never heard about security at all...this data must not even be read dude

    Ok. I see. I wish you luck, Mostafa. I will never disturb you on this forum.

    Microsoft CRM Freelancer

    My blog (english)
    Мой блог (русскоязычный)
    Wednesday, October 6, 2010 12:59 PM
  • Andriy is correct, you need to amend their access to the User entity in their security role. You can do this via Settings\Administration\Security Roles, open the role to configure and set up access to the User entity on on the Business Management tab. If you set it up correctly, when they click on the Owner link on the form, they will be presented with a "Permission denied" page.
    Neil - My CRM Blog
    Wednesday, October 6, 2010 1:00 PM
  • yes, that's right sudhansu


    have any idea about how to do this ???

    Wednesday, October 6, 2010 1:12 PM
  • Dear Neil,

    what do you mean by correctly ???

    Wednesday, October 6, 2010 1:20 PM
  • if i am right, thanks.

    but i hope the concept of read only(disable) is that you can see the value but can not edit it in that level.

    so the lookup value in the form level you can not edit and you can see the values so the hyPerlinked is enabled.

    but still let me put a try on it.


    Wednesday, October 6, 2010 1:45 PM
  • That's really your call. Although the minimum permission you can set is this - http://imgur.com/UwEzL.jpg

    If you do not want them to even read user accounts, you could use javascript in the User entity on-load to hide all fields/tabs on the user form if the user is in a certain role. This post should help you get started with this - http://post.ly/mVB4

    Neil - My CRM Blog
    Wednesday, October 6, 2010 1:51 PM
  • You could simply hide the lookup (like Andriy suggested) and then create a new field (nvarchar) in which you show the data from the lookup-field.

    Wednesday, October 6, 2010 1:59 PM
  • Dear sudhansu,

    i need that the  field and its hyperlink are disabled so that the user cannot open the form in which the user data are shown


    thanks for your efforts :)

    Wednesday, October 6, 2010 3:49 PM
  • My approach doesn't work for you either?
    Wednesday, October 6, 2010 4:02 PM
  • Dear boert,


    thanks alot for your effort,

    but i think i will use your approche as plan B

    Wednesday, October 6, 2010 4:13 PM
  • I have answered your post in the Developer forum with the following information:  http://crmentropy.blogspot.com/2010/10/disable-links-in-lookup-field.html
    Dave Berry - MVP Dynamics CRM - http:\\crmentropy.blogspot.com
    Wednesday, October 6, 2010 7:53 PM
  • Thanks alot David, you're the best
    Thursday, October 7, 2010 8:56 AM
  • david thanks for the work around.

    Thursday, October 7, 2010 9:09 AM