locked
Changing the URL of the Remote login page RRS feed

  • Question

  • I rather a novice at understanding in-depth configurations of IIS, so please be patient! :)

    I purchased a domain name and a SSL Cert from Godaddy when I built my WHS, lets say that domain and cert are for remote.mydomain.com. I configured WHS, thru the wizard, to use this domain subsite and domain name. When I goto https://remote.mydomain.com/ I get page cannot be displayed. When I goto http://www.mydomain.com I get "There is a problem with this websites security certificate." and if I hit continue to the website, it takes me to the remote login page at https://www.mydomain.com/remote.

    So it seems that for some reason, even though the wizard shows remote.mydomain.com as the url, somewhere the system is still pointing to www.mydomain.com/remote. How can I resolve this issue?

    Thanks in advance for your help!

    Rich

    Wednesday, June 13, 2012 12:49 PM

Answers

  • So I found out finally thru reasearch the WHS2k11 wizard and GoDaddy do not play well together, even though it is supposed to work. After numerous calls with tech support with both companies, I finally found the answer thru the forums. Here are the solutions:

    On my Notes:

    1. create a certificate request from ->IIS7->Server certificates.  (Make sure you create a 2048 bit)

    - saVE it as a txt file so you can copy the contents later.

    2.  purchase a standard SSL Certificate from a provider (GoDaddy, or Network Solutions), and go to the process of aquiring the certificate.

    -Once the certificate is approve and ready to download from go daddy, YOu will need to install the certificate to the following location.

    -Please follow this guide: Installing an SSL Certificate in Microsoft IIS 7http://support.godaddy.com/help/article/4801/installing-an-ssl-certificate-in-microsoft-iis-7

    This should take care of website error certificate. As for the RDP issues on the machines inside your network, you will have issues connecting stating an error on a gateway certificate.

    To solve that issue, do the following

    3.  Add additional role on your server "Remote Desktop Services", make sure to select "Remote Desktop Gateway" and go through the wizard.  Make sure to select your GoDaddy Certificate.

    Once installed, you can try your remote access from a browser outside your network.

    Apologize for not being specific as the steps depend on the Certificate provider, but you should focus your research in this area.

    BTW, should you buy an SSL Certificate at GoDaddy, use this promo code to get a great discount "PromoSSL".

    • Marked as answer by RWWilkins Thursday, July 12, 2012 7:54 PM
    Thursday, July 12, 2012 7:54 PM

All replies

  • Hi Rich, I hope you have followed the correct steps to setup RWA in WHS2011:

    Windows Home Server 2011 Learning Bites - Remote Web Access

    http://www.youtube.com/watch?v=YgZDa5QF25I

    You can check if the option in the wizard "Get a peronalized domain name from Microsoft" works.

    Also check if the client can access the server internally, eg. https://server or https://192.168.0.100


    Sean Zhu

    TechNet Community Support

    Wednesday, June 20, 2012 6:22 AM
  • Thanks for the response Sean. Yes, I went thru the wizard for remote access setup. I can actually connect remotely using https://www.mydomain.com/remote. However, this is not the URL or domain that I setup thru the wizard. I had chosen remote.mydomain.com and bought a certificate for that url thru godaddy. So my problem is the server, even though I have the wizard configured to point to remote.mydomain.com, is still associating https://www.mydomain.com/remote as the remote URL. The personalized domain name from Microsoft won't help me as I wish to utilize my own domain name.
    Wednesday, June 20, 2012 11:59 AM
  • So I found out finally thru reasearch the WHS2k11 wizard and GoDaddy do not play well together, even though it is supposed to work. After numerous calls with tech support with both companies, I finally found the answer thru the forums. Here are the solutions:

    On my Notes:

    1. create a certificate request from ->IIS7->Server certificates.  (Make sure you create a 2048 bit)

    - saVE it as a txt file so you can copy the contents later.

    2.  purchase a standard SSL Certificate from a provider (GoDaddy, or Network Solutions), and go to the process of aquiring the certificate.

    -Once the certificate is approve and ready to download from go daddy, YOu will need to install the certificate to the following location.

    -Please follow this guide: Installing an SSL Certificate in Microsoft IIS 7http://support.godaddy.com/help/article/4801/installing-an-ssl-certificate-in-microsoft-iis-7

    This should take care of website error certificate. As for the RDP issues on the machines inside your network, you will have issues connecting stating an error on a gateway certificate.

    To solve that issue, do the following

    3.  Add additional role on your server "Remote Desktop Services", make sure to select "Remote Desktop Gateway" and go through the wizard.  Make sure to select your GoDaddy Certificate.

    Once installed, you can try your remote access from a browser outside your network.

    Apologize for not being specific as the steps depend on the Certificate provider, but you should focus your research in this area.

    BTW, should you buy an SSL Certificate at GoDaddy, use this promo code to get a great discount "PromoSSL".

    • Marked as answer by RWWilkins Thursday, July 12, 2012 7:54 PM
    Thursday, July 12, 2012 7:54 PM