locked
OCS server-client connectionproblem RRS feed

  • Question

  • Hellow everybody,

    I'm an IT student and I'm working on a project. My task is to make a voipsetup using OCS 2007.

    Until now I have 2 virtual machines running. One with Windows Server 2003 R2 and one running Windows XP SP3.

    I've managed to install and configure my server with OCS :

    - the server is active directory controller (voip.be)
    - I've configured the dns server with a a-record for the pool (pool1) and the srv record for automatic client login
    - I've installed SQL 2005 SP1 and created an instance
    ...

    Actually I've did everything using the OCS configurationwizard and now are all OCS services up and running.

    After that I've created a new user and enabled the user for OCS use. When I open OCS I see the user in the userslist.

    On my virtual client (Windows XP SP3) I've installed the OC client.
    I've added my client to the voip.be domain. I can also ping from my client to my server and from my server to my client.

    But when I try to logon with my client using the frontname.surname@voip.be I get the following error :

    "Cannot sign in because the server is temporalt Unavailable..."

    So I went to tools-->configuration-->advanced and changed from automatic configuration to manual configuration using the
    ipaddress of my server.

    When I select TCP I get the same error, when I select TLS the client complains about :

    "There was a problem verifying the certificatie from the server..."

    When I check that on my server I see 2 certificates made bij the OCS wizard so I don't think that's the problem.

    When I open the OCS control panel I see : Default certificate settings:
    voipserver.voip.be checked green.

    But I also read : No client's found in the pool.

    Now how do I add a client to my pool?

    When I check my logs is see the following error :

    "Exchange Unified Routing Application did not find any Exchange UM server."

    Is that really necessary  to make a connection between my server and client?

    I hope I gave enough information to find a solution for my problem.

    Thanks in advance!

    Saturday, October 18, 2008 5:54 PM

Answers

  • If you want to test without all the TLS pre-requisites you have to first enable it on the Front-End server.

    Go to your Front-End Server properties, General, Connections. Make sure you have the following interfaces configured:
    "All     5060    TCP"
    "All     5061    MTLS"

    Once you have this configured you can configure your communicator client to connect to your Front-End Server using the IP Address and TCP.

    If this is working you can go ahead and configure your communicator client for TLS. Now it's important to have your certificates deployed correctly. For example you cannot configure your communicator client with an IP Address for the server and choose TLS, this will never work. If you connect to the server using TLS you have to connect as voipserver.voip.be as this is the common name configured on your certificate. You also have to make sure that the issuer of that certificate is trusted by your XP workstation.

    Other troubleshooting steps could be:
    - Make sure you have configured the correct SIP address on your user. You may be logging in with frontname.surname@voip.be but it may actually be something else. Check the user properties for the SIP Address
    - verify the eventlogs, sometimes they reveal a bit more information to what's is going wrong. Go into Communicator Options, General and enable the checkbox "Turn on Windows Event Logging for Communicator"

    Hope this get's you any further...

    Tonino Bruno




    Sunday, October 19, 2008 1:46 PM

All replies

  • The OCS log also complains about this error :
    "Configuration indicates that the load balancer deployed for this pool operatis in Source Nat(SNAT). However, if the load balancer is operating in Destination NAT (DNAT) mode then functionality in this pool may be broken"

    Since I"m using a virtual environment I'm not making use of a load balancer.

    In the OCS wizard I've chosen "Depoly Pools in a Consolidated Topology".

    Sunday, October 19, 2008 9:29 AM
  • If you want to test without all the TLS pre-requisites you have to first enable it on the Front-End server.

    Go to your Front-End Server properties, General, Connections. Make sure you have the following interfaces configured:
    "All     5060    TCP"
    "All     5061    MTLS"

    Once you have this configured you can configure your communicator client to connect to your Front-End Server using the IP Address and TCP.

    If this is working you can go ahead and configure your communicator client for TLS. Now it's important to have your certificates deployed correctly. For example you cannot configure your communicator client with an IP Address for the server and choose TLS, this will never work. If you connect to the server using TLS you have to connect as voipserver.voip.be as this is the common name configured on your certificate. You also have to make sure that the issuer of that certificate is trusted by your XP workstation.

    Other troubleshooting steps could be:
    - Make sure you have configured the correct SIP address on your user. You may be logging in with frontname.surname@voip.be but it may actually be something else. Check the user properties for the SIP Address
    - verify the eventlogs, sometimes they reveal a bit more information to what's is going wrong. Go into Communicator Options, General and enable the checkbox "Turn on Windows Event Logging for Communicator"

    Hope this get's you any further...

    Tonino Bruno




    Sunday, October 19, 2008 1:46 PM
  • The tcp connection wassen't configured yet. Now I can make a connection betweem my client and server.

    Thanks for the advice Bruno!
    Monday, October 20, 2008 11:47 AM