locked
Addressbook synchronization issue with office communicator 2007. RRS feed

  • Question

  • Hi all

     

    I am using office communicator 2007.

    I am having problem with client machine and server for addressbook synchronization.I am getting the following message:

     

    cannot synchronize with the corporate address book.This may be because the proxy server setting in your web browser does not allow access to the address book.If the problem persists, contact your system administrator.

     

     

    I have tried a lot but not able to solve the problem.I have searched out on net for this problem but could not get solution.so Please help me.

     

     

    Thanks in Advance

    Sunil Sharma

    Wednesday, January 23, 2008 11:25 AM

Answers

  • Hi

     

    I resolved this issue as follows

     

    1) Open OCS Admin Console and click on your Pool Name - now on the right hand side you will see a status of your OCS deployment.

    2) Expand AddressBook Server Setting and check what is entered next to "File Share Location for Internal Connections"

    Before I fixed this problem this was set to: https://poolname.xx.yy.zz/abs/int/handler

     

    As we use a proxy server this was getting resolved to an external web address and thus it was failing. So I changed this to  https://poolname/abs/int/handler

     

    But I was still getting the same error.  Then I checked my Certificate name it was poolname.xx.yy.zz therefore it did not trust poolname on its own.

     

    Luckly my certificate alternative name was not a FQDN and was just servername so I changed the "File Share Location for Internal Connections" to https://servername/abs/int/handler

     

    To change the name follow the instructions on the OSCPedia site and the other answers in this thread.

     

    So in a nutshell this name must not be a FQDN with xx.yy. as the proxy sees the dots and thinks it is an external website and make sure the Non FQDN name matches the certificate you are deploying.

     

    Hope this helps

     

    Dhiren

     

     

    Monday, February 25, 2008 6:21 PM

All replies

  • Are you receiving the erro message from internal or external clients?

     

    There are quite a few threads in this forum regarding similiar issues with internal client that you might want to look for.  If it's external clients, then have you configured an HTTP reverse proxy to allow access to the ABS files?

    Wednesday, January 23, 2008 6:57 PM
    Moderator
  • HI

     

    I am getiing the error message from internal client.

    Thursday, January 24, 2008 6:08 AM
  • OK, start with this post recent post:

    http://forums.microsoft.com/unifiedcommunications/ShowPost.aspx?PostID=2734499&SiteID=57

     

    And search the forums as there are tons of thread covering this exact topic, many in the last couple months alone.  It's a common issue that is usually related to some mis-configuration or deviation from the deployment guide's recommendations.

    Thursday, January 24, 2008 1:40 PM
    Moderator
  • Hi,

     

     

    Earlier problem resolved, I again installed ocs 2007.Now on server address book is synchronized.But on the client side I am getting the given below error message for Address book synchronization:

     

    can not synchronize with corporate address book becuase the  file could  not be found.Contact your system administrator.

     

     

    Please also help me how we can download address book on the client side.This is the internal client.

     

    Regards

    Sunil Sharma

    Monday, January 28, 2008 7:27 AM
  • Hi Sunil,

     

    Go through the following link to check if the address book server setting is right or not!...

     

    http://www.ocspedia.com/ABS/Steps.htm

     

    If the mentioned steps is done!.. there shouldn't be any problem downloading the address book on the client side. If you still face the problem, do share with me.

     

     

    Ram K Ojha
    MCSE 2003 - Messaging, MCTS- (LCS 2005 & OCS 2007)
    http://www.OCSPedia.com
    http://www.ITCentrics.com

     

    Monday, February 4, 2008 12:50 AM
  • Hi Sunil,

     

    this problem occurs because the password of the RTCComponentService account expired. When setting the flag in AD "password never expires", the problem will be resolved (reboot of server required). Also mind the RTCService account. You need to perform simular steps for this account. Of course I assume you left the default accounts in place when installing/configuring OCS.

     

    Regards,

     

    Wim

    Monday, February 4, 2008 7:34 PM
  • Hi

     

    I resolved this issue as follows

     

    1) Open OCS Admin Console and click on your Pool Name - now on the right hand side you will see a status of your OCS deployment.

    2) Expand AddressBook Server Setting and check what is entered next to "File Share Location for Internal Connections"

    Before I fixed this problem this was set to: https://poolname.xx.yy.zz/abs/int/handler

     

    As we use a proxy server this was getting resolved to an external web address and thus it was failing. So I changed this to  https://poolname/abs/int/handler

     

    But I was still getting the same error.  Then I checked my Certificate name it was poolname.xx.yy.zz therefore it did not trust poolname on its own.

     

    Luckly my certificate alternative name was not a FQDN and was just servername so I changed the "File Share Location for Internal Connections" to https://servername/abs/int/handler

     

    To change the name follow the instructions on the OSCPedia site and the other answers in this thread.

     

    So in a nutshell this name must not be a FQDN with xx.yy. as the proxy sees the dots and thinks it is an external website and make sure the Non FQDN name matches the certificate you are deploying.

     

    Hope this helps

     

    Dhiren

     

     

    Monday, February 25, 2008 6:21 PM