locked
Slow speed in WHS but only on one of the drives ??? RRS feed

  • Question

  • I have a 2.5 GHz with 2gb DDR2 Memory with GB-LAN in my whs It has a 120gb SATA2 system disk and 2 1tb SATA2 and a 500gb SATA2 drive in it "BUT"
    and here is the weird part only on of the 1000gb disk is slow I have already run a diagnose on the disk and I know that it is running SATA2 "3GB/S" and there is nothing wrong with the disk all test are fine.
    When I copy A file and it put the data on any of the other disk I have speeds of 5-65000kb/s but on this one it's around 3500-3750kb/s.
    All the disk is useing the motherboards sata2 ports

    the this are as:

    HITACHI DESKSTAR    HDS722580                System disk         --> works fine
    Seagate                      ST31000528AS            storage                  -->works fine
    Seagate                      ST3500320SA              storage                  -->works fine
    Samsung                    HD103SI                      storage                  --> very slow speed

    Tuesday, November 24, 2009 3:27 AM

Answers

  • I have fixed it thanks for the help it was the ATA controller that had reduced the speed on the HD to PIO mode 1

    Here is a workaround to fix it

     

     

    WORKAROUND - How to move transfer mode from PIO back to UDMA

    To re-enable the UDMA mode for an affected device:
    1. Double-click Administrative Tools, and then click Computer Management.
    2. Click System Tools, and then click Device Manager.
    3. Expand the IDE ATA/ATAPI Controllers node.
    4. Double-click the controller (typically Primary IDE Channel) for which you want to restore the typical DMA transfer mode.
    5. Click the Driver tab.
    6. Click Uninstall.
    7. When the process completes, restart your computer. When Windows restarts, the hard disk controller is re-enumerated and the transfer mode is reset to the default value for each device that is connected to the controller.

     

    Thanks for your help

    Tuesday, November 24, 2009 8:05 PM

All replies

  • Could be the drive is running in PIO mode. Please checkout this thread and this one and this one.

     If your disk controller has dropped back to PIO mode, it's been detecting errors from your disks for a while, and has been stepping back the disk access mode to try to compensate. This usually indicates a problem either with one or more disks attached to the controller, or with the controller itself. After correcting the problem please run chkdsk on all disks in your server
    • Edited by brubberModerator Tuesday, November 24, 2009 7:43 AM added some more info
    Tuesday, November 24, 2009 7:39 AM
    Moderator
  • Could be the drive is running in PIO mode. Please checkout this thread and this one and this one.

     If your disk controller has dropped back to PIO mode, it's been detecting errors from your disks for a while, and has been stepping back the disk access mode to try to compensate. This usually indicates a problem either with one or more disks attached to the controller, or with the controller itself. After correcting the problem please run chkdsk on all disks in your server

    how do I correct this??

    Thnaks for replying
    Tuesday, November 24, 2009 5:50 PM
  • First, read the threads brubber has linked for you and try the remedies and workarounds mentioned in them.

    If that doesn't do it, then you replace the component that's failing. Usually it's a disk drive. If several of your drives have all stepped back to PIO mode, then it may be the controller, which is often integrated on your motherboard. It's also possible for a loose connector, weak power supply, etc. to cause this issue.
    I'm not on the WHS team, I just post a lot. :)
    Tuesday, November 24, 2009 6:16 PM
    Moderator
  • How do I correct this??

    Thnaks for replying

    Have a look at item 7.2 or if this fails 7.1 on this page. Alternatively you can search the web for "disk running in PIO mode" or something similar.
    Tuesday, November 24, 2009 7:49 PM
    Moderator
  • I have fixed it thanks for the help it was the ATA controller that had reduced the speed on the HD to PIO mode 1

    Here is a workaround to fix it

     

     

    WORKAROUND - How to move transfer mode from PIO back to UDMA

    To re-enable the UDMA mode for an affected device:
    1. Double-click Administrative Tools, and then click Computer Management.
    2. Click System Tools, and then click Device Manager.
    3. Expand the IDE ATA/ATAPI Controllers node.
    4. Double-click the controller (typically Primary IDE Channel) for which you want to restore the typical DMA transfer mode.
    5. Click the Driver tab.
    6. Click Uninstall.
    7. When the process completes, restart your computer. When Windows restarts, the hard disk controller is re-enumerated and the transfer mode is reset to the default value for each device that is connected to the controller.

     

    Thanks for your help

    Tuesday, November 24, 2009 8:05 PM