locked
CRM 4 installation errors RRS feed

  • Question

  • Hi, we've been trying to install CRM on our server for the past 3 days with luck. Everytime we run the wizard there seems to be an error, at the moment we've gone back a step (part of the initial install that was working now isn't).

    We click the "Install Microsoft Dynamics CRM Server" from the autorun sequence on the CD.
    Click the "Update installation files (strongly recommended)" but have tried the "Do not update installation files" too.
    Put our licence key in
    Click to accept the licence agreement
    Get told we don't have "Microsoft Visual C++ Runtime" installed even though we do (v8.0.56336, v9.0.21022, v9.0.30729.17)
    Click to install it (again)
    Says successfully installed version 8.0
    Click Next
    Get the following error: "The specified module could not be found. (Exception from HRESULT: 0x8007007E)" - have google'd it with no luck.

    Anyone got any ideas or points in the right direction?

    Thanks, Tom
    Friday, February 5, 2010 6:23 PM

All replies

  • Tom,

    On the C++ you will get that message everytime, it doesn't check/remember that it is already installed so you can take that off the list as errors, you are getting the message everyone gets.

    The other one is a little more challenging.

    Question - where did you get the installation code? I have seen situations where the code on the install CD can give you this kind of error.

    Or did you get it online at: http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=a9c110fd-aac8-4d2a-b401-7801b1866e82

    Jerry http://www.crminnovation.com
    Friday, February 5, 2010 6:45 PM
  • Hi Viper IT,

    You say that you have tryed to install on the server multiple times. If this is correct the error could be that you have to clean up everything before trying to install again. Delete the Microsoft Dynamics CRM folder. Chect the SQL Server to see if there are any "left overs", from a previously install.

    I ran into a simmilar error some times ago, and that was the problem.
    Henrik Jensen Instructor / Consultant MCP, MCAD, MCSD, MCTS, MCPD, MCITP, MBSS, MBSP, MCT www.crmblog.dk (Danish only)
    Friday, February 5, 2010 9:46 PM
  • I'm having the same issue, but I'm upgrading from 3.0 to 4.0.  Did this ever get solved?  The server has no Internet access so I'm running with a config file parameter via cmd.  Corrupt installation code?
    Wednesday, March 23, 2011 1:56 AM